View Single Post
      07-13-2012, 08:13 AM   #1
Marvelousone
Enlisted Member
1

 
Marvelousone's Avatar
 
Drives: 2009 135i
Join Date: Dec 2009
Location: Toronto, ON


Posts: 41
iTrader: (1)

Unhappy Car Pulling To Left Hard - Out of Options?!

Early last summer I purchased some Hankook V12's on VMR 701 rims from a local, reputable tire shop. Leaving the shop I noticed that the car was slightly pulling to the left, but thought screw it, I'm getting coilovers in the next month or so, and I'll get an alignment and be ok.

Installed the coilovers a month or so later, got the alignment from a local shop, and no difference. The car pulls to the left slightly on normal roads, but at speeds over 100kph (on highway) it constantly requires correcting. This is especially bad in the left or middle lanes.

Fast forward to this summer, the winters come off, summers go back on, and again, itís pulling. Yesterday I take it to BMW for an overpriced alignment, and they basically say thanks for paying, we made slight adjustments however the problem is still there. They believe it's the tire itself (front, driver side).

I take it to the local tire shop, they Road Force Balance all tires and everything seems ok, but they say maybe due to uneven wear, the tire is screwed, so I say ok, and purchase a new tire because at this point, I have no idea what else to do. Anyways, problem is still there, car is still pulling to the left.

It's been aligned by 2 shops, and has a brand new front left tire, and still pulls....can ANYONE tell me what this may be?

Thanks!!
__________________
2009 135i AT / CF Trim / ACS Pedals / Alpine HID 7000K / ST Coilovers / BMS DCI / VMR v701 18"/215/40 18"/245/35