View Single Post
      07-13-2012, 02:51 PM   #10
Marvelousone
Enlisted Member
Marvelousone's Avatar
1
Rep
41
Posts

 
Drives: 2009 135i
Join Date: Dec 2009
Location: Toronto, ON

iTrader: (1)

Thanks guys for all replying. I'll try to answer some of the suggestions as best I can.

Ken - The alignment was done first at Altech motors, which I actually learned about on the forum. The second time it was done at BMW (yesterday). BMW as well as Altech checked to make sure everything was tight. The tires, without doubt are cheap, but were sourced from Tires23, which is also a reputable local vendor, which I'm sure many in the GTA go to. Buying tires is an option....but I'm honestly scared that after another thousand bucks, it'll be an issue still. And as for buying more parts....thatís the last thing I want to think about right now....even if itís a good idea

Dackel - I totally forgot to mention that BMW did swap left and right tires, and noticed the pull changed to the right side instead of the left. Thatís why they said itís most likely the left front tire. Now of course it could be (and would suck) the front right tire instead...

In2str - BMW said they checked all 4 wheels for tightness, now I know thatís just what they are saying so if I happen to get it up on a lift sometime soon, I'll check for that.

Brusk - BMW said they checked everything for tightness and itís all ok. I did not see the alignment specs, I'll ask BMW for those. I think swapping tires is a good idea and I still do have the stock BMW ones so that may be my best option.

If anyone else has any ideas, maybe if this is happening/happened to them, I would love to hear it. It sucks to keep spending money without any fix, and having the people who should know the answers tell you "we have no idea".
__________________
2009 135i AT / CF Trim / ACS Pedals / Alpine HID 7000K / ST Coilovers / BMS DCI / VMR v701 18"/215/40 18"/245/35