View Single Post
      09-18-2012, 05:08 AM   #1
Carbon130i
Private
 
Carbon130i's Avatar
 
Drives: 130i with M Sport Pack
Join Date: Jul 2008
Location: A

Posts: 52
iTrader: (0)

Flat spot on N52 engine for 130i

I have a flat spot when accelerating in any gear. It starts anywhere between 3800rpm and 4500rpm, it does it for about 1000rpm.

The history of the car is that it was standing for months since the accident and while getting repaired…. It only had body damage on the whole left hand side, the only mechanical damage was the air filter box…. Once I got the car back from the repairs, 2 days later I had the 60000km service (replaced the filters, oil, brake pads, etc) and decatted the exhaust. Since I’ve had the car back, I’ve had the flat spot.

The flat spot either got caused by standing for months or when they did the decat…. The car has been at BMW, and a few other service workshops, for the diagnostics test, OEM software update, new oil and filters again, sensors checked, etc. The only 2 things they didn’t do is open up the engine and the VANOS.

Even tried aftermarket tuning software and the BMS Power Box. With either of these, there was no power gains at all, and the flat spot was a lot worse… Went back to latest OEM software.... The decat and K&N filter (fitted 4 years ago) is now the only mods done.

The flat spot feels like its battling with the air/fuel mixture or the suction of the fuel line. What do you think is causing it?

At the moment, I either have to change down or up a gear to get the revs below 3800rpm or higher than 4500rpm to accelerate
__________________

130i M Sport
Carbon130i is offline   No_Country
0
Reply With Quote