View Single Post
      10-13-2012, 02:06 PM   #1
qntran2
Private
 
Drives: 08 135i
Join Date: Jun 2008
Location: Nola

Posts: 69
iTrader: (1)

Anyone else experience ADV.1 Woes?

I was curious if I had bad luck or if this is the norm.

My brother and I both ordered rims from ADV.1 through a local retailer. He ordered the five spoke 1 Piece forged for his E93 and I ordered the TF Split Five Spoke in Matte Black a week later.

The 3 series rims came in first open the box to see that they had made him a 1 piece forged rim with 5 split spokes... wrong rim. But my brother decided it was fine our wheels would look different enough since mine would have a lip. He kept them.

Then 08/08/12 my wheels came in and oh my was I happy.




But wait once it was on the car something was strange



Hmmm wrong offset much? ADV.1 was called they said it was an easy fix expect it back in two weeks. Shipped it back to ADV.1 a week later.

August and September roll by and finally I get the call that my rims came in had them put onto the car and well... Still stuck out a little but nothing a little camber and a drop won't fix right and it really did look good on the car as is.



Next morning woke up to a flat front passenger tire. Thought to myself how the #$%@ did I hit a nail already. Had the tire looked at no leaks whatsoever refilled tire with air. Then we found the leak. The rim was leaking at the bolts. I guess when the Rim was corrected it wasn't sealed correctly.

So now the rim is going back to ADV.1 and I'm SOL for what another month? Two? Oh and someone else ordered a set from ADV.1 as the same time as I did and they sent his rims with the wrong lip.

So is this to be expected from this company or did all three of us have terrible luck?

*rant off*
qntran2 is offline  
0
Reply With Quote