View Single Post
      11-15-2012, 04:25 PM   #10
mike the snake
Lieutenant
11
Rep
541
Posts

 
Drives: 135i
Join Date: Sep 2011
Location: Sonoma County, CA.

iTrader: (1)

Sorry, I didn't mean to come off ignorant.

I've raced cars, and I have plenty of experience with high performance driving. I plan to autocross my 135, but I'm serious when I say my car literally changes lanes, and is a total handfull when I fully accellerate in 1st and 2nd gears.

Other non LSD cars I've owned would spin one wheel, or if on very even ground would spin both wheels and get slightly sideways, but my 135 becomes a bucking bronco when getting on it.
I was prepared for the back end to break loose, but not to whip out so violently when I almost lost it. It wasn't simply the car getting sideways and I wasn't ready for it. No amount of correction or overcorrection would have stopped that incident, it was instantaneous and violent.

It's not me, or inexperience, something is not right about my car. In comparison, my race car WAS a handfull for good reason, and I was easily able to handle full throttle and getting sideways in it because it was predictable.

The shop that installed my Ohlins R&T suspension mentioned the back of the car didn't feel right but the car hadn't been aligned yet so I attributed what they said to that.

My car has Michelin PSS 245-265 with Apex wheels, Ohlins R&T suspension, Procede tune with DCT's and axle-back exhaust, and has been aligned properly.

It feels almost like a link is broken, almost like rear steering.

I remember reading a thread here about someone else having the same issue, basically changing lanes under hard accelleration, so I know I'm not totally alone.

I was hoping maybe someone knew something, maybe a worn rear link or maybe had a similar behaving car, but in any case I'm glad some at least got some entertainment value from my post.

I'll try and get a video and post it up.