View Single Post
      02-02-2013, 08:02 PM   #9
GRK_TrackJunkie's Avatar

Drives: 135i N54
Join Date: Apr 2008
Location: New York

iTrader: (0)

Originally Posted by Dackelone
Originally Posted by Da _Grk_Tuner View Post
hey guys I have replaced my fuel pump 2 times before hitting 25,000 miles also I had BMW change my spark plugs right before my warranty expired at 45,000 miles I also recently got walnut blasting on my car done by Helix at 46,000 miles and still sometimes when I'm at a red light I get a quick small shake and I see the rpm gauge moving a bit and then stops right away I get this once in a while even with the hpfp replaced twiced. changed spark plugs according to BMW and. walnut shell blast

any idea guys?

Software. My car used to do that when new. My dealer changed the plugs/injectors/and spark plugs - and updated the SW when my car was brand new. I never had that problem again. I actually kind of miss it though.

Then later when I got BMW anti-tuner SW update for the HPFP recall... that killed my throttle response and gave me that "lag SW" update.

Personally I would just live with this - its really not causing any harm. BUT if it really bothers you - you could have bmw do a SW update and take your chances with the "lag SW".
well its not like its doing it all the time I'm just wondering why it does it at all
MHD Custom Flash (E40) [Jake@MOTIV] / Vargas Stage 2 Turbos / Fuel it LPFP Stage 2/ MMP Turbo Inlets/ 3.5 Tmap Sensor / ER FMIC /ER Chargepipe HKS-BOV / AA Downpipes / Agency Power Race mid pipes / Berk Technology race exhaust / BMW SSK / VMR wheels--Yokohma ADVAN AD08R tires / KW Club sport coilovers+KW Camber Plates / Spec stg2+Spec SMSFW