View Single Post
      11-11-2009, 05:58 AM   #9
Nifelheim
New Member
2
Rep
17
Posts

 
Drives: 130i
Join Date: Mar 2009
Location: Sydney

iTrader: (0)

Quote:
Originally Posted by jksgoh View Post
I had a ticking noise around a year ago now, which varied with the revs (ie faster when i reved it faster), is this similar to what others have experience. dealer told me it can happen due to lots of short trips, took it for a decent drive and i've never had it again.
anything to worry about?
Sounds identical to the problem I experienced with 130i e 87. At first BMW said it was failed cat which was replaced.. noise persisted , after a few more months of procrastination ( head off , lifters replaced etc) and referring the tech guys to the info in these threads BMW replaced the engine. Tech guys were great but BMW Australia still havent told me what the problem was or why it occured. Dont want to know/acknowledge there is an issue.

The tech said they found metal shavings in the oil which to my non mechanical mind indicates this "ticking" problem is fairly serious. Bombs tick before they go off.....

I do a few track days and was up front with BMW about this given all the data logging these days and the tech guys said the engine still should not have failed.

New enging feels much stonger so I am keeping it for now...... but wont be buying another BMW which is a pity as I love the 130i package and would have upgraded to the 135i. Priced as a premium product but fail to deliver on quality.