View Single Post
      02-08-2010, 10:40 PM   #6
HPFREAK
Lieutenant Colonel
21
Rep
1,873
Posts

 
Drives: 09 135 CPE
Join Date: Sep 2009
Location: Socal

iTrader: (8)

Quote:
Originally Posted by MadMan77 View Post
If I remember correctly v2.0 requires a Gen 3 board. You might want to mention that in the OP.
you can use it with Gen 2 as well but you cant run the USB to it. Gen 3 is the best way to go though for sure.