BMW 1 Series Coupe Forum / 1 Series Convertible Forum (1M / tii / 135i / 128i / Coupe / Cabrio / Hatchback) (BMW E82 E88 128i 130i 135i)
 





 

Post Reply
 
Thread Tools Search this Thread
      04-08-2012, 05:15 AM   #1
misk
Ja gut
 
misk's Avatar
 
Drives: BMW 128i
Join Date: Apr 2011
Location: Fairfax,VA

Posts: 80
iTrader: (2)

Magnaflow with A/T issues

So I recently installed a Magnaflow Cat-back system on the 1 and really love how deep it sounds under 3k RPM. One thing I have noticed while driving in steptronic mode is that when you down shift the car still accelerates with foot off the pedal. With the stock exhaust it would decelerate immediately. Does the change in flow from the cat back system confuse the ECU and gear ratios? Has anyone had this problem before?

Also worth noting is that up shifting in manual mode the car almost feels like its double clutching with gears upward the RPM remains the same but load on the engine is higher. (you can hear it)

Any feedback would be great.
misk is offline   United_States
0
Reply With Quote
      04-08-2012, 10:07 AM   #2
AW128i
Major
 
AW128i's Avatar
 
Drives: E82 N51
Join Date: Nov 2010
Location: Southeastern, PA

Posts: 1,004
iTrader: (1)

Send a message via AIM to AW128i
I'd say what you're feeling is normal. Perhaps you didn't notice it before the exhaust because you weren't paying as much attention to it? With the downshifting, I've noticed that the ECU will sort of rev-match in Steptronic mode. I think it's that, that causes a sort of freewheeling feeling, which can be mistaken for accelerating. It's not that the car is accelerating, it's just coasting briefly when you're expecting perhaps deceleration.

As for the upshifting, this is still a torque converter automatic so perhaps you're noticing the brief period of time when the transmission has upshifted but the torque converter is in the process of locking up (the TC is unlocked in-between shifts)? Maybe not, since that is a split-second thing.

Overall, you're probably more aware of what's going on because the engine load is now more distinguishable since the exhaust is enhancing the volume and tone of the engine.
__________________
"The Camaro's V6 makes so much horsepower because them horses are trying as hard as they can to run the fuck away from that ugly ass car." -Golden3ye
AW128i is offline   United_States
0
Reply With Quote
      04-08-2012, 06:03 PM   #3
Greenkirby21
Vrooom :)
 
Greenkirby21's Avatar
 
Drives: C7 Stringray
Join Date: Jun 2010
Location: Dream Land

Posts: 2,598
iTrader: (1)

Send a message via AIM to Greenkirby21
Quote:
Originally Posted by misk View Post
So I recently installed a Magnaflow Cat-back system on the 1 and really love how deep it sounds under 3k RPM. One thing I have noticed while driving in steptronic mode is that when you down shift the car still accelerates with foot off the pedal. With the stock exhaust it would decelerate immediately. Does the change in flow from the cat back system confuse the ECU and gear ratios? Has anyone had this problem before?

Also worth noting is that up shifting in manual mode the car almost feels like its double clutching with gears upward the RPM remains the same but load on the engine is higher. (you can hear it)

Any feedback would be great.
I think its because the steptronic is slow to downshift. At least for me, downshifting is horrible. It takes a good two seconds for it to downshift.

Secondly, I think the car is actually holding the exhaust better when upshifting. It might be my intake, but when shifting at the sweet spots(~3k) then it doesn't feel like I am losing much power as before.

Since these are just bolt ons, it shouldn't affect anything drastically.

If I were you, I would try resetting your auto transmission, since the car over time learns your driving style. Also, give it some time for the ECU to adapt : )
__________________
2009 128i Coupe Crimson Red MODS: -Injen Intake-Magnaflow Exhaust-Carbon Fiber Spoiler - Carbon Fiber Grilles - OZ Ultraleggeras - CF Mirrors
Greenkirby21 is offline   United_States
0
Reply With Quote
      04-08-2012, 08:49 PM   #4
misk
Ja gut
 
misk's Avatar
 
Drives: BMW 128i
Join Date: Apr 2011
Location: Fairfax,VA

Posts: 80
iTrader: (2)

Thanks for the info guys. Yeah I guess I will give it some time to just get used to everything and maybe reset it down the road.
misk is offline   United_States
0
Reply With Quote
Post Reply

Bookmarks

Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Forum Jump


All times are GMT -5. The time now is 12:27 PM.




1addicts
Powered by vBulletin® Version 3.7.0
Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.
1Addicts.com, BIMMERPOST.com, E90Post.com, F30Post.com, M3Post.com, ZPost.com, 5Post.com, 6Post.com, 7Post.com, XBimmers.com logo and trademark are properties of BIMMERPOST