BMW 1 Series Coupe Forum / 1 Series Convertible Forum (1M / tii / 135i / 128i / Coupe / Cabrio / Hatchback) (BMW E82 E88 128i 130i 135i)
 





 

Post Reply
 
Thread Tools Search this Thread
      01-14-2013, 11:53 PM   #1
Miko226
Lieutenant
Miko226's Avatar
United_States
14
Rep
559
Posts

Drives: 08 135i n54
Join Date: Nov 2012
Location: Boca Raton, FL

iTrader: (0)

Check Engine Light Shaking w/ no power Need HELP!!

So i was driving home like normal gave it a little gas to accelerate and when it shifted from 2-3 AT it felt like something didnt catch right and as im pulling up to my house i get a check engine light and the car starts shaking and sputtering at low rpm with no power i drive it around my block to see if there was any white smoke and there was none the car just sounded like it had a mild cam all of the sudden.... Going to take off my JB4 before i give it to the dealer tomorrow anybody have any ideas on what it could be by what i just said? and should i drive it?
__________________
08 n54 135i Alpina-AT 88k
Engine: JB4 e40/93, AFE DCI, VRSF 5" FMIC V2, VRSF Upper/Lower CP, BMS Tstat, RB PCV & BMS OCC (Next)
Exhaust: Active DP, n55 Mids (Next), Berk Ceramic Delete
Tires: Nitto 555 265/35, Nitto 555 225/40
Appreciate 0
      01-15-2013, 12:15 AM   #2
Tee-Dub
Captain
Tee-Dub's Avatar
United_States
14
Rep
753
Posts

Drives: 2008 135i
Join Date: May 2009
Location: Vancouver, WA

iTrader: (9)

Why don't you check for codes, or do you have auto clear on? If there are any codes, write them down, then clear them and see if that helps.
Appreciate 0
      01-15-2013, 12:48 AM   #3
Miko226
Lieutenant
Miko226's Avatar
United_States
14
Rep
559
Posts

Drives: 08 135i n54
Join Date: Nov 2012
Location: Boca Raton, FL

iTrader: (0)

I cleared the codes manually and the light came right back on how do I get the numbers to lookup do I have to plug into the jb4 CPU itself?
__________________
08 n54 135i Alpina-AT 88k
Engine: JB4 e40/93, AFE DCI, VRSF 5" FMIC V2, VRSF Upper/Lower CP, BMS Tstat, RB PCV & BMS OCC (Next)
Exhaust: Active DP, n55 Mids (Next), Berk Ceramic Delete
Tires: Nitto 555 265/35, Nitto 555 225/40
Appreciate 0
      01-15-2013, 01:02 AM   #4
Tee-Dub
Captain
Tee-Dub's Avatar
United_States
14
Rep
753
Posts

Drives: 2008 135i
Join Date: May 2009
Location: Vancouver, WA

iTrader: (9)

I don't have a JB4, but I'm pretty sure you have to use the BMS USB cable (if you bought one) and hook your computer up to the JB4 to get the codes.
Appreciate 0
      01-15-2013, 10:38 AM   #5
b1aze
Just one more taste...
United_States
27
Rep
1,416
Posts

Drives: 2010 135i
Join Date: Aug 2012
Location: Shirley, MA

iTrader: (14)

Quote:
Originally Posted by Tee-Dub
I don't have a JB4, but I'm pretty sure you have to use the BMS USB cable (if you bought one) and hook your computer up to the JB4 to get the codes.
This. In the JB4 computer interface, there is a "read codes" button that will spit out, in your case, a bunch of codes.
Appreciate 0
      01-15-2013, 12:04 PM   #6
Miko226
Lieutenant
Miko226's Avatar
United_States
14
Rep
559
Posts

Drives: 08 135i n54
Join Date: Nov 2012
Location: Boca Raton, FL

iTrader: (0)

Quote:
Originally Posted by b1aze
Quote:
Originally Posted by Tee-Dub
I don't have a JB4, but I'm pretty sure you have to use the BMS USB cable (if you bought one) and hook your computer up to the JB4 to get the codes.
This. In the JB4 computer interface, there is a "read codes" button that will spit out, in your case, a bunch of codes.
I have read the codes but all it did was move the speedo an flash some lights no actual codes displayed
__________________
08 n54 135i Alpina-AT 88k
Engine: JB4 e40/93, AFE DCI, VRSF 5" FMIC V2, VRSF Upper/Lower CP, BMS Tstat, RB PCV & BMS OCC (Next)
Exhaust: Active DP, n55 Mids (Next), Berk Ceramic Delete
Tires: Nitto 555 265/35, Nitto 555 225/40
Appreciate 0
      01-15-2013, 12:07 PM   #7
Miko226
Lieutenant
Miko226's Avatar
United_States
14
Rep
559
Posts

Drives: 08 135i n54
Join Date: Nov 2012
Location: Boca Raton, FL

iTrader: (0)

It seems to be a fuel pump issue from what I read should I take off the jb4 before giving it to the dealer or does it not really matter and just turn back to stock tune??
__________________
08 n54 135i Alpina-AT 88k
Engine: JB4 e40/93, AFE DCI, VRSF 5" FMIC V2, VRSF Upper/Lower CP, BMS Tstat, RB PCV & BMS OCC (Next)
Exhaust: Active DP, n55 Mids (Next), Berk Ceramic Delete
Tires: Nitto 555 265/35, Nitto 555 225/40
Appreciate 0
      01-15-2013, 12:26 PM   #8
deploytosave
Private First Class
2
Rep
120
Posts

Drives: 08 135i
Join Date: Apr 2012
Location: La porte Tx

iTrader: (0)

Quote:
Originally Posted by Miko226 View Post
It seems to be a fuel pump issue from what I read should I take off the jb4 before giving it to the dealer or does it not really matter and just turn back to stock tune??
i wouldnt risk it, take off the JB4, its not hard...

also, long cranks are generally a sign of fuel pumps on these cars, how does it act on start up?
Appreciate 0
      01-15-2013, 12:27 PM   #9
Miko226
Lieutenant
Miko226's Avatar
United_States
14
Rep
559
Posts

Drives: 08 135i n54
Join Date: Nov 2012
Location: Boca Raton, FL

iTrader: (0)

From everything I read it is a fuel issue when it starts up it is long tumbling cranks engine seems fine just feels as if its choked
__________________
08 n54 135i Alpina-AT 88k
Engine: JB4 e40/93, AFE DCI, VRSF 5" FMIC V2, VRSF Upper/Lower CP, BMS Tstat, RB PCV & BMS OCC (Next)
Exhaust: Active DP, n55 Mids (Next), Berk Ceramic Delete
Tires: Nitto 555 265/35, Nitto 555 225/40
Appreciate 0
      01-15-2013, 12:52 PM   #10
ipitythefoo
III II VIII XI
0
Rep
75
Posts

Drives: 2013 328xi Sport Line
Join Date: Jan 2012
Location: GTA

iTrader: (0)

Quote:
Originally Posted by Miko226 View Post
It seems to be a fuel pump issue from what I read should I take off the jb4 before giving it to the dealer or does it not really matter and just turn back to stock tune??
I experienced something similar (except there wasn't really a noticeable difference in power) and it checked out to be a VANOS error.

It's one of the common problems with BMW vehicles (like the HPFP for the 335i's).

I took off my JB4 (used the clear-code function before uninstalling) and brought to dealership. They found out one of the exhaust camshaft solenoid or something needed to be replaced.

My car has been in the dealership under warranty repair for over a month now (they wanted to replace a few other parts that are linked so I didn't complain).

My error code was P0015: B Camshaft Position-Timing Over-Retarded B1.
__________________
2013 BMW 328i xDrive
2011 BMW 135i DCT
Appreciate 0
      01-18-2013, 01:33 AM   #11
Brian@MWP
Private
United_States
0
Rep
90
Posts

Drives: BMW
Join Date: Jan 2013
Location: Chicago

iTrader: (0)

I would remove it 100% . Are you getting a strong fuel smell from the exhaust? Maybe injectors or HPFP.
Appreciate 0
      01-18-2013, 04:03 AM   #12
Miko226
Lieutenant
Miko226's Avatar
United_States
14
Rep
559
Posts

Drives: 08 135i n54
Join Date: Nov 2012
Location: Boca Raton, FL

iTrader: (0)

Yes i was getting a fuel smell out the back i took the car to bmw after i took my jb4 off and left my intake on my service adviser told me nothing would really void my extended warranty besides bigger turbos or serious engine mods alike. it ended up being just one coil on the first cylinder got my car back this morning and put the jb4 back on and my Active DP's are going in tomorrow hopefully and he also offered me a bmw performance exhaust that was coming off a car they were trying to total from a newer 135 for free!
__________________
08 n54 135i Alpina-AT 88k
Engine: JB4 e40/93, AFE DCI, VRSF 5" FMIC V2, VRSF Upper/Lower CP, BMS Tstat, RB PCV & BMS OCC (Next)
Exhaust: Active DP, n55 Mids (Next), Berk Ceramic Delete
Tires: Nitto 555 265/35, Nitto 555 225/40
Appreciate 0
      01-19-2013, 12:17 AM   #13
Brian@MWP
Private
United_States
0
Rep
90
Posts

Drives: BMW
Join Date: Jan 2013
Location: Chicago

iTrader: (0)

Thumbs up

sounds like going to the dealer worked out in your favor
Appreciate 0
Post Reply

Bookmarks

Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Forum Jump


All times are GMT -4. The time now is 11:06 AM.




1addicts
1addicts
Powered by vBulletin® Version 3.7.0
Copyright ©2000 - 2015, Jelsoft Enterprises Ltd.
1Addicts.com, BIMMERPOST.com, E90Post.com, F30Post.com, M3Post.com, ZPost.com, 5Post.com, 6Post.com, 7Post.com, XBimmers.com logo and trademark are properties of BIMMERPOST