BMW 1 Series Coupe Forum / 1 Series Convertible Forum (1M / tii / 135i / 128i / Coupe / Cabrio / Hatchback) (BMW E82 E88 128i 130i 135i)
 





 

Post Reply
 
Thread Tools Search this Thread
      10-29-2012, 10:41 AM   #23
RimasRS
Colonel
 
RimasRS's Avatar
 
Drives: 135i MT 2009 AW
Join Date: Sep 2010
Location: Europe

Posts: 2,376
iTrader: (0)

Quote:
Originally Posted by M130ISWP View Post
I've had the pedal in for 10 days now. It still has the flat spot but not as bad as what it was.

I've checked with ART today, they said that the new pedal module needs to be programmed into the system. I thought it was just a "plug n play"

Below are the dyno graphs that were done this year. The decat and K&N filter mods were in all 3 graphs.
The flat spot only kicked in on the 3rd graph. Luckily it didnt kick in, in the first 2 graphs. The first 2 were done on the same day.

This pic was with the BMS Power Box map:



This one is with OEM map, notice the increase of power:



This one is 6 weeks later with other software:
I think you can try to reset adaptions of the throttle somewhere was DYI how to do that maybe that will help
RimasRS is offline  
0
Reply With Quote
      11-01-2012, 06:22 PM   #24
Three_thirty_I
Captain
 
Three_thirty_I's Avatar
 
Drives: '05 E90 330i Manual
Join Date: Aug 2010
Location: Cape Town, South Africa

Posts: 754
iTrader: (0)

Garage List
Hmm, would also have thought that it would simply be a plug and play solution. Interestingly that third graph is very similar to what (or where) I am experiencing with my 330i in terms of the intermittent performance dip - 3000 rpm to around 4500 rpm...
__________________
BMW E90 330i (M) '05 (His) | (Hers) BMW E46 320i f/l (M) '03


Three_thirty_I is offline   South Africa
0
Reply With Quote
      11-19-2012, 02:12 AM   #25
Carbon69
Private
 
Carbon69's Avatar
 
Drives: 130i with M Sport Pack
Join Date: Jul 2008
Location: A

Posts: 51
iTrader: (0)

Just an update. The car is back at BMW today.

I did another mod 2 weeks ago. Took out the middle silencer box. Its got a nice growl to it at 1900rpm to 2300rpm
__________________
130i M Sport
Carbon69 is offline   No_Country
0
Reply With Quote
      12-11-2012, 07:35 AM   #26
Three_thirty_I
Captain
 
Three_thirty_I's Avatar
 
Drives: '05 E90 330i Manual
Join Date: Aug 2010
Location: Cape Town, South Africa

Posts: 754
iTrader: (0)

Garage List
Quote:
Originally Posted by M130ISWP View Post
Just an update. The car is back at BMW today.

I did another mod 2 weeks ago. Took out the middle silencer box. Its got a nice growl to it at 1900rpm to 2300rpm
What happened with the throttle pedal module and ART? They have been letting me down massively by never returning my calls and ended up replacing the DISA flaps myself but still have the problems.

What did BMW find on this last visit?
__________________
BMW E90 330i (M) '05 (His) | (Hers) BMW E46 320i f/l (M) '03


Three_thirty_I is offline   South Africa
0
Reply With Quote
      12-11-2012, 02:53 PM   #27
Carbon69
Private
 
Carbon69's Avatar
 
Drives: 130i with M Sport Pack
Join Date: Jul 2008
Location: A

Posts: 51
iTrader: (0)

Quote:
Originally Posted by Three_thirty_I
What happened with the throttle pedal module and ART? They have been letting me down massively by never returning my calls and ended up replacing the DISA flaps myself but still have the problems.

What did BMW find on this last visit?
The pedal was a waste of money. It wasn't the cause of the flat spot. BMW won't refund me.

They've also let me down. Left a few messages and they never return calls.

The last visit at BMW was that their system only detected the Cats missing, no other errors. They said I must put the Cats back in.

I've still got the flat spot. And an aircon problem now.
The aircon is on and off. It has gas. I don't think its related to the flat spot, it started a few weeks ago.

The exhaust place said it might be the fuel pump causing the flat spot.

I've given up on what's causing it
__________________
130i M Sport
Carbon69 is offline   No_Country
0
Reply With Quote
      12-11-2012, 03:02 PM   #28
Dackelone
Moderator
 
Dackelone's Avatar
 
Drives: 135i Silber mit/Rot 6MT N54
Join Date: Feb 2010
Location: Bayern, Germany

Posts: 15,065
iTrader: (1)

Quote:
Originally Posted by M130ISWP View Post
The exhaust place said it might be the fuel pump causing the flat spot.

That is actually a good idea. It could be the fuel pump. It could be mechanical issue with the pump, or even a voltage fluctuation issue at the pump. Or a ground issue at the pump.

Do you have access to an OBD-II code reader. Maybe you could read the fuel pressure while on the fly. Or install a mechanical fuel pressure gauge(temporarily) and drive WOT and see what it read at your flat spot. You will probably need a helper.
Dackelone is offline   Germany
0
Reply With Quote
      12-12-2012, 01:53 AM   #29
Carbon69
Private
 
Carbon69's Avatar
 
Drives: 130i with M Sport Pack
Join Date: Jul 2008
Location: A

Posts: 51
iTrader: (0)

Quote:
Originally Posted by Dackelone
That is actually a good idea. It could be the fuel pump. It could be mechanical issue with the pump, or even a voltage fluctuation issue at the pump. Or a ground issue at the pump.

Do you have access to an OBD-II code reader. Maybe you could read the fuel pressure while on the fly. Or install a mechanical fuel pressure gauge(temporarily) and drive WOT and see what it read at your flat spot. You will probably need a helper.
I've got a Bluetooth and a wifi obdii dongle.
I've used a friends Samsung with Torque, months ago, to find any problems. The error that we noticed while driving, was the boost gauge, but this engine isn't turbo'ed.

I've tried all the 'trial' apps on my iPhone. Most of them can't detect the obc.

I also used a friends 'BavarianTechnic' cable with the app. Ran all the 'fault find' tests, found no faults.

I need to get a normal USB cable obdii reader to try INPA
__________________
130i M Sport
Carbon69 is offline   No_Country
0
Reply With Quote
      12-12-2012, 06:48 AM   #30
Three_thirty_I
Captain
 
Three_thirty_I's Avatar
 
Drives: '05 E90 330i Manual
Join Date: Aug 2010
Location: Cape Town, South Africa

Posts: 754
iTrader: (0)

Garage List
Same thing with the DISA flaps for me (R5k gamble)...

I think in both in your and my case we need to have the fuel pump pressure tested and in my case have the injectors tested too to ensure that their individual spray patterns are up to spec. These cars don't have replaceable fuel filters (which is so stupid), so there is a big chance that they could be slightly dirty or blocked. It could even just be that the pump is weaker than it should be or that the regulator is not working properly.

Now just need to find a place that can test these things without immediately wanting to rip a person off. ART won't see me again - over 2 weeks later after leaving a very polite message to PLEASE call me back, and still nothing!
__________________
BMW E90 330i (M) '05 (His) | (Hers) BMW E46 320i f/l (M) '03


Three_thirty_I is offline   South Africa
0
Reply With Quote
      12-12-2012, 01:08 PM   #31
Carbon69
Private
 
Carbon69's Avatar
 
Drives: 130i with M Sport Pack
Join Date: Jul 2008
Location: A

Posts: 51
iTrader: (0)

Yeah, we need to get our pumps/injectors pressure tested. Just don't know where.

I went to another place today, for a diagnostics test. Their diagnostics only had the Cats error. The guy said the VBT sensor (never heard of it) might be the cause of the flat spot. He said I must take it to a place that has the AutoLogic machine to reset it.

The car is going to BMW next week Tuesday to get the aircon sorted out. They reckon its the resistor that's faulty. They gonna do another diagnostics to see if it is the resistor.

BMW also gave me the report printout this morning for the previous diagnostics that they did the other day. The report explained in full detail about the Cats missing etc.
__________________
130i M Sport
Carbon69 is offline   No_Country
0
Reply With Quote
      12-12-2012, 03:24 PM   #32
Three_thirty_I
Captain
 
Three_thirty_I's Avatar
 
Drives: '05 E90 330i Manual
Join Date: Aug 2010
Location: Cape Town, South Africa

Posts: 754
iTrader: (0)

Garage List
My neighbour is a rep for Goch and Cooper and had a chat with him the other day, he is convinced that they can do this and also diagnostics on a dyno for live readings if necessary so pretty keen to speak to them and find out more.

Zayd (NavZ) and myself are going through to Nick in Paarl to do the CDV delete and while we are busy I am going to take a poke around underneath to see if I can see anything loose that could be causing the rattling noise that I have been battling with.

I also want to try an octane booster to see if this does anything, maybe it is pinging after all?! Another thing I want to do is let SMG do a software update (Mike says that their prices for a software update it pretty good)...
__________________
BMW E90 330i (M) '05 (His) | (Hers) BMW E46 320i f/l (M) '03


Three_thirty_I is offline   South Africa
0
Reply With Quote
      12-12-2012, 03:33 PM   #33
Carbon69
Private
 
Carbon69's Avatar
 
Drives: 130i with M Sport Pack
Join Date: Jul 2008
Location: A

Posts: 51
iTrader: (0)

I know both owners at G&C. Mr Cooper left, it's just Deon now.

Maybe they can do the pressure tests?

If you book your car in for Tuesday at SMG, I will see you there
__________________
130i M Sport
Carbon69 is offline   No_Country
0
Reply With Quote
      12-12-2012, 05:44 PM   #34
Three_thirty_I
Captain
 
Three_thirty_I's Avatar
 
Drives: '05 E90 330i Manual
Join Date: Aug 2010
Location: Cape Town, South Africa

Posts: 754
iTrader: (0)

Garage List
Well, I first want to speak to one of their techs to see if they can run the tests that I want done, no point forking out more money just to have a computer plugged in that is likely to not find anything wrong in my car's case. Doubt that my car will be at SMG as soon as that, but will see.
__________________
BMW E90 330i (M) '05 (His) | (Hers) BMW E46 320i f/l (M) '03


Three_thirty_I is offline   South Africa
0
Reply With Quote
      01-31-2013, 06:22 AM   #35
mikesonfirst
New Member
 
mikesonfirst's Avatar
 
Drives: BMW 125i Coupe
Join Date: Jan 2012
Location: Melbourne, Australia

Posts: 14
iTrader: (0)

Guys, did you get any further with this? I have a 125i and have the same issue.
mikesonfirst is offline  
0
Reply With Quote
      01-31-2013, 06:43 AM   #36
Carbon69
Private
 
Carbon69's Avatar
 
Drives: 130i with M Sport Pack
Join Date: Jul 2008
Location: A

Posts: 51
iTrader: (0)

No, got no where. The 1 BMW dealership (SMG) still insist that its caused by the catalytic converters missing. I know its something else causing it.
My aircon is also still faulty.

Three_thirty_I still has his Cats in.... He went to another BMW dealership yesterday, they said his flat spot could be ecu software related.
Mine isn't software related, I've tried aftermarket. Got latest (about Oct) oem software installed.
__________________
130i M Sport
Carbon69 is offline   No_Country
0
Reply With Quote
      01-31-2013, 06:53 AM   #37
mikesonfirst
New Member
 
mikesonfirst's Avatar
 
Drives: BMW 125i Coupe
Join Date: Jan 2012
Location: Melbourne, Australia

Posts: 14
iTrader: (0)

I haven't had mine checked by a technician yet but I've just put an Evolve tune in it and the flat spot is still there (if anything more noticeable now due to more power). Will let you know if I find a solution.
mikesonfirst is offline  
0
Reply With Quote
      01-31-2013, 07:02 AM   #38
Carbon69
Private
 
Carbon69's Avatar
 
Drives: 130i with M Sport Pack
Join Date: Jul 2008
Location: A

Posts: 51
iTrader: (0)

The aftermarket software and piggyback made it worse. So went back to OEM software.

Yeah, please let us know
__________________
130i M Sport
Carbon69 is offline   No_Country
0
Reply With Quote
      02-01-2013, 12:25 AM   #39
TheSt|G
Resident Tamed Racing Driver
 
TheSt|G's Avatar
 
Drives: 130is 6MT, E39 M5, E36 M3
Join Date: Mar 2008
Location: Outside Philly

Posts: 3,157
iTrader: (2)

When you say decatted, what did you replace them with?
__________________

130is MSport 6MT/ SuperSprint Headers & Exhaust with Swain Tech Race Coat / DISA Manifold / EVOLVE Tune / TCK DA Coilovers / Euro CF Intake/Box / BMW v1 Wheel / BBS RGRs with PSS / F30 Brake Shield / BMW CF Spoiler & Diffuser / Blackline Tails / Rear Fogs Enabled / Front Fogs Delete / CDV Delete / BMW Black Kidneys / M5 Illuminated Knob / BMW Stripe
TheSt|G is offline   United_States
0
Reply With Quote
      02-01-2013, 01:44 AM   #40
andrey_gta
Colonel
 
andrey_gta's Avatar
 
Drives: 130i coupé ;)
Join Date: Nov 2011
Location: Bimmerpost

Posts: 2,574
iTrader: (1)

Garage List
2008 BMW 128i  [0.00]
Quote:
Originally Posted by mikesonfirst View Post
I haven't had mine checked by a technician yet but I've just put an Evolve tune in it and the flat spot is still there (if anything more noticeable now due to more power). Will let you know if I find a solution.
the n52 has a little flat spot, even if tuned, its not really gone.
look up 130i dyno's

AA tune may have masqued the spot better,i have yet to see a converted RWD dyno
__________________
128i Sport 6MT converted to Euro 130i spec, tuned by evolve ~220 whp 207 wtq(ft-lb) SAE
In-progress: n54 ssk, m3 trans mnt, e36M lip Wishlist: m3 susp, n55 eng mnt, headers, LSD, finn dif e60


"The 1-series is the last car that BMW engineered before the Germans, as a car-making culture, fell out of love with driving." - R&T 2013 135is
andrey_gta is offline   Canada
0
Reply With Quote
      02-01-2013, 03:45 AM   #41
Carbon69
Private
 
Carbon69's Avatar
 
Drives: 130i with M Sport Pack
Join Date: Jul 2008
Location: A

Posts: 51
iTrader: (0)

Quote:
Originally Posted by TheSt|G View Post
When you say decatted, what did you replace them with?
Didn't replace them, just took them out
__________________
130i M Sport
Carbon69 is offline   No_Country
0
Reply With Quote
      02-01-2013, 03:52 AM   #42
Carbon69
Private
 
Carbon69's Avatar
 
Drives: 130i with M Sport Pack
Join Date: Jul 2008
Location: A

Posts: 51
iTrader: (0)

Quote:
Originally Posted by andrey_gta View Post
the n52 has a little flat spot, even if tuned, its not really gone.
look up 130i dyno's

AA tune may have masqued the spot better,i have yet to see a converted RWD dyno
Mine never had the flat spot until recently
__________________
130i M Sport
Carbon69 is offline   No_Country
0
Reply With Quote
      02-01-2013, 09:22 AM   #43
TheSt|G
Resident Tamed Racing Driver
 
TheSt|G's Avatar
 
Drives: 130is 6MT, E39 M5, E36 M3
Join Date: Mar 2008
Location: Outside Philly

Posts: 3,157
iTrader: (2)

Quote:
Originally Posted by M130ISWP View Post
Didn't replace them, just took them out
You mean you took out the factory headers and drilled out the cats from the inside and then replaced them?
__________________

130is MSport 6MT/ SuperSprint Headers & Exhaust with Swain Tech Race Coat / DISA Manifold / EVOLVE Tune / TCK DA Coilovers / Euro CF Intake/Box / BMW v1 Wheel / BBS RGRs with PSS / F30 Brake Shield / BMW CF Spoiler & Diffuser / Blackline Tails / Rear Fogs Enabled / Front Fogs Delete / CDV Delete / BMW Black Kidneys / M5 Illuminated Knob / BMW Stripe
TheSt|G is offline   United_States
0
Reply With Quote
      02-01-2013, 09:30 AM   #44
Carbon69
Private
 
Carbon69's Avatar
 
Drives: 130i with M Sport Pack
Join Date: Jul 2008
Location: A

Posts: 51
iTrader: (0)

A BMW technician did it for me.

Yeah, drilled them out but didnt replace them.
__________________
130i M Sport
Carbon69 is offline   No_Country
0
Reply With Quote
Post Reply

Bookmarks

Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Forum Jump


All times are GMT -5. The time now is 08:20 AM.




1addicts
Powered by vBulletin® Version 3.7.0
Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.
1Addicts.com, BIMMERPOST.com, E90Post.com, F30Post.com, M3Post.com, ZPost.com, 5Post.com, 6Post.com, 7Post.com, XBimmers.com logo and trademark are properties of BIMMERPOST