BMW 1 Series Coupe Forum / 1 Series Convertible Forum (1M / tii / 135i / 128i / Coupe / Cabrio / Hatchback) (BMW E82 E88 128i 130i 135i)
 





 

Post Reply
 
Thread Tools Search this Thread
      08-22-2008, 05:58 AM   #1
Swift135
Lieutenant
Australia
6
Rep
453
Posts

Drives: 330d, M3 DCT E92
Join Date: Jan 2008
Location: Brisbane

iTrader: (0)

Got new software update today V31.0 and......

As my car was built in February it had the "older" software, I had a performance steering wheel installed and the only way for it to work properly was to update the software. The version installed was 31.0. I went to pick up the car and 2 problems, first the windows would not drop when opening or closing the doors?? ie. the small movement that seals the window after it is fully shut. Secondly there was a rattle in the engine about 2500 rpm when I lightly depress or step off the throttle under light load. Waste gates opening and closing? Who knows. They have kept the car over the weekend to remove the software and do a fresh reinstall. All I wanted is the performance wheel to work and my car drive as it did before.
__________________
Appreciate 0
      08-22-2008, 07:24 AM   #2
holo777
Private First Class
1
Rep
162
Posts

Drives: 135i Conv
Join Date: Apr 2008
Location: NE TN

iTrader: (0)

I'm crossing my fingers for ya! Let us know if you see the turbo lag afterwards or have any different driving impressions (though hopefully they won't have 'upgraded' your ECU software)
Appreciate 0
      08-22-2008, 07:25 AM   #3
andrew@southernBM
andrew@southernBM's Avatar
Australia
42
Rep
1,474
Posts

Drives: M3 E92 SC'd, M235i
Join Date: Apr 2008
Location: Melbourne, Australia.

iTrader: (0)

Thanks for the phone call today. I do hope they sort out the mess that has been created in your car. The Steering wheel i find hard to understand what went wrong, the wiring issues surprises me, I installed one with no issues what so ever, and now the new running issue worries me more, let me know how you get on in the next few days, i'd like to know what is going on.
Appreciate 0
      08-22-2008, 07:27 AM   #4
rocketpop
Captain
rocketpop's Avatar
No_Country
11
Rep
844
Posts

Drives: 135i
Join Date: Dec 2007
Location: Home

iTrader: (0)

Thats odd, I could have swore that I read that the steering wheel did not have to have any thing done to the car to work, as far as software goes.
__________________
Appreciate 0
      08-22-2008, 07:32 AM   #5
andrew@southernBM
andrew@southernBM's Avatar
Australia
42
Rep
1,474
Posts

Drives: M3 E92 SC'd, M235i
Join Date: Apr 2008
Location: Melbourne, Australia.

iTrader: (0)

Quote:
Originally Posted by rocketpop View Post
Thats odd, I could have swore that I read that the steering wheel did not have to have any thing done to the car to work, as far as software goes.
You are correct. But BMW told him there was a power wire missing so they ran another.......makes me worry.
Appreciate 0
      08-22-2008, 07:51 AM   #6
Swift135
Lieutenant
Australia
6
Rep
453
Posts

Drives: 330d, M3 DCT E92
Join Date: Jan 2008
Location: Brisbane

iTrader: (0)

Thanks for talking to me today Andrew.:respekt: Their main issue was that the new ring for the airbag would not communicate with the older software? The one thing I noticed is that the icons on the trip computer on the dash were different. The symbol for distance to empty and average speed etc. were more detailed even animated (much more fine details in the symbol)? The tech said that the software upgrade should not have done anything to affect the engine functions.:iono:
__________________
Appreciate 0
      08-22-2008, 08:10 AM   #7
WAY
Brigadier General
Australia
56
Rep
4,045
Posts

Drives: Fast ones
Join Date: Jul 2007
Location: Melbourne, Australia

iTrader: (0)

Swift, don't you have the SSTT in your car as well? Anything to do with that?
Appreciate 0
      08-22-2008, 08:18 AM   #8
Swift135
Lieutenant
Australia
6
Rep
453
Posts

Drives: 330d, M3 DCT E92
Join Date: Jan 2008
Location: Brisbane

iTrader: (0)

Yes its still there, they didn't mentioned it. I have sent a PM to Jeff to see if it would have caused a problem with the software upgrade, I can't see it being a problem. I was unaware that things would have escalated to a full software upgrade when I put the car in to get the steering wheel put on. If I would have known prior I would have removed it.
............the more I think about it, it does take some time for the SSTT to adjust after installing, the battery would have been off for the wheel install, then the new software went in. I only drive the car lightly for 10 minutes before I took it back. The window issue they know how to fix so i'm hoping that the other issue may be the SSTT needing some WOT runs to get back into the groove, it did take a couple of days for it to peak when it was first installed.
__________________
Appreciate 0
      08-22-2008, 08:50 AM   #9
J-Sud
Captain
J-Sud's Avatar
United_States
17
Rep
808
Posts

Drives: 2015 BMW M235i
Join Date: Aug 2007
Location: Houston, TX

iTrader: (1)

Garage List
2015 BMW M235i  [0.00]
2009 135i  [0.00]
2014 Audi TTS  [0.00]
2012 Lexus IS-F  [0.00]
Quote:
Originally Posted by Swift135 View Post
As my car was built in February it had the "older" software, I had a performance steering wheel installed and the only way for it to work properly was to update the software. The version installed was 31.0. I went to pick up the car and 2 problems, first the windows would not drop when opening or closing the doors?? ie. the small movement that seals the window after it is fully shut. Secondly there was a rattle in the engine about 2500 rpm when I lightly depress or step off the throttle under light load. Waste gates opening and closing? Who knows. They have kept the car over the weekend to remove the software and do a fresh reinstall. All I wanted is the performance wheel to work and my car drive as it did before.
That sounds like the waste gate problem people are having on the 335i. I know a few people on e90post have had to replace their turbos to fix it and one guy acutally had complete boost failure.

http://www.e90post.com/forums/showth...=bubbles+turbo
__________________
2015 M235i 8AT | Alpine White | Black Leather | All M Perf Carbon Interior bits | M Perf Grills | M Perf Mirror Caps | M Perf Diffuser | M Perf Exhaust | Dinan Stage 1
Appreciate 0
      08-22-2008, 10:45 AM   #10
imported_mega
Colonel
No_Country
34
Rep
2,023
Posts

Drives: various bmw's
Join Date: Jul 2007
Location: neverland

iTrader: (0)

ohh crap so that wheel is not a DIY install
Appreciate 0
      08-22-2008, 10:49 AM   #11
ChrisK
Brigadier General
ChrisK's Avatar
United_States
98
Rep
4,934
Posts

Drives: '15 X1
Join Date: Jun 2007
Location: IL

iTrader: (5)

Garage List
2015 BMW X1  [0.00]
The big question for me is... will this update finally fix my Alarm?
Appreciate 0
      08-22-2008, 06:21 PM   #12
crzy4135i
Major
crzy4135i's Avatar
United_States
29
Rep
1,075
Posts

Drives: 08 135i
Join Date: Nov 2007
Location: US

iTrader: (0)

Quote:
Originally Posted by mega View Post
ohh crap so that wheel is not a DIY install
That's the main reasons I didn't buy it. It's expensive enough without having to pay for install that may or may not go smoothly. I would not want to be the first performance steering wheel install that the dealer does.
__________________
Ordered 4/7/08, Delivered 5/15/08, Sold, but not forgotten.
Appreciate 0
      08-24-2008, 06:00 PM   #13
andrew@southernBM
andrew@southernBM's Avatar
Australia
42
Rep
1,474
Posts

Drives: M3 E92 SC'd, M235i
Join Date: Apr 2008
Location: Melbourne, Australia.

iTrader: (0)

Just a thought, did they swap the slip ring to the new one when they installed the new wheel?
Appreciate 0
      08-24-2008, 08:57 PM   #14
Swift135
Lieutenant
Australia
6
Rep
453
Posts

Drives: 330d, M3 DCT E92
Join Date: Jan 2008
Location: Brisbane

iTrader: (0)

Yes the new slip ring which came with the wheel was used. Just spoke to the tech then, he had no idea about waste gates opening or closing with respect to the V31`software!! He just thought the new software would make the car run smoother and better.
__________________
Appreciate 0
      08-24-2008, 09:09 PM   #15
frimmelnojerz
Captain
frimmelnojerz's Avatar
United_States
7
Rep
692
Posts

Drives: Montego blue 135i
Join Date: Jun 2008
Location: Bayonne, NJ

iTrader: (0)

Send a message via AIM to frimmelnojerz
Quote:
Originally Posted by ChrisK View Post
The big question for me is... will this update finally fix my Alarm?
theres an alarm?
__________________
08' 135 in much need of some TLC.
But after that... Watch out.
AA/Berk/ER/UR/CP-e/Snow/ESS
Appreciate 0
      08-24-2008, 09:45 PM   #16
ChrisK
Brigadier General
ChrisK's Avatar
United_States
98
Rep
4,934
Posts

Drives: '15 X1
Join Date: Jun 2007
Location: IL

iTrader: (5)

Garage List
2015 BMW X1  [0.00]
:iono:

Not sure if you are joking or not, but you can install the alarm yourself for $200.

http://www.1addicts.com/forums/showthread.php?t=7536
Appreciate 0
Post Reply

Bookmarks

Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Forum Jump


All times are GMT -4. The time now is 04:52 PM.




1addicts
1addicts
Powered by vBulletin® Version 3.7.0
Copyright ©2000 - 2015, Jelsoft Enterprises Ltd.
1Addicts.com, BIMMERPOST.com, E90Post.com, F30Post.com, M3Post.com, ZPost.com, 5Post.com, 6Post.com, 7Post.com, XBimmers.com logo and trademark are properties of BIMMERPOST