BMW 1 Series Coupe Forum / 1 Series Convertible Forum (1M / tii / 135i / 128i / Coupe / Cabrio / Hatchback) (BMW E82 E88 128i 130i 135i)
 





 

Post Reply
 
Thread Tools Search this Thread
      05-17-2018, 08:05 PM   #1
jbarzelatto
Second Lieutenant
10
Rep
211
Posts

Drives: 2011 135i Lemans
Join Date: Jul 2013
Location: Santiago, Chile

iTrader: (0)

135i N55 SWAP ISSUES - 2012 ENGINE INTO 2011 CHASIS/DME

Whats up guys! I recently replaced my engine because I friend basically gifted me his engine. I had over 150.000 km and his had 20.000 km. His was a 2012 135i N55 E SERIES automatic tranny and mine is a 2011 135i N55 E SERIES. The 2012 is a bit newer so its a bit different.

I kepy my DME, and changed some pins but its basically the same. I have a VTT Stage 2+ Turbo Installed. But I am having the following issues

MAF code 277A ---> Air mass sensor, signal: Short-circuit or line break (open circuit)

Scanner doesnt show it now after I changed some idle settings, but CYLINDER 4 is off. When we shut down one by one, the only one that doesnt make a difference in the sound and feel, is 4.

I suspect that the 277a error makes the cylinder 4 shut down as security measure. I have changed the MAF sensors with 3 different ones, even changed the DME to a cloned one thinking it was a DME. And checked the cables pins and all is well. I have no idea what else to do. The car doesnt run smoothly, very rough, due to the 4th cylinder being shut off.

Not sure if this is due to the swap that its a newer engine in an E series, but I was told it shoulnt be a problem if I kept my dme, and changed the order of a couple of pins.

Help is appreciated! Thanks!

Last edited by jbarzelatto; 05-17-2018 at 08:19 PM. Reason: typo
Appreciate 0
      05-18-2018, 08:41 AM   #2
dsocold
First Lieutenant
86
Rep
396
Posts

Drives: sedona red
Join Date: Apr 2015
Location: new york

iTrader: (0)

its time to see a pro because there can be so many variables thats causing this one can not sipmly just guess the issue. But check all the obvious connections again make sure its not something simple (it usually is) then go from there
Appreciate 0
      05-18-2018, 10:22 AM   #3
jbarzelatto
Second Lieutenant
10
Rep
211
Posts

Drives: 2011 135i Lemans
Join Date: Jul 2013
Location: Santiago, Chile

iTrader: (0)

Thanks for the answer!

Anything else you suggest in the simple matter, other than changing the sensor, dme, and checking the flow circuit for any boost leaks?
Appreciate 0
Post Reply

Bookmarks

Tags
e series, f series, maf sensor, n55, swap

Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off


All times are GMT -4. The time now is 01:54 PM.




1addicts
Powered by vBulletin® Version 3.7.0
Copyright ©2000 - 2018, Jelsoft Enterprises Ltd.
1Addicts.com, BIMMERPOST.com, E90Post.com, F30Post.com, M3Post.com, ZPost.com, 5Post.com, 6Post.com, 7Post.com, XBimmers.com logo and trademark are properties of BIMMERPOST