BMW 1 Series Coupe Forum / 1 Series Convertible Forum (1M / tii / 135i / 128i / Coupe / Cabrio / Hatchback) (BMW E82 E88 128i 130i 135i)
 





 

Post Reply
 
Thread Tools Search this Thread
      07-28-2016, 02:43 PM   #1
schmidtp
Lieutenant
22
Rep
402
Posts

Drives: 2008 BMW 135i 6MT
Join Date: Sep 2013
Location: Madison, WI

iTrader: (2)

Garage List
Had Water Spill on TPM board, any other affects?

Hi Everyone,

Unfortunately I had some purified water spill in the trunk of my car. Ended up soaking the TPM circuit board. Got a TPM malfunction about 2 min from home then 30 seconds from home got an electrical malfunction warning. Any possibility of other damage? It was the only thing to get wet and right as I got home I disconnected the battery and now will let it sit for a week while on vacation.

Thanks,
Patrick
__________________
2008 TSM 135i N54
Appreciate 0
      07-29-2016, 08:07 AM   #2
m_thompson
Major
m_thompson's Avatar
United_States
54
Rep
1,246
Posts

Drives: M-Sport 128i, 328xi, 3.0CS
Join Date: Jun 2008
Location: New England, USA

iTrader: (0)

Garage List
2009 128i  [0.00]
1972 3.0CS  [5.00]
We had clogged sunroof drains that soaked the TPM in out 328xiT. The gauges would randomly go to the max value, and dash lights would randomly go on, and the ABS stopped working.
__________________
'09 128i - Black Sapphire Metallic\Coral Red\Glacier Silver\N51 DISA\6MT\Navigation\Premium\M-Sport\Heated seats\Xenon Headlights\iPod\Smartphone\Euro Delivery

Appreciate 0
      11-11-2016, 04:42 PM   #3
CrisCrossAppleSauce
Private
6
Rep
65
Posts

Drives: 09 Lemans Blue 135i
Join Date: Oct 2016
Location: SoCal

iTrader: (0)

Did you end up solving this issue as i got water in mine as well an it gave me the same issues now it wont start.
Appreciate 0
      11-11-2016, 06:39 PM   #4
The Wind Breezes
Major
361
Rep
1,312
Posts

Drives: 135i N55 DCT
Join Date: Apr 2015
Location: USA

iTrader: (0)

Quote:
Originally Posted by CrisCrossAppleSauce View Post
Did you end up solving this issue as i got water in mine as well an it gave me the same issues now it wont start.
Remove the board, disassemble to the extent that's practical and thoroughly dry it...if it doesn't work after that you'll probably want to get a new one.
Appreciate 0
      11-11-2016, 07:19 PM   #5
CrisCrossAppleSauce
Private
6
Rep
65
Posts

Drives: 09 Lemans Blue 135i
Join Date: Oct 2016
Location: SoCal

iTrader: (0)

Quote:
Originally Posted by The Wind Breezes View Post
Remove the board, disassemble to the extent that's practical and thoroughly dry it...if it doesn't work after that you'll probably want to get a new one.
Okay good i just did that, after further inspection my keyless module had water in it, too so i did the same, hoping this is the cause as to my car not starting. Since it wasnt the battery.
Appreciate 0
      11-13-2016, 03:43 PM   #6
DaZuc
Congrats u played ya self
United_States
137
Rep
742
Posts

Drives: 335i xDrive
Join Date: Sep 2014
Location: Rockland, NY

iTrader: (10)

Garage List
OT

Where is the TPM module located in the trunk?
Appreciate 0
      11-14-2016, 03:33 AM   #7
CrisCrossAppleSauce
Private
6
Rep
65
Posts

Drives: 09 Lemans Blue 135i
Join Date: Oct 2016
Location: SoCal

iTrader: (0)

Quote:
Originally Posted by DaZuc View Post
OT

Where is the TPM module located in the trunk?
It's in the trunk on the passenger side.
Remove the carpet/liner and you'll see it towards the bottom!
Appreciate 1
Post Reply

Bookmarks

Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off


All times are GMT -4. The time now is 12:41 AM.




1addicts
Powered by vBulletin® Version 3.7.0
Copyright ©2000 - 2017, Jelsoft Enterprises Ltd.
1Addicts.com, BIMMERPOST.com, E90Post.com, F30Post.com, M3Post.com, ZPost.com, 5Post.com, 6Post.com, 7Post.com, XBimmers.com logo and trademark are properties of BIMMERPOST