BMW 1 Series Coupe Forum / 1 Series Convertible Forum (1M / tii / 135i / 128i / Coupe / Cabrio / Hatchback) (BMW E82 E88 128i 130i 135i)
 





 

Post Reply
 
Thread Tools Search this Thread
      09-23-2017, 11:45 PM   #1
Bones in AK
New Member
3
Rep
15
Posts

Drives: 2011 128i
Join Date: Aug 2017
Location: Anchorage, AK

iTrader: (1)

Rough Idle 2011 128i

Okay I have done a search and have found similar problems but not the same. Only when stopped in gear (auto) it will drop 150-200 rpm return to normal. It happens with AC on or off (one of the checks from other posts) and is not constant it does not do it all the time. Any ideas?
Appreciate 0
      09-25-2017, 07:48 AM   #2
02Pilot
Private
33
Rep
98
Posts

Drives: 128i
Join Date: Jul 2017
Location: NY

iTrader: (0)

First thing I'd be looking for is a vacuum leak post-MAF. Check for loose clamps and cracks in tubing, especially around bends. A smoke test is the sure way to find it, but requires special equipment.

Have you pulled fault codes, and if so, what are they? I'd strongly encourage doing this, as it may make it much easier to locate the issue.
Appreciate 1
      09-25-2017, 10:10 PM   #3
Bones in AK
New Member
3
Rep
15
Posts

Drives: 2011 128i
Join Date: Aug 2017
Location: Anchorage, AK

iTrader: (1)

No check engine light. This is my first "Modern" BMW car so have not gotten a code reader yet. I can do a vac. test but not until Thursday. I am planning on getting new Plugs and Coils. Are there any Aftermarket Coils or stock the only choice? how about suggestions for Code Readers?
Appreciate 0
      09-26-2017, 02:28 AM   #4
ArmatageShanks
Private First Class
21
Rep
148
Posts

Drives: 2011 BMW 128i, 6MT
Join Date: May 2015
Location: Orange County, CA

iTrader: (0)

Could it possibly be the coils? I have a 2011 128i and apparently it came with faulty coil packs from the factory that lasted only 40k miles. I was having issues with my rpm's when it was happening.
Appreciate 0
      09-26-2017, 07:27 AM   #5
02Pilot
Private
33
Rep
98
Posts

Drives: 128i
Join Date: Jul 2017
Location: NY

iTrader: (0)

It could be the coils, or it could be something else, or a combination of factors. The big plus to having a proper code reader is that you can avoid throwing parts at the car by accurately diagnosing the issue before you start. I use the Foxwell NT510 from ECS that comes pre-loaded with the BMW-specific software, but there are plenty of other options, depending on how deep you want to be able to go and how quickly you want it to work out of the box.

That said, being an old school sort of mechanic, the ignition would be a reasonable suspect, though I still think a vacuum leak is the more likely culprit. I would stick to OEM for the coils.
Appreciate 0
      09-28-2017, 02:53 PM   #6
Jrfly9
New Member
1
Rep
21
Posts

Drives: 2011 128i Msport
Join Date: Jun 2016
Location: 'Merica

iTrader: (0)

I have had this same issue, both before and after my AA headers, tune, exhaust, etc. I have had my local Dealer check it out with no pending codes.

In addition to the rough idle my engine has also died when cruising to a stop. Still confused at what it is. At the moment, my best guess is MAP sensor (need to clean) or the contact between the spark plug and the coil pack boot (saw this as a possible solution on the e92 forum.

Should note that I am manual, if that matters
Appreciate 0
      09-28-2017, 07:43 PM   #7
Crazydad
New Member
0
Rep
9
Posts

Drives: 11' 128i M-Sport, AT, LeMans
Join Date: Sep 2017
Location: Texas

iTrader: (0)

I just ordered the foxwell/schwaben for ECS tuning, it's on sale 15% off until tomorrow or so. I think $169.
Appreciate 0
      10-01-2017, 10:45 PM   #8
RedRanger
Lieutenant
RedRanger's Avatar
34
Rep
535
Posts

Drives: 2008 128i Sedona Red
Join Date: Mar 2014
Location: St. Louis, MO

iTrader: (2)

Quote:
Originally Posted by Jrfly9 View Post
I have had this same issue, both before and after my AA headers, tune, exhaust, etc. I have had my local Dealer check it out with no pending codes.

In addition to the rough idle my engine has also died when cruising to a stop. Still confused at what it is. At the moment, my best guess is MAP sensor (need to clean) or the contact between the spark plug and the coil pack boot (saw this as a possible solution on the e92 forum.

Should note that I am manual, if that matters
Mine did the same. Still haven't figured out what is wrong with it.
__________________
2008 Sedona Red 128i
Black Chrome powder coated VMR 710's 18's, Carbon fiber engine bay cover and intake, Carbon fiber interior trim,
Demon eyebrows, euro intake, performance brace, black grills, Magnaflow exhaust, Stage 3IM, AA Tune
Appreciate 0
      10-11-2017, 02:45 PM   #9
Jrfly9
New Member
1
Rep
21
Posts

Drives: 2011 128i Msport
Join Date: Jun 2016
Location: 'Merica

iTrader: (0)

Died again rolling to a stop light, getting pretty annoying. Also dangerous when I'm headed into a turn and power steering cuts out
Appreciate 0
      10-13-2017, 12:21 PM   #10
TheBigChill
Private
6
Rep
51
Posts

Drives: 2009 128i 6MT Sport
Join Date: Jul 2017
Location: Troy, NY

iTrader: (0)

You should really take the time to build a cheap leak/smoke detector. It could save you a lot of time and money. I made one for $8 walking around a hardware store.

Good luck.

Last edited by TheBigChill; 10-17-2017 at 11:35 AM.
Appreciate 0
      11-11-2017, 11:15 AM   #11
wolfe
Lieutenant
wolfe's Avatar
78
Rep
569
Posts

Drives: 128i M-Sport
Join Date: Apr 2010
Location: USA

iTrader: (1)

Quote:
Originally Posted by Jrfly9 View Post
Died again rolling to a stop light, getting pretty annoying. Also dangerous when I'm headed into a turn and power steering cuts out
Have you had the vanos bolt recall done?
Appreciate 0
      11-11-2017, 02:30 PM   #12
Bimmer-Bob
!
Bimmer-Bob's Avatar
United_States
313
Rep
3,137
Posts

Drives: 2010 128i
Join Date: Feb 2010
Location: Anacortes, WA

iTrader: (4)

Garage List
Quote:
Originally Posted by Bones in AK View Post
No check engine light. This is my first "Modern" BMW car so have not gotten a code reader yet. I can do a vac. test but not until Thursday. I am planning on getting new Plugs and Coils. Are there any Aftermarket Coils or stock the only choice? how about suggestions for Code Readers?
The car can store fault codes without triggering a CEL. You should definitely try pulling them - I can't imagine the engine would stall multiple times without the DME logging something.
__________________
____________________________
Appreciate 0
      11-14-2017, 03:21 PM   #13
Jrfly9
New Member
1
Rep
21
Posts

Drives: 2011 128i Msport
Join Date: Jun 2016
Location: 'Merica

iTrader: (0)

Quote:
Originally Posted by wolfe View Post
Have you had the vanos bolt recall done?

Interesting, I was totally unaware of this recall. I searched my VIN on BMW's recall section and this is not listed. Searching through some older threads, circa 2014, my build date and engine seem to fail in line with the recall. Strange.

Anyone have any other information on this?


Thanks!
Mark
Appreciate 0
      11-14-2017, 07:19 PM   #14
02Pilot
Private
33
Rep
98
Posts

Drives: 128i
Join Date: Jul 2017
Location: NY

iTrader: (0)

If it doesn't show as pending in the database it's likely already been done.
Appreciate 0
      11-16-2017, 09:37 PM   #15
wolfe
Lieutenant
wolfe's Avatar
78
Rep
569
Posts

Drives: 128i M-Sport
Join Date: Apr 2010
Location: USA

iTrader: (1)

Quote:
Originally Posted by 02Pilot View Post
If it doesn't show as pending in the database it's likely already been done.
They're supposed to put a decal in the driver's door jamb too, right?

3 of the 4 exhaust vanos bolts had loosened on my car, it would stall sometimes and eventually threw the vanos unit jammed/stiff code.
Appreciate 0
      11-17-2017, 01:43 AM   #16
Bimmer-Bob
!
Bimmer-Bob's Avatar
United_States
313
Rep
3,137
Posts

Drives: 2010 128i
Join Date: Feb 2010
Location: Anacortes, WA

iTrader: (4)

Garage List
Quote:
Originally Posted by wolfe View Post
They're supposed to put a decal in the driver's door jamb too, right?
First I've heard of this...I mean, makes sense, but I don't recall seeing a decal, and I've definitely had the VANOS recall done (and the two before that).
__________________
____________________________
Appreciate 0
      Yesterday, 12:08 PM   #17
wolfe
Lieutenant
wolfe's Avatar
78
Rep
569
Posts

Drives: 128i M-Sport
Join Date: Apr 2010
Location: USA

iTrader: (1)

Interesting. I haven't had any recalls performed yet (by the dealer anyway). The label is mentioned in the recall campaign bulletin.

Kind of glad to hear this honestly; the stickers could add up fast since we're up to what, 5 or so recalls on the e82 now?
Attached Images
 
Appreciate 0
Post Reply

Bookmarks

Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off


All times are GMT -4. The time now is 09:04 AM.




1addicts
Powered by vBulletin® Version 3.7.0
Copyright ©2000 - 2017, Jelsoft Enterprises Ltd.
1Addicts.com, BIMMERPOST.com, E90Post.com, F30Post.com, M3Post.com, ZPost.com, 5Post.com, 6Post.com, 7Post.com, XBimmers.com logo and trademark are properties of BIMMERPOST