BMW 1 Series Coupe Forum / 1 Series Convertible Forum (1M / tii / 135i / 128i / Coupe / Cabrio / Hatchback) (BMW E82 E88 128i 130i 135i)
 





 

Post Reply
 
Thread Tools Search this Thread
      07-26-2017, 09:25 PM   #1
claasmi
Private
19
Rep
56
Posts

Drives: 2011 128i 6MT
Join Date: Jun 2015
Location: Toronto

iTrader: (0)

Garage List
2011 128i  [0.00]
RPM fluctuating constantly after header install + tune

I just installed AA headers + AA offroad tune. On cold start the engine idles fine, but after its warmed up it fluctuates up and down constantly about once a second. At idle the needle dips maybe 100 - 200 rpm down and back up, over and over again very consistently. In gear at low RPM I can also feel it fluctuating. The only code I am getting is:

Fuel Pump:
CED4
Externer Fehler: CAN-ID 0xAA (TORQUE_3) fehlte(e)

The headers were installed by a reputable shop and I cleared all adaptations after putting the tune on. I did just yesterday also install a 3 stage intake (myself) but it was running totally fine before the headers went on.

Any ideas what the issue could be?
Appreciate 0
      07-27-2017, 12:46 AM   #2
desertman123
CERTIFIED
desertman123's Avatar
United_States
258
Rep
701
Posts

Drives: '08 128i
Join Date: May 2016
Location: Orlando, FL

iTrader: (0)

Garage List
2008 BMW 128i  [5.00]
Double check EVERYTHING and make sure there's no vacuum leaks, particularly on the intake side. Check vacuum lines, clean MAF, clean VANOS solenoids. Make sure your oil breather isn't cracked.

Also pull the battery terminal for like 15 minutes. Maybe you just need to clear adaptations since you have a pretty major change to the breathing of the engine?
__________________
PM me if you're selling 1-series rear mudflaps or side/rear sunshades!

My 2008 128i - Sparkling Graphite/Beige - Sport pkg - 6MT
Parents' 2014 528i - Mineral White/Ivory White - fully loaded
Appreciate 0
      07-27-2017, 11:40 AM   #3
claasmi
Private
19
Rep
56
Posts

Drives: 2011 128i 6MT
Join Date: Jun 2015
Location: Toronto

iTrader: (0)

Garage List
2011 128i  [0.00]
I had an issue after installing the 3 stage intake a few days before (turns out I just forgot to plug a hose in) so I had already thoroughly checked all the connections on the intake side. Also I did clear all adaptations already using BAV cable. Is there any chance this would be caused by something on the exhaust side? (a leak either between the headers and the engine or the headers and the mid pipe) as this was the only part I didn't personally do and check myself. It seems too much of a coincidence for it to be something not directly related to the headers as everything was totally fine right up until the headers and tune went on.
Appreciate 0
      07-27-2017, 11:48 AM   #4
crowtrobot
Private
30
Rep
96
Posts

Drives: 2011 128i
Join Date: Sep 2015
Location: Ithaca, NY

iTrader: (1)

Try pulling the battery cable and let it sit for a while. I had some pretty bad idle surging after I did the AA headers, tried doing the pedal dance as suggested by AA to reset the adaptations, but this didn't help.

Idle surge went away after disconnecting the battery for a different job.

If not that, perhaps the shop mixed up the O2 sensor connections? If you can check the O2 sensor output, my recollection is that one will be max'd out if they are reversed.
Appreciate 0
      07-27-2017, 12:27 PM   #5
claasmi
Private
19
Rep
56
Posts

Drives: 2011 128i 6MT
Join Date: Jun 2015
Location: Toronto

iTrader: (0)

Garage List
2011 128i  [0.00]
Well, I just went for a drive on the highway for a bit, maintaining steady rpm around 3000 for about 20 minutes and the issue seems to be gone now. Now I'll just wait and see if it comes back.
Appreciate 0
      07-30-2017, 10:57 AM   #6
Bimmer-Bob
!
Bimmer-Bob's Avatar
United_States
307
Rep
3,137
Posts

Drives: 2010 128i
Join Date: Feb 2010
Location: Anacortes, WA

iTrader: (4)

Garage List
Check for codes, too. I had surging idle when warm - it started after a header install, so I figured it was related, and it sort of seemed to come and go. I think to some extent, it's normal as the car learns to adjust fueling, but I finally checked codes and had several faults stored related to the eccentric shaft sensor (no CEL or SES). I changed that and it seems to have improved significantly (although it took several drive cycles).

Just a thought - I think it never hurts to check codes on these cars as a regular part tof your diagnostics, no matter what the issue is. After all, that's where the dealer techs are going to start!
__________________
____________________________
Appreciate 0
      07-30-2017, 12:13 PM   #7
desertman123
CERTIFIED
desertman123's Avatar
United_States
258
Rep
701
Posts

Drives: '08 128i
Join Date: May 2016
Location: Orlando, FL

iTrader: (0)

Garage List
2008 BMW 128i  [5.00]
Quote:
Originally Posted by Bimmer-Bob View Post
Just a thought - I think it never hurts to check codes on these cars as a regular part tof your diagnostics, no matter what the issue is. After all, that's where the dealer techs are going to start!
Ain't that the truth!!! I scanned my parent's 5 series the other day, just to see what popped up.

Multiple misfire codes!! Even though it never shook, felt fine, no CEL/SES, etc. When I mentioned it to my mom she figured that's why she feels like she's always filling up the gas tank.
__________________
PM me if you're selling 1-series rear mudflaps or side/rear sunshades!

My 2008 128i - Sparkling Graphite/Beige - Sport pkg - 6MT
Parents' 2014 528i - Mineral White/Ivory White - fully loaded
Appreciate 0
      07-30-2017, 04:43 PM   #8
needexhaust
New Member
0
Rep
29
Posts

Drives: 2012 BMW 128I
Join Date: Sep 2016
Location: Mississauga

iTrader: (0)

Which device do you guys use to scan codes?
Appreciate 0
      07-30-2017, 05:56 PM   #9
Bimmer-Bob
!
Bimmer-Bob's Avatar
United_States
307
Rep
3,137
Posts

Drives: 2010 128i
Join Date: Feb 2010
Location: Anacortes, WA

iTrader: (4)

Garage List
Quote:
Originally Posted by needexhaust View Post
Which device do you guys use to scan codes?
I use the same laptop with Simon 3 cable and software that I used to load the AA tune. I also have INPA and NCS Expert loaded on the same laptop (have to use a different cable, though), but I find the Simon 3 to be the fastest and easiest way to check and clear codes. A handheld device would probably be even easier and quicker, but I already had what I'm using.
__________________
____________________________
Appreciate 0
      07-30-2017, 07:38 PM   #10
claasmi
Private
19
Rep
56
Posts

Drives: 2011 128i 6MT
Join Date: Jun 2015
Location: Toronto

iTrader: (0)

Garage List
2011 128i  [0.00]
Quote:
Originally Posted by needexhaust View Post
Which device do you guys use to scan codes?
I use the Bavarian Technic cable and software. Its really overkill for what I use it for, but it can do a lot things like read sensor values in real time and send control signals like resetting adaptations. The Simon3 tool never really worked for me to do anything other than uploading the tune. I was getting codes using the Bav cable when the Simon3 tool didn't show anything. The only issue I found with the Bav cable was it never worked on Windows 7 for me, I ended up having to use a VM with Windows XP. This might be because I am running Windows in bootcamp on a Macbook, although the Simon3 cable works fine without a VM.
Appreciate 0
      08-01-2017, 10:15 AM   #11
desertman123
CERTIFIED
desertman123's Avatar
United_States
258
Rep
701
Posts

Drives: '08 128i
Join Date: May 2016
Location: Orlando, FL

iTrader: (0)

Garage List
2008 BMW 128i  [5.00]
Quote:
Originally Posted by needexhaust View Post
Which device do you guys use to scan codes?
CarlyBMW, because I'm a cheapass and also don't feel like learning how to use all the fancy BMW tools.
__________________
PM me if you're selling 1-series rear mudflaps or side/rear sunshades!

My 2008 128i - Sparkling Graphite/Beige - Sport pkg - 6MT
Parents' 2014 528i - Mineral White/Ivory White - fully loaded
Appreciate 0
      08-07-2017, 03:46 PM   #12
needexhaust
New Member
0
Rep
29
Posts

Drives: 2012 BMW 128I
Join Date: Sep 2016
Location: Mississauga

iTrader: (0)

Quote:
Originally Posted by desertman123 View Post
CarlyBMW, because I'm a cheapass and also don't feel like learning how to use all the fancy BMW tools.
This is what I was looking for 😂
Appreciate 0
Post Reply

Bookmarks

Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off


All times are GMT -4. The time now is 09:04 PM.




1addicts
Powered by vBulletin® Version 3.7.0
Copyright ©2000 - 2017, Jelsoft Enterprises Ltd.
1Addicts.com, BIMMERPOST.com, E90Post.com, F30Post.com, M3Post.com, ZPost.com, 5Post.com, 6Post.com, 7Post.com, XBimmers.com logo and trademark are properties of BIMMERPOST