BMW 1 Series Coupe Forum / 1 Series Convertible Forum (1M / tii / 135i / 128i / Coupe / Cabrio / Hatchback) (BMW E82 E88 128i 130i 135i)
 





 

Post Reply
 
Thread Tools Search this Thread
      08-24-2017, 11:21 AM   #1
rominun
First Lieutenant
rominun's Avatar
United_States
38
Rep
357
Posts

Drives: 2008 Bmw 135i
Join Date: Sep 2016
Location: So-Cal

iTrader: (0)

AC Blower Fix

So after my AC stopped working, I decided to jump into fixing it. I could hear that the compressor was turning on when the car idled, so I ruled that out. The car had enough freon because I could feel the vents getting cold but there was no air being pushed out. I then figured my Blower motor was bad. I went in the passenger footwell, took off the bottom cover and found my issue. The connector going to the Blower motor resistor was all corroded and was making contact with every wire that was exposed. Went to the dealer and bought the connector and the crimping pins (was $36 :/). When I got home, I crimped the pins to the wire, added heat shrink and tada, everything worked. Since my resistor looked all chewed up, I might end up buying a new one if the problem happens again. I've seen this problem going around the e90 forums so I decided to post it here.
__________________
2008 Bmw FBO 135i Droptop
Mods: VRSF Downpipes, VRSF 7" Intercooler, Active Autowerke Charge Pipe, Precision Raceworks Inlets, Fuel-it Stage 1 Inline Fuel Pump, BMW PE Mod w/ cutout valve, ST coilovers, MFactory SMFW, 335is Clutch, BMW Performance Short Shifter, JB4 w/ MHD Backend Flash, 3.46 Gear Ratio
Appreciate 0
      08-24-2017, 11:23 AM   #2
rominun
First Lieutenant
rominun's Avatar
United_States
38
Rep
357
Posts

Drives: 2008 Bmw 135i
Join Date: Sep 2016
Location: So-Cal

iTrader: (0)

Here are some pictures of the connection points.
Attached Images
     
__________________
2008 Bmw FBO 135i Droptop
Mods: VRSF Downpipes, VRSF 7" Intercooler, Active Autowerke Charge Pipe, Precision Raceworks Inlets, Fuel-it Stage 1 Inline Fuel Pump, BMW PE Mod w/ cutout valve, ST coilovers, MFactory SMFW, 335is Clutch, BMW Performance Short Shifter, JB4 w/ MHD Backend Flash, 3.46 Gear Ratio
Appreciate 1
      08-24-2017, 11:50 AM   #3
1and1
Loves me some MHD!
1and1's Avatar
United_States
260
Rep
602
Posts

Drives: faster than he should...
Join Date: Jul 2016
Location: Tally, FL

iTrader: (1)

Garage List
'09 135i  [5.00]
wow- that's particularly special ain't it!
Thanks for posting and the pics.

If you get a moment, and have the receipt still handy, add the part numbers for the connector & pins you picked up
__________________
1and1
135i - E82.N54 2009 BSM - MHD / A/T & custom xHP flash / Drop-in / PR CP
X1 - E84.N20 2013 MGM - Stock - The Wife's
Appreciate 0
      08-24-2017, 12:25 PM   #4
rominun
First Lieutenant
rominun's Avatar
United_States
38
Rep
357
Posts

Drives: 2008 Bmw 135i
Join Date: Sep 2016
Location: So-Cal

iTrader: (0)

Quote:
Originally Posted by 1and1 View Post
wow- that's particularly special ain't it!
Thanks for posting and the pics.

If you get a moment, and have the receipt still handy, add the part numbers for the connector & pins you picked up
I'll be sure to add those when I get home.
__________________
2008 Bmw FBO 135i Droptop
Mods: VRSF Downpipes, VRSF 7" Intercooler, Active Autowerke Charge Pipe, Precision Raceworks Inlets, Fuel-it Stage 1 Inline Fuel Pump, BMW PE Mod w/ cutout valve, ST coilovers, MFactory SMFW, 335is Clutch, BMW Performance Short Shifter, JB4 w/ MHD Backend Flash, 3.46 Gear Ratio
Appreciate 0
      08-24-2017, 01:07 PM   #5
Tarpon
New Member
Tarpon's Avatar
United_States
4
Rep
16
Posts

Drives: 2008 128i
Join Date: Jan 2014
Location: Ft.Lauderdale,Fl

iTrader: (0)

I have some intermittent symptoms where when on max ac the blower still blows max for a few minutes after I turn it down. But, if I turn it off then back on it blows the correct speed thats selected. I've also had on a few hot days, the blower doesn't come on until I drive away. That makes me think it might be the corroded connections. Did you have sny similar symptoms before it stopped working ?
Appreciate 0
      08-24-2017, 01:30 PM   #6
rominun
First Lieutenant
rominun's Avatar
United_States
38
Rep
357
Posts

Drives: 2008 Bmw 135i
Join Date: Sep 2016
Location: So-Cal

iTrader: (0)

Quote:
Originally Posted by Tarpon View Post
I have some intermittent symptoms where when on max ac the blower still blows max for a few minutes after I turn it down. But, if I turn it off then back on it blows the correct speed thats selected. I've also had on a few hot days, the blower doesn't come on until I drive away. That makes me think it might be the corroded connections. Did you have sny similar symptoms before it stopped working ?
You basically had the same symptoms as me, but mine were far worse. I would be driving in the city with the AC on all the time and it would never work. After driving on fwy for over 30 min, it would start to work and after shutting the car off, it wouldn't work. It would just come and go so I decided to take a look yesterday and figured out my problem. Take the bottom cover off the passenger footwell under the dash (2 torqx screw) and you'll see the Blower motor right there.
__________________
2008 Bmw FBO 135i Droptop
Mods: VRSF Downpipes, VRSF 7" Intercooler, Active Autowerke Charge Pipe, Precision Raceworks Inlets, Fuel-it Stage 1 Inline Fuel Pump, BMW PE Mod w/ cutout valve, ST coilovers, MFactory SMFW, 335is Clutch, BMW Performance Short Shifter, JB4 w/ MHD Backend Flash, 3.46 Gear Ratio
Appreciate 0
      08-25-2017, 11:36 AM   #7
Tarpon
New Member
Tarpon's Avatar
United_States
4
Rep
16
Posts

Drives: 2008 128i
Join Date: Jan 2014
Location: Ft.Lauderdale,Fl

iTrader: (0)

Thanks. I'll take a look.
Appreciate 0
Post Reply

Bookmarks

Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off


All times are GMT -4. The time now is 02:12 PM.




1addicts
Powered by vBulletin® Version 3.7.0
Copyright ©2000 - 2017, Jelsoft Enterprises Ltd.
1Addicts.com, BIMMERPOST.com, E90Post.com, F30Post.com, M3Post.com, ZPost.com, 5Post.com, 6Post.com, 7Post.com, XBimmers.com logo and trademark are properties of BIMMERPOST