BMW 1 Series Coupe Forum / 1 Series Convertible Forum (1M / tii / 135i / 128i / Coupe / Cabrio / Hatchback) (BMW E82 E88 128i 130i 135i)
 





 

Post Reply
 
Thread Tools Search this Thread
      08-23-2010, 08:29 PM   #1
johnnis
New Member
2
Rep
9
Posts

Drives: bmw e87 hatchback
Join Date: Aug 2010
Location: cyprus

iTrader: (0)

air intake system

hello!! few months ago i changed the filter of my car and i remove the down piece of the box( where the filter was) and after a month my engine got full of water....so i decided to change the original air intake system with other one....does anybody have any idea what is the best to do?? btw my car is 116i
Appreciate 0
      08-24-2010, 11:19 AM   #2
blingers
Private First Class
blingers's Avatar
11
Rep
198
Posts

Drives: Pre-LCI 130i
Join Date: Jun 2010
Location: sydney

iTrader: (0)

do you have any photos of what you remove in the airbox? and when you said the engine got full of water you mean it hydrolocked or the engine bay was full of water?
Appreciate 0
      08-24-2010, 11:23 AM   #3
Metralha
Private First Class
Metralha's Avatar
7
Rep
176
Posts

Drives: BMW 120d E81 - 2007/09
Join Date: Oct 2009
Location: Portugal

iTrader: (0)

116i.....leave it stock is the best you can dp....
__________________


Appreciate 0
      08-24-2010, 08:05 PM   #4
johnnis
New Member
2
Rep
9
Posts

Drives: bmw e87 hatchback
Join Date: Aug 2010
Location: cyprus

iTrader: (0)

bmw mechanics said that the engine got full of water i dont know exactly ...
Appreciate 0
      08-28-2010, 01:16 AM   #5
blingers
Private First Class
blingers's Avatar
11
Rep
198
Posts

Drives: Pre-LCI 130i
Join Date: Jun 2010
Location: sydney

iTrader: (0)

hopefully the mechanic removed that water and yeah put back the stock airbox and see if the water still gets in or not.
Appreciate 0
      08-31-2010, 11:15 AM   #6
johnnis
New Member
2
Rep
9
Posts

Drives: bmw e87 hatchback
Join Date: Aug 2010
Location: cyprus

iTrader: (0)

my car its ok now...i would like to found out what is the best i have to by to fix in my car and no problem occur after...
Appreciate 0
Post Reply

Bookmarks

Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off


All times are GMT -4. The time now is 08:15 AM.




1addicts
Powered by vBulletin® Version 3.7.0
Copyright ©2000 - 2018, Jelsoft Enterprises Ltd.
1Addicts.com, BIMMERPOST.com, E90Post.com, F30Post.com, M3Post.com, ZPost.com, 5Post.com, 6Post.com, 7Post.com, XBimmers.com logo and trademark are properties of BIMMERPOST