BMW 1 Series Coupe Forum / 1 Series Convertible Forum (1M / tii / 135i / 128i / Coupe / Cabrio / Hatchback) (BMW E82 E88 128i 130i 135i)
 





 

Post Reply
 
Thread Tools Search this Thread
      09-21-2014, 04:47 PM   #111
Pyrat 2
Colonel
Pyrat 2's Avatar
United_States
631
Rep
2,287
Posts

Drives: Rapidly from A to B
Join Date: Jun 2005
Location: Illinois

iTrader: (2)

Garage List
1999 BMW M3  [0.00]
2016 BMW M2  [5.00]
2006 330i  [4.50]
2014 X1 2.8i xDrive  [0.00]
Quote:
Originally Posted by Dackelone View Post
You need new pad sensors. Or you can try @Ericsson.FFS way posted above.
Tried both Ericsson way and then put on a new sensor I had lying around. No go.
Appreciate 0
      09-21-2014, 05:14 PM   #112
Dackelone
European Editor
Dackelone's Avatar
Germany
6116
Rep
21,976
Posts

Drives: N54 e82
Join Date: Feb 2010
Location: Bayern, Germany

iTrader: (1)

Quote:
Originally Posted by HeelToe View Post
Tried both Ericsson way and then put on a new sensor I had lying around. No go.
Then you will need a dealer to reset you brake pad light.
__________________
Appreciate 0
      09-21-2014, 06:12 PM   #113
Pyrat 2
Colonel
Pyrat 2's Avatar
United_States
631
Rep
2,287
Posts

Drives: Rapidly from A to B
Join Date: Jun 2005
Location: Illinois

iTrader: (2)

Garage List
1999 BMW M3  [0.00]
2016 BMW M2  [5.00]
2006 330i  [4.50]
2014 X1 2.8i xDrive  [0.00]
Figured that was my next option. They owe me a free brake fluid change under warranty. Maybe they'll comp me a reset. Will probably bring it in next weekend.

In the meantime I put on some fresh Ferodo 2500s today and bedded them in. Hoping that these tolerate my track activities.
Appreciate 0
      10-24-2014, 08:51 PM   #114
Spectral
Enlisted Member
3
Rep
40
Posts

Drives: MY10 135i SBM
Join Date: Oct 2014
Location: Brisbane

iTrader: (0)

Another "thanks" from me!

Just one note, I have read above that some people are still saying they have the red car on lift icon in their dash display, even after shorting out the sensor temporarily.

I also had this, but then I turned off the car, back on again, then went back into the reset menu and reset the Inspection (car on lift) setting even though it still said another 11000km to go... and the red icon then went away. Note that my sensors were NOT worn at all. I changed the pads just in time.

So my procedure:

Swap pads (and rotors in my case)
Plug sensor in
Start car and reset front brakes (and got the ------- km message and still got inspection warnings)
Turn off car
Unplug sensor and short out the vehicle side of the sensor with a wire like above
Start car and reset front brakes (got 110000km message and still got inspection warnings (as the car knew something wasn't right)
Turn off car
Plug sensor back in
Start car and reset front brakes (got 62000km on the display which sounds better)
Turn off car - still got the red car on the lift error/warning
Start car and reset the inspection setting.
Turn off car - all messages and warnings cleared.

Whew!
Appreciate 0
      10-26-2014, 06:27 PM   #115
Dackelone
European Editor
Dackelone's Avatar
Germany
6116
Rep
21,976
Posts

Drives: N54 e82
Join Date: Feb 2010
Location: Bayern, Germany

iTrader: (1)

Quote:
Originally Posted by Spectral View Post
Another "thanks" from me!

Just one note, I have read above that some people are still saying they have the red car on lift icon in their dash display, even after shorting out the sensor temporarily.

I also had this, but then I turned off the car, back on again, then went back into the reset menu and reset the Inspection (car on lift) setting even though it still said another 11000km to go... and the red icon then went away. Note that my sensors were NOT worn at all. I changed the pads just in time.

So my procedure:

Swap pads (and rotors in my case)
Plug sensor in
Start car and reset front brakes (and got the ------- km message and still got inspection warnings)
Turn off car
Unplug sensor and short out the vehicle side of the sensor with a wire like above
Start car and reset front brakes (got 110000km message and still got inspection warnings (as the car knew something wasn't right)
Turn off car
Plug sensor back in
Start car and reset front brakes (got 62000km on the display which sounds better)
Turn off car - still got the red car on the lift error/warning
Start car and reset the inspection setting.
Turn off car - all messages and warnings cleared.

Whew!
^^Thanks for posting this update for us!
__________________
Appreciate 0
      01-11-2015, 06:04 PM   #116
Frodo135
Registered
1
Rep
1
Posts

Drives: 08 135i M-sport ED Slvr/Blk
Join Date: Nov 2014
Location: NH, USA

iTrader: (0)

I was able to reset the Service Due indicator without a problem, resetting the oil change interval, brake change interval and service due date as well.
Dack, Thanks so much for this!! I did have to have the car running to get into the service reset menu, but then it worked like a charm. Initially, I kept holding it too long and getting into the software/hardware codes section.
Appreciate 1
      03-01-2015, 01:48 PM   #117
Kristy92646
Registered
United_States
1
Rep
4
Posts

Drives: 2010 BMW 135i
Join Date: Feb 2014
Location: Boston, MA

iTrader: (0)

Send a message via Yahoo to Kristy92646
Thanks! This post helped me with my first oil change and resetting the service due lights!
Appreciate 1
      03-03-2015, 08:16 PM   #118
ianc
Ex '87 Carrera
ianc's Avatar
United_States
126
Rep
1,188
Posts

Drives: '10 TiAg 6MT 135i
Join Date: Feb 2010
Location: Redwood Shores, California

iTrader: (0)

Hmmm... Not working for me for some reason. Trying to reset my oil service due light. I get in, put in key and turn on ignit, then hold trip odom button. After about 7 sec, I do see the yellow triangle with the exclamation mark, but if I release the button, it just goes away again and I don't see the service due. I can get to service due by scrolling to it with the up down button on the stalk, then press BC to enter. I can see the oil change due, but pressing BC again just exits me out to display my mileage, avg speed, etc. so I don't see the 'Reset' choice. Any ideas? THX!
__________________
"I will tell you there is a big difference between driving money and driving blood, sweat and tears." - PorscheGuy79

"I got 328 loaner and was impressed with performance. It feels much faster than my 135i." - MOCKBA
Appreciate 0
      03-03-2015, 08:36 PM   #119
Dackelone
European Editor
Dackelone's Avatar
Germany
6116
Rep
21,976
Posts

Drives: N54 e82
Join Date: Feb 2010
Location: Bayern, Germany

iTrader: (1)

Quote:
Originally Posted by ianc View Post
Hmmm... Not working for me for some reason. Trying to reset my oil service due light. I get in, put in key and turn on ignit, then hold trip odom button. After about 7 sec, I do see the yellow triangle with the exclamation mark, but if I release the button, it just goes away again and I don't see the service due. I can get to service due by scrolling to it with the up down button on the stalk, then press BC to enter. I can see the oil change due, but pressing BC again just exits me out to display my mileage, avg speed, etc. so I don't see the 'Reset' choice. Any ideas? THX!
Ian, keep holding down the trip reset button another 15 secs or so. You have to get past the hidden odo menu and into the service window. Just try again but keep holding down the trip reset button 15 second longer.

Dack
__________________
Appreciate 0
      03-04-2015, 06:41 AM   #120
Spectral
Enlisted Member
3
Rep
40
Posts

Drives: MY10 135i SBM
Join Date: Oct 2014
Location: Brisbane

iTrader: (0)

If that doesn't work, try doing it with the car running.
Appreciate 0
      03-04-2015, 12:59 PM   #121
ianc
Ex '87 Carrera
ianc's Avatar
United_States
126
Rep
1,188
Posts

Drives: '10 TiAg 6MT 135i
Join Date: Feb 2010
Location: Redwood Shores, California

iTrader: (0)

Thanks Dack! I dunno what went wrong the first time; it seemed like I went straight from the yellow triangle to the hidden menu and didn't see the service menu. I went out and tried it again (ignit on but engine off) and saw the service menu come up a few secs after the yellow triangle this time, and was able to clear the oil service warning.

I guess the real cause is I'm just a moron...

ianc
__________________
"I will tell you there is a big difference between driving money and driving blood, sweat and tears." - PorscheGuy79

"I got 328 loaner and was impressed with performance. It feels much faster than my 135i." - MOCKBA
Appreciate 1
      04-22-2015, 01:54 PM   #122
JimD
Brigadier General
JimD's Avatar
110
Rep
3,077
Posts

Drives: 128i convertible
Join Date: Apr 2009
Location: Lexington, SC

iTrader: (0)

I got the "service soon" light and went through all the service intervals to set them well into the future. I don't really use them and my car is out of warranty. But I still had the light. So I hooked up "torque" and looked for errors. I had the dreaded gas cap code (evaporative system warning). I had already got something on the dash that my wife thought was the gas cap so I had tightened it. But the light was on. So I used Torque to reset the error and now the service soon light is out.

On my other cars, I get the check engine light for a evaporative system issue but on my bimmer, it is the service soon light. New one for me. It isn't resettable using this otherwise excellent sticky, however.
__________________
128i Convertible, MT, Alpine White, Black Top, Taupe Leatherette, Walnut, Sport
Ordered 5/22/09, Completed 6/4/09, At Port 6/9/09, On the Georgia Highway 6/13/09, Ship Arrived Charleston 6/24/09 at 10pm, PCD 7/21/09
Appreciate 1
      04-22-2015, 03:39 PM   #123
Dackelone
European Editor
Dackelone's Avatar
Germany
6116
Rep
21,976
Posts

Drives: N54 e82
Join Date: Feb 2010
Location: Bayern, Germany

iTrader: (1)

Quote:
Originally Posted by JimD View Post
I got the "service soon" light and went through all the service intervals to set them well into the future. I don't really use them and my car is out of warranty. But I still had the light. So I hooked up "torque" and looked for errors. I had the dreaded gas cap code (evaporative system warning). I had already got something on the dash that my wife thought was the gas cap so I had tightened it. But the light was on. So I used Torque to reset the error and now the service soon light is out.

On my other cars, I get the check engine light for a evaporative system issue but on my bimmer, it is the service soon light. New one for me. It isn't resettable using this otherwise excellent sticky, however.

Thanks for the great feedback!
__________________
Appreciate 0
      05-01-2015, 04:40 PM   #124
DietTab
First Lieutenant
DietTab's Avatar
8
Rep
324
Posts

Drives: 08 135i
Join Date: May 2014
Location: Manhattan, KS

iTrader: (2)

Quote:
Originally Posted by Dackelone View Post
I've had that "car on a lift" icon light up on my BC before. I used this same DIY to reset it. I did not have to take it to a dealer.

Attachment 1076501
You can not reset this from the stalk once it turns red and says "SERVICE". Just pointing that out. You can only reset it up until the actual due time, once you hit that point, you're SOL.
__________________
LSXOCET - 404rwhp @ 1600 lbs curb weight... bonkers fast
Appreciate 1
      07-22-2015, 08:22 PM   #125
dbronnik
Lieutenant
dbronnik's Avatar
111
Rep
461
Posts

Drives: N54 E88
Join Date: Mar 2012
Location: California

iTrader: (3)

Garage List
Thanks Dackelone! (funny story, I was at the dealer for something else and asked how much it would cost to reset the light. They told me it would be 140$ to connect my car to their computer to reset the light. I laughed and said no thanks, then they came back to me and said it would be just 70$ for the brake service light... hilarious!)

Quote:
Originally Posted by DietTab View Post
You can not reset this from the stalk once it turns red and says "SERVICE". Just pointing that out. You can only reset it up until the actual due time, once you hit that point, you're SOL.
Hmm which service does that apply to? I just reset my brake service lights for front and rear with -2k overdue on the front and 10k to due in the rear.
__________________
Appreciate 1
      08-03-2015, 05:09 AM   #126
swagon
Brigadier General
swagon's Avatar
No_Country
2272
Rep
3,993
Posts

Drives: E82|N55|6MT
Join Date: Jun 2013
Location: .

iTrader: (0)

Discovered the method on Youtube, but it is the same as Dackelone's. Replaced the brake pads and fluid on our E91 last November at home so naturally the brake pad light went on. At our shop they couldn't get rid of it, been like that until now when I discovered this "secret" method. I can't believe I found it out just now LOL. The car's silent now.
__________________
Appreciate 1
      09-07-2015, 05:40 PM   #127
JohnnyG_TO
Enlisted Member
7
Rep
33
Posts

Drives: 135i - 2011
Join Date: Jun 2014
Location: Canada

iTrader: (0)

Quote:
Originally Posted by DietTab View Post
You can not reset this from the stalk once it turns red and says "SERVICE". Just pointing that out. You can only reset it up until the actual due time, once you hit that point, you're SOL.
I planned on changing spark plugs this weekend and wanted to wait until that was done before I reset this, which turned red about a week ago. When I read this post earlier in the morning, I was pissed that I waited! But I tried it anyway and it worked just fine. This is on a 2011 135.
Appreciate 1
      10-07-2015, 01:39 PM   #128
dcaron9999
Major
dcaron9999's Avatar
Canada
99
Rep
1,405
Posts

Drives: 2011 135i M package
Join Date: Jan 2010
Location: Mirabel, Quebec

iTrader: (0)

Found the SI B34 03 13 service bulletin on the BMW TIS entitled, "Incorrect Remaining Service Life from CBS Data for Brake pads".

It applies to E8x,E9X, F2X, F3X chassis ...

Situation: The yellow “Service Due” warning message lights up in the instrument cluster, even though the brake pad thickness is more than 4.2mm (above the thickness at which the pad sensor intervenes). The calculated remaining service life for the brake pads (front and/or rear axle) from the CBS data does not match the actual brake pad thickness.

The fix is a software update on the "Brake pad correction CBS conversion" module ...
After programming, the vehicle CBS data must be corrected.
In the diagnostic menu item “Front/rear brake”, select “Reset forecast to 50,000km” and then reset the forecast distance. In the diagnostic menu item “Front/rear brake”, select “Set availability, enter the brake pad thickness” and enter the pad thickness measured in mm. If the service counter increases after entering the actual brake pad thickness, the brake pad thickness must be entered once again. The service counter is now reset to the original value.
__________________
2011 X3 35i with M pack + 2011 135i w/6SPMT | 255 square tire setup | Quaife 3.46 LSD | Diff lock down bracket | Bilstein B8+Swift SpecR springs+H&R FSB | CDV delete | BMS Oil Tstat bypass | ER FMIC & CP | N54Tuning DP | GC Street Camber Plates | M3 FCA +guide rods+RSFB's+Tranny mounts | Manzo toe arms | Cobb Stg2 agressive tune | Hawk DTC70 brake pads | RB SS brake pistons | Goodridge SS brake lines | Custom brake cooling ducts

Last edited by dcaron9999; 10-07-2015 at 01:49 PM.
Appreciate 1
      10-13-2015, 09:08 PM   #129
spykey
New Member
0
Rep
8
Posts

Drives: 2007 BMW 118i
Join Date: Oct 2015
Location: Sydney, NSW

iTrader: (0)

where to get this software

Hi,
in one of the posting this thread, someone is using a software.

I've attached the photo that he posted.


Name:  IMG_9142.jpg
Views: 508
Size:  126.7 KB

Can someone tell me what software it is and where I can get a copy?

Thank you!
Appreciate 0
      10-14-2015, 06:53 AM   #130
Dackelone
European Editor
Dackelone's Avatar
Germany
6116
Rep
21,976
Posts

Drives: N54 e82
Join Date: Feb 2010
Location: Bayern, Germany

iTrader: (1)

Quote:
Originally Posted by spykey View Post
Hi,
in one of the posting this thread, someone is using a software.

I've attached the photo that he posted.


Attachment 1299038

Can someone tell me what software it is and where I can get a copy?

Thank you!

I posted that screen shot. The software is from Bavarian Technic (BT)... you only pay for the OBDII cable... then download the free sw from their website bellow. Its fairly easy to use. I think "BMwhat" app or "BMW Carly" app also can reset the service interval lights as well. But I have never used those apps before.


http://www.bavariantechnic.com/buy.aspx


Dackel
__________________
Appreciate 0
      10-14-2015, 07:52 AM   #131
spykey
New Member
0
Rep
8
Posts

Drives: 2007 BMW 118i
Join Date: Oct 2015
Location: Sydney, NSW

iTrader: (0)

Quote:
Originally Posted by Dackelone View Post
I posted that screen shot. The software is from Bavarian Technic (BT)... you only pay for the OBDII cable... then download the free sw from their website bellow. Its fairly easy to use. I think "BMwhat" app or "BMW Carly" app also can reset the service interval lights as well. But I have never used those apps before.


http://www.bavariantechnic.com/buy.aspx


Dackel
Looks like an awesome software but the hardware are pricey..
Appreciate 0
      10-14-2015, 08:43 AM   #132
Dackelone
European Editor
Dackelone's Avatar
Germany
6116
Rep
21,976
Posts

Drives: N54 e82
Join Date: Feb 2010
Location: Bayern, Germany

iTrader: (1)

Quote:
Originally Posted by spykey View Post
Looks like an awesome software but the hardware are pricey..
Well... most people just buy the basic($179) or enthusiast($287) BT kit. You can find them for sale on 1Addicts from time to time for under $200.

Most apps like Torque or BMwhat or Carly are way cheaper ($5 to $60). Plus you need a OBDII dongle for $30.

Dackel
__________________
Appreciate 0
Post Reply

Bookmarks

Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off


All times are GMT -4. The time now is 06:29 AM.




1addicts
Powered by vBulletin® Version 3.7.0
Copyright ©2000 - 2017, Jelsoft Enterprises Ltd.
1Addicts.com, BIMMERPOST.com, E90Post.com, F30Post.com, M3Post.com, ZPost.com, 5Post.com, 6Post.com, 7Post.com, XBimmers.com logo and trademark are properties of BIMMERPOST