BMW 1 Series Coupe Forum / 1 Series Convertible Forum (1M / tii / 135i / 128i / Coupe / Cabrio / Hatchback) (BMW E82 E88 128i 130i 135i)
 





 

Post Reply
 
Thread Tools Search this Thread
      11-13-2017, 05:24 AM   #1
Drawn05
Captain
Australia
48
Rep
841
Posts

Drives: Yes
Join Date: Dec 2010
Location: Left

iTrader: (0)

Professional Radio CD73 LCD screen problem

The heat/light appears to cause my radio's LCD screen to fade. It's not dead pixels, rather it's fine in the morning but then fades once heat/light starts to get at it.

I replaced the panel from a used Radio but it appears to not made any difference. Could be that the donor Radio also had the same flaw but I don't know...

Anyone else had this issue? How did you fix?
Appreciate 0
      11-13-2017, 05:32 AM   #2
JBT2
Private
JBT2's Avatar
Australia
7
Rep
60
Posts

Drives: 2008 E82 135i
Join Date: Oct 2016
Location: Brisbane, Australia

iTrader: (0)

It seems to be a typical problem with 1ers and 3ers of this vintage. Cr@p system from Alpine. Mine does it too.

The screen can be replaced but you're looking at about $400 to do so unless you're very handy with a soldering iron.
Appreciate 0
      11-13-2017, 06:08 AM   #3
titium
Captain
175
Rep
962
Posts

Drives: 2009 BMW 135i
Join Date: Jun 2015
Location: Sydney

iTrader: (0)

Quote:
Originally Posted by JBT2 View Post
It seems to be a typical problem with 1ers and 3ers of this vintage. Cr@p system from Alpine. Mine does it too.

The screen can be replaced but you're looking at about $400 to do so unless you're very handy with a soldering iron.
it's not that bad dont need to be skilled just need to be careful to not rip the ribbon cables. you can buy the lcd for about $90.
Appreciate 0
      11-13-2017, 06:10 AM   #4
Drawn05
Captain
Australia
48
Rep
841
Posts

Drives: Yes
Join Date: Dec 2010
Location: Left

iTrader: (0)

Yeah it's funny that the screen for the AC is likely to have suffered the same heat/light but is in great condition...but the Radio is buggered.

I have replaced the LCD screen already with another used one but it didn't fix the problem.
Appreciate 0
      12-07-2017, 08:31 AM   #5
chunho01
Private First Class
chunho01's Avatar
Australia
25
Rep
155
Posts

Drives: 125i E88 M-Sport
Join Date: Sep 2015
Location: Australia

iTrader: (0)

Same shiz here :/
So bad lately I can't even see what writing it has. It's just a jumble of orange/black. So embarrassing when I have passengers.
Appreciate 0
      12-07-2017, 05:00 PM   #6
JBT2
Private
JBT2's Avatar
Australia
7
Rep
60
Posts

Drives: 2008 E82 135i
Join Date: Oct 2016
Location: Brisbane, Australia

iTrader: (0)

Quote:
Originally Posted by titium View Post
it's not that bad dont need to be skilled just need to be careful to not rip the ribbon cables. you can buy the lcd for about $90.
Hmmm....do you have a reliable source of these LCD panels? I'd hate to throw money away on some piece of junk through Ebay etc.
Appreciate 0
      Yesterday, 05:59 PM   #7
Drawn05
Captain
Australia
48
Rep
841
Posts

Drives: Yes
Join Date: Dec 2010
Location: Left

iTrader: (0)

I fixed mine by buying a used radio and swapping the LCD panel over. Worked well however it is fiddly.
Appreciate 0
Post Reply

Bookmarks

Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off


All times are GMT -4. The time now is 09:41 PM.




1addicts
Powered by vBulletin® Version 3.7.0
Copyright ©2000 - 2017, Jelsoft Enterprises Ltd.
1Addicts.com, BIMMERPOST.com, E90Post.com, F30Post.com, M3Post.com, ZPost.com, 5Post.com, 6Post.com, 7Post.com, XBimmers.com logo and trademark are properties of BIMMERPOST