BMW 1 Series Coupe Forum / 1 Series Convertible Forum (1M / tii / 135i / 128i / Coupe / Cabrio / Hatchback) (BMW E82 E88 128i 130i 135i)
 





 

Post Reply
 
Thread Tools Search this Thread
      02-11-2018, 10:49 AM   #1
chris_flies
Wavetrac or MFactory 1.5-way?
chris_flies's Avatar
United_States
885
Rep
1,299
Posts

Drives: Enthusiastically...
Join Date: Mar 2017
Location: Woodbridge, VA, USA

iTrader: (0)

Garage List
2009 BMW 128i  [5.00]
Error Code 0093C3

Last night, for some reason, my passenger window opened unbeknownst to me, and let in LOTS of rain water (it's been raining since yesterday morning). The passenger side of the dash was wet, the door card was wet, the carpet was wet (great!), the seat was wet, the floor mats were wet, and on and on and on.

Anyways, I was driving to Lowe's this morning, and about 10 minutes after setting off, I get a red airbag light, and the seatbelt light comes on, but no dinging. 5 minutes later I pull into Lowe's and rip out Carly and run a diagnostic. No codes, but it also said "No ECU's Found" under the Airbag tab. Hmmm...

About 15 minutes later, I come out of the store, start up the car, and immediately plug-in Carly, and run another diagnostic. This time I get 3 codes. So, I clear all codes, two of the codes disappeared, but one remained, in the Airbag tab. I got this code: 0093C3, with the description OC3 from Carly. After brief research, it seems that this shows an error in the passenger's seat occupancy mat.

Can I simply dry out the sensor, and all will be fine? Or is it now shot from water damage? Any help is appreciated!

EDIT: Better question. Is the sensor separate from the bottom cushion, or is it all one unit that may need replacing? I can't find any standalone replacement sensors, and whole cushions are around $700!
__________________
2009 128i 6-Speed Coupé | Monaco Blue with Black Sensatec | chris_flies' 128i Build
"To disarm the people...was the best and most effectual way to enslave them" -George Mason
-NA Supremacy Propagandist-

Last edited by chris_flies; 02-11-2018 at 11:07 AM.
Appreciate 0
      02-11-2018, 11:40 AM   #2
chris_flies
Wavetrac or MFactory 1.5-way?
chris_flies's Avatar
United_States
885
Rep
1,299
Posts

Drives: Enthusiastically...
Join Date: Mar 2017
Location: Woodbridge, VA, USA

iTrader: (0)

Garage List
2009 BMW 128i  [5.00]
I guess now's as good a time as any to install some bucket seats!!!
__________________
2009 128i 6-Speed Coupé | Monaco Blue with Black Sensatec | chris_flies' 128i Build
"To disarm the people...was the best and most effectual way to enslave them" -George Mason
-NA Supremacy Propagandist-
Appreciate 0
      02-11-2018, 12:35 PM   #3
MightyMouseTech
Brigadier General
MightyMouseTech's Avatar
2840
Rep
4,819
Posts

Drives: 13 135i 6MT LeMans Blue MSport
Join Date: Feb 2013
Location: Ottawa, Canada

iTrader: (0)

When we get a similar code on Acuras, we start the car, turn the heat on full blast aimed at the seat, turn on the A/C, and let in run for an hour or so. Then try clearing the code. Usually works.
Appreciate 1
      02-11-2018, 01:04 PM   #4
chris_flies
Wavetrac or MFactory 1.5-way?
chris_flies's Avatar
United_States
885
Rep
1,299
Posts

Drives: Enthusiastically...
Join Date: Mar 2017
Location: Woodbridge, VA, USA

iTrader: (0)

Garage List
2009 BMW 128i  [5.00]
Quote:
Originally Posted by MightyMouseTech View Post
When we get a similar code on Acuras, we start the car, turn the heat on full blast aimed at the seat, turn on the A/C, and let in run for an hour or so. Then try clearing the code. Usually works.
Thanks! I'll try that. Would running the seat heaters help, or should I not do that since the electronics were clearly exposed to moisture?
__________________
2009 128i 6-Speed Coupé | Monaco Blue with Black Sensatec | chris_flies' 128i Build
"To disarm the people...was the best and most effectual way to enslave them" -George Mason
-NA Supremacy Propagandist-
Appreciate 0
      02-11-2018, 01:44 PM   #5
Esteban
Major General
Esteban's Avatar
United_States
2579
Rep
5,050
Posts

Drives: Because I'm Driven
Join Date: Jun 2014
Location: The Golden State

iTrader: (0)

Sorry to hear that happened. It looks like you're having your share of bad luck. I would try what MMT says. It's worth a shot. Don't think I would turn on the heated seats since, as you said, that's where some of the damage occurred.
__________________

2011 E82 N55 135i ///M Sport • 7-SP DCT • LeMans Blue/Black Boston Leather
Dinan Stage 2 • BMW Performance Suspension • PE • 313s • Blacklines • Black & Chrome Grilles • Pirelli P Zeros 225/255
Appreciate 1
      02-11-2018, 04:39 PM   #6
MightyMouseTech
Brigadier General
MightyMouseTech's Avatar
2840
Rep
4,819
Posts

Drives: 13 135i 6MT LeMans Blue MSport
Join Date: Feb 2013
Location: Ottawa, Canada

iTrader: (0)

Quote:
Originally Posted by chris_flies View Post
Quote:
Originally Posted by MightyMouseTech View Post
When we get a similar code on Acuras, we start the car, turn the heat on full blast aimed at the seat, turn on the A/C, and let in run for an hour or so. Then try clearing the code. Usually works.
Thanks! I'll try that. Would running the seat heaters help, or should I not do that since the electronics were clearly exposed to moisture?
Would not turn on heated seats. Those thin electrical wires are probably soaked with water.
Appreciate 1
      02-11-2018, 06:58 PM   #7
chris_flies
Wavetrac or MFactory 1.5-way?
chris_flies's Avatar
United_States
885
Rep
1,299
Posts

Drives: Enthusiastically...
Join Date: Mar 2017
Location: Woodbridge, VA, USA

iTrader: (0)

Garage List
2009 BMW 128i  [5.00]
No dice.
__________________
2009 128i 6-Speed Coupé | Monaco Blue with Black Sensatec | chris_flies' 128i Build
"To disarm the people...was the best and most effectual way to enslave them" -George Mason
-NA Supremacy Propagandist-
Appreciate 0
      02-12-2018, 04:20 PM   #8
chris_flies
Wavetrac or MFactory 1.5-way?
chris_flies's Avatar
United_States
885
Rep
1,299
Posts

Drives: Enthusiastically...
Join Date: Mar 2017
Location: Woodbridge, VA, USA

iTrader: (0)

Garage List
2009 BMW 128i  [5.00]
I'm gonna disconnect the battery and either pull the seat out, or pull just the module out here in a few moments...
__________________
2009 128i 6-Speed Coupé | Monaco Blue with Black Sensatec | chris_flies' 128i Build
"To disarm the people...was the best and most effectual way to enslave them" -George Mason
-NA Supremacy Propagandist-
Appreciate 0
      02-13-2018, 10:30 PM   #9
chris_flies
Wavetrac or MFactory 1.5-way?
chris_flies's Avatar
United_States
885
Rep
1,299
Posts

Drives: Enthusiastically...
Join Date: Mar 2017
Location: Woodbridge, VA, USA

iTrader: (0)

Garage List
2009 BMW 128i  [5.00]
Well, I took the passenger seat out of the car after my rain + window incident. Left it in front of a heater all day, thing was dry as a desert by the end. Put it back in the car, no dice. But, I did get a consistent signal from the airbag module, unlike before, which is progress.

As for racing seats, I think I'm going to shoot for a pair of OMP First-R's, they're FIA-Approved full bucket seats that fit my dimensions with a little room for growth. I was also recommended the Macht Schnell occupancy sensor module, but I think I'll stick with an eBay emulator, which will keep the airbag active, but will clear the error.
__________________
2009 128i 6-Speed Coupé | Monaco Blue with Black Sensatec | chris_flies' 128i Build
"To disarm the people...was the best and most effectual way to enslave them" -George Mason
-NA Supremacy Propagandist-
Appreciate 0
      02-13-2018, 10:37 PM   #10
chris_flies
Wavetrac or MFactory 1.5-way?
chris_flies's Avatar
United_States
885
Rep
1,299
Posts

Drives: Enthusiastically...
Join Date: Mar 2017
Location: Woodbridge, VA, USA

iTrader: (0)

Garage List
2009 BMW 128i  [5.00]
I just drove the car.

It was all going fine, actually. The fault cleared itself and everything was fine.

15 minutes into my drive, I decided to give the engine some go-juice, and as I surpassed 50, the lights came back on.

Came into a parking lot, shut it off, started it back up. Everything was fine again for about 15 seconds, and then it all went to hell again. I'll see what the story is tomorrow morning. Maybe my mistake was turning on the pass. side heated seats...

Oh well.
__________________
2009 128i 6-Speed Coupé | Monaco Blue with Black Sensatec | chris_flies' 128i Build
"To disarm the people...was the best and most effectual way to enslave them" -George Mason
-NA Supremacy Propagandist-
Appreciate 0
Post Reply

Bookmarks

Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off


All times are GMT -4. The time now is 12:42 PM.




1addicts
Powered by vBulletin® Version 3.7.0
Copyright ©2000 - 2018, Jelsoft Enterprises Ltd.
1Addicts.com, BIMMERPOST.com, E90Post.com, F30Post.com, M3Post.com, ZPost.com, 5Post.com, 6Post.com, 7Post.com, XBimmers.com logo and trademark are properties of BIMMERPOST