BMW 1 Series Coupe Forum / 1 Series Convertible Forum (1M / tii / 135i / 128i / Coupe / Cabrio / Hatchback) (BMW E82 E88 128i 130i 135i)
 





 

Post Reply
 
Thread Tools Search this Thread
      06-10-2010, 05:11 AM   #1
BigshotMD
Enlisted Member
 
Drives: BMW 125i + M-Sport Package
Join Date: Jul 2009
Location: Australia

Posts: 38
iTrader: (0)

Question How to convince BMW to give me new ECU and software upgrade?

So I've politely asked BMW to upgrade my ECU and computer software. They politely said no. Their reason is that it has to be a documented problem in which the new software has to be of definite benefit. Apparently, they have to write to the BMW Australia and get an authorization for my specific vehicle VIN.

I find that this is a load of rubbish and that they are lazy. But is this really true? Is there a way to get it to ensure everything remains up-to-date?

Cheers.
BigshotMD is offline   Australia
0
Reply With Quote
      06-10-2010, 05:59 AM   #2
crew09
Private
 
Drives: 135i
Join Date: Dec 2009
Location: Mass

Posts: 78
iTrader: (0)

This has been a topic of discussion many times, the easiest way appears to be complaining that you're hearing weird "popping" noises from the radio when the car is off.
crew09 is offline   United_States
0
Reply With Quote
      06-10-2010, 06:14 AM   #3
Dackelone
Moderator
 
Dackelone's Avatar
 
Drives: 135i Silber mit/Rot 6MT N54
Join Date: Feb 2010
Location: Bayern, Germany

Posts: 15,085
iTrader: (1)

Quote:
Originally Posted by crew09 View Post
This has been a topic of discussion many times, the easiest way appears to be complaining that you're hearing weird "popping" noises from the radio when the car is off.
Yup! +1~!
Dackelone is offline   Germany
0
Reply With Quote
      06-10-2010, 07:33 AM   #4
banglemangle
Lieutenant
 
Drives: bmw135
Join Date: Feb 2010
Location: Somewhere on the East Coast of Australia

Posts: 577
iTrader: (0)

Tell them your car takes a long time to start, when it does, loads of smoke comes out of the exhaust until all 6 pots decide to play nicely with one another, that you have two yellowish car enginish lights on the dash (1 big, 1 small), that the car wont rev beyond 2.5k and has no power.

I told them that and they updated my s/ware and threw in a free fuel pump (part no ended with 943) that promptly broke - lol.

Last edited by banglemangle; 06-10-2010 at 07:34 AM. Reason: spelling
banglemangle is offline   Azerbaijan
0
Reply With Quote
      06-10-2010, 07:46 AM   #5
FJUNO78
Captain
 
FJUNO78's Avatar
 
Drives: 25 to 2
Join Date: Nov 2006
Location: staten island, NY

Posts: 885
iTrader: (0)

Garage List
2010 135i  [0.00]
2007 e92 328I  [0.00]
Quote:
Originally Posted by BigshotMD View Post
So I've politely asked BMW to upgrade my ECU and computer software. They politely said no. Their reason is that it has to be a documented problem in which the new software has to be of definite benefit. Apparently, they have to write to the BMW Australia and get an authorization for my specific vehicle VIN.

I find that this is a load of rubbish and that they are lazy. But is this really true? Is there a way to get it to ensure everything remains up-to-date?

Cheers.
if everything is working, why would you want to mess with your software?

for the 135i, people are saying that the new sw actually lowers boost. I would be pissed if they gave me new sw for no valid reason.
__________________
2010 135i - Alpine White - Coral Red- Glacier Trim - Bluetooth - ///M Sport - Paddle Shifters
FJUNO78 is offline  
0
Reply With Quote
      06-10-2010, 09:06 AM   #6
Angry3
All your 1 are belong to us!!!
 
Angry3's Avatar
 
Drives: '08 135i 'Vert
Join Date: Apr 2008
Location: Charlotte, NC

Posts: 641
iTrader: (0)

Quote:
Originally Posted by FJUNO78 View Post
if everything is working, why would you want to mess with your software?

for the 135i, people are saying that the new sw actually lowers boost. I would be pissed if they gave me new sw for no valid reason.
Exactly. I asked my dealer for a sw update months back to get rid of the 29.2 in mine, they of course said no even after I complained about little things the code supposedly fixed.

Now with daily hard starting they want to change the code instead of changing the hpfp. The bottom line is that if your car is running that's the best you can hope for. Being picky about *how* our cars run and little things isn't a luxury we as 135 owners have...
Angry3 is offline  
0
Reply With Quote
      06-10-2010, 10:26 AM   #7
ianc
Ex '87 Carrera
 
ianc's Avatar
 
Drives: '10 TiAg 6MT 135i
Join Date: Feb 2010
Location: Redwood Shores, California

Posts: 712
iTrader: (0)

From the dealer's point of view: why should they update your SW? It is a time-consuming process and costs them money. Just so you can claim to have the latest SW?

Then there are potential issues with customers complaining about lost\different functionality after the update is done and asking for a downgrade again, opening up a world of pain for them.

I can sympathize with the policy of no upgrade unless it's to cure a specific problem,

ianc
__________________
"I will tell you there is a big difference between driving money and driving blood, sweat and tears." - PorscheGuy79

"I got 328 loaner and was impressed with performance. It feels much faster than my 135i." - MOCKBA
ianc is offline   United_States
0
Reply With Quote
      06-12-2010, 06:28 AM   #8
x5mad
Captain
 
x5mad's Avatar
 
Drives: F30 328i
Join Date: May 2009
Location: Australia

Posts: 843
iTrader: (0)

I agree with the above posts about not getting sw update unless needed, if it aint broke....

However if you feel that you must have the update then the following will work. I had a few electrical gremlins and apparently one of them has a SIB that advises the dealer that a sw update is to be done. I cant remember which one exactly so I'll list them all:

- advise them that the side mirrors do not retain memory. Ie when you unlock the car the next day you find that the mirrors are pointed in random positions.
- when you use the single button to close all windows at the same time, the passenger window closes and then reopens about a third when it hits the top.
- when using bluetooth to make your phone calls you cannot adjust the call volume high enough to be able to hear the other caller clearly.

One of these has a sib which will automatically mandate a software update.
x5mad is offline  
0
Reply With Quote
      06-12-2010, 08:33 AM   #9
sparoz
Brigadier General
 
sparoz's Avatar
 
Drives: VO 1///M; AW X3 30d
Join Date: Jun 2008
Location: Sunshine Coast

Posts: 4,744
iTrader: (0)

Just have a sw update because my bluetooth is playing up - seriously, I much prefer the old software - they've changed how the nav works which is a bit annoying. There's also switching issues like some time the parking sensor would not switch to the new screen. Engine wise - the delivery is smoother which I feel it gives me a bit more control.

BTW bigshotMD - jump to the Aussie Forum sometime, never seen you around there .
__________________
1///M - Valencia Orange
X3 30d - Alpine White

Under Six Seconds http://www.under6s.com
sparoz is offline   Australia
0
Reply With Quote
      06-12-2010, 03:41 PM   #10
1speedbike
Colonel
 
1speedbike's Avatar
 
Drives: 2008 BMW 135i
Join Date: Jun 2008
Location: NJ, NYC, Baltimore

Posts: 2,932
iTrader: (15)

Don't get it yet. There's a problem with it. My HPFP went and along with a replacement pump they need to upgrade the ECU. Unfortunately, three of the cars they tried to upgrade had the software crash yesterday alone, including mine (mine was the only 1er getting the upgrade so I can't say if it pertains to certain models). They need to keep my car til at least Monday and I'm stuck with a 328 loaner til then
__________________

Year 1 of the 1
1speedbike is offline  
0
Reply With Quote
      06-12-2010, 04:05 PM   #11
rudyv1
Private First Class
 
Drives: 2008 135i Convertible
Join Date: Jun 2009
Location: Kitchener ON

Posts: 152
iTrader: (0)

Can you let us know the software version they put on your car when you get it back please?

Thanks
Rudy


Quote:
Originally Posted by 1speedbike View Post
Don't get it yet. There's a problem with it. My HPFP went and along with a replacement pump they need to upgrade the ECU. Unfortunately, three of the cars they tried to upgrade had the software crash yesterday alone, including mine (mine was the only 1er getting the upgrade so I can't say if it pertains to certain models). They need to keep my car til at least Monday and I'm stuck with a 328 loaner til then
rudyv1 is offline  
0
Reply With Quote
      06-12-2010, 04:49 PM   #12
BimmerSchnitzel
J1V3.455.7URCK3Y
 
Drives: 2008 SGM 135i
Join Date: Sep 2009
Location: St. Louis, MO

Posts: 134
iTrader: (0)

Unless you want your car to feel like it lost about 30 HP to the wheels, I would recommend staying away from the new software like the plague.
BimmerSchnitzel is offline   United_States
0
Reply With Quote
      06-12-2010, 04:55 PM   #13
rudyv1
Private First Class
 
Drives: 2008 135i Convertible
Join Date: Jun 2009
Location: Kitchener ON

Posts: 152
iTrader: (0)

I've heard the reverse, that the newer software (version 36.5 i believe) makes power delivery smoother and pulls better.

I have the original shipping factory version of software with my car, built 06/2008

I have the problem with the popping sound from the radio after I turn the car off, and the passenger window goes up 3/4 of the way up and stops, bluetooth pairing issues, etc. The main problems with original software I guess.

Thanks again
Rudy

Quote:
Originally Posted by BimmerSchnitzel View Post
Unless you want your car to feel like it lost about 30 HP to the wheels, I would recommend staying away from the new software like the plague.
rudyv1 is offline  
0
Reply With Quote
      06-13-2010, 01:42 AM   #14
BimmerSchnitzel
J1V3.455.7URCK3Y
 
Drives: 2008 SGM 135i
Join Date: Sep 2009
Location: St. Louis, MO

Posts: 134
iTrader: (0)

Quote:
Originally Posted by rudyv1 View Post
I've heard the reverse, that the newer software (version 36.5 i believe) makes power delivery smoother and pulls better.

I have the original shipping factory version of software with my car, built 06/2008

I have the problem with the popping sound from the radio after I turn the car off, and the passenger window goes up 3/4 of the way up and stops, bluetooth pairing issues, etc. The main problems with original software I guess.

Thanks again
Rudy
http://www.1addicts.com/forums/showthread.php?t=375502
BimmerSchnitzel is offline   United_States
0
Reply With Quote
      06-13-2010, 02:45 AM   #15
Taymaishu
Banned
 
Drives: I love massive black cocks
Join Date: Jul 2009
Location: in my ass and around my mouth

Posts: 3,020
iTrader: (0)

Garage List
2009 125i  [2.75]
The software upgrade for the 125i (which the OP has) may have completely different effects on power delivery. I've had the window issue on the car before, but may just mention the 'popping' problem at my service
Taymaishu is offline   Australia
0
Reply With Quote
      06-13-2010, 03:24 AM   #16
RPM90
Major General
 
Drives: 335i Msport w/sport AT
Join Date: Mar 2006
Location: Chicago

Posts: 5,928
iTrader: (1)

Quote:
Originally Posted by banglemangle View Post
Tell them your car takes a long time to start, when it does, loads of smoke comes out of the exhaust until all 6 pots decide to play nicely with one another, that you have two yellowish car enginish lights on the dash (1 big, 1 small), that the car wont rev beyond 2.5k and has no power.

I told them that and they updated my s/ware and threw in a free fuel pump (part no ended with 943) that promptly broke - lol.
Your new 943 pump failed?
Was it the pump or a faulty install?

I believe this is the first actual post I've seen with someone who has had a 943 fail.
Please confirm. Thanks.

What did they to do to fix it?
RPM90 is offline  
0
Reply With Quote
      06-13-2010, 04:12 PM   #17
1speedbike
Colonel
 
1speedbike's Avatar
 
Drives: 2008 BMW 135i
Join Date: Jun 2008
Location: NJ, NYC, Baltimore

Posts: 2,932
iTrader: (15)

Quote:
Originally Posted by rudyv1 View Post
Can you let us know the software version they put on your car when you get it back please?

Thanks
Rudy
I will be sure to let you know, as well as say what effects it has on the car to the best of my ability. Hopefully it'll be done tomorrow.. crossing my fingers since I'm tired of this 328 with this awful beige interior.
__________________

Year 1 of the 1
1speedbike is offline  
0
Reply With Quote
      06-13-2010, 05:59 PM   #18
My135
Lieutenant Colonel
 
Drives:
Join Date: Mar 2008

Posts: 1,603
iTrader: (0)

Recently, I have my HPFP replaced and a new software upgraded. The car now start right the way (no more long crank) and drive the same as before. I have not noticed any ill effect from the new software like other people complainted.
__________________
7/08 135 Coupe, Crimson Red, 6 SP, Sport, Taupe Lette/Aluminum. Performance Mods: JB4 on Map 5, BMS DP Fix V3, Injen polished intake, AR Catless DP, Maddad resonated mid-pipes, aFe exhaust polished tips, ST Suspension Coil Over and Hotchkis front sway bar. Others: BMS OCC, BT Scanner, Mud Flap. Next Mods: AA Front Strut Brace.
My135 is offline  
0
Reply With Quote
      06-13-2010, 06:14 PM   #19
ianc
Ex '87 Carrera
 
ianc's Avatar
 
Drives: '10 TiAg 6MT 135i
Join Date: Feb 2010
Location: Redwood Shores, California

Posts: 712
iTrader: (0)

Unless we know what version people had and what version they've been upgraded to, this thread (and others like it) are unfortunately fairly worthless...

ianc
__________________
"I will tell you there is a big difference between driving money and driving blood, sweat and tears." - PorscheGuy79

"I got 328 loaner and was impressed with performance. It feels much faster than my 135i." - MOCKBA
ianc is offline   United_States
0
Reply With Quote
      06-15-2010, 07:31 AM   #20
wkndracr
Private First Class
 
wkndracr's Avatar
 
Drives: '10 135i
Join Date: Jan 2010
Location: Yonkers, NY

Posts: 158
iTrader: (0)

My car is still in the shop getting the update right now, after a software crash yesterday. How can I check what software version is installed when I get my car back? Or do I need to ask the SA?
__________________
2010 135i 6MT
Cobb Stage 1, Eibach prokit with Eibach-tuned Bilsteins, and some audio stuff.
wkndracr is offline   United_States
0
Reply With Quote
      06-15-2010, 10:28 AM   #21
banglemangle
Lieutenant
 
Drives: bmw135
Join Date: Feb 2010
Location: Somewhere on the East Coast of Australia

Posts: 577
iTrader: (0)

Quote:
Originally Posted by RPM90 View Post
Your new 943 pump failed?
Was it the pump or a faulty install?

I believe this is the first actual post I've seen with someone who has had a 943 fail.
Please confirm. Thanks.

What did they to do to fix it?
1. Don't Know - Long cranks and engine light within 2 weeks of install of 943
2. See 1) above.
3. Car fixed by BMW Oz

Last edited by banglemangle; 06-16-2010 at 03:53 AM.
banglemangle is offline   Azerbaijan
0
Reply With Quote
      06-18-2010, 02:30 PM   #22
wkndracr
Private First Class
 
wkndracr's Avatar
 
Drives: '10 135i
Join Date: Jan 2010
Location: Yonkers, NY

Posts: 158
iTrader: (0)

FWIW, I got my car back the other day with the latest software, and noticed no loss of power. I can here the fuel pump prime now when i unlock the doors and my passenger mirror seems to have stopped moving on its own when i hit the unlock button. so far there seems to be no ill effects with the new software.
__________________
2010 135i 6MT
Cobb Stage 1, Eibach prokit with Eibach-tuned Bilsteins, and some audio stuff.
wkndracr is offline   United_States
0
Reply With Quote
Post Reply

Bookmarks

Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Forum Jump


All times are GMT -5. The time now is 10:14 AM.




1addicts
Powered by vBulletin® Version 3.7.0
Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.
1Addicts.com, BIMMERPOST.com, E90Post.com, F30Post.com, M3Post.com, ZPost.com, 5Post.com, 6Post.com, 7Post.com, XBimmers.com logo and trademark are properties of BIMMERPOST