BMW 1 Series Coupe Forum / 1 Series Convertible Forum (1M / tii / 135i / 128i / Coupe / Cabrio / Hatchback) (BMW E82 E88 128i 130i 135i)
 





 

Post Reply
 
Thread Tools Search this Thread
      12-16-2012, 05:32 AM   #67
gomtingsuk
New Member
 
Drives: BMW 135i
Join Date: Dec 2012
Location: England

Posts: 15
iTrader: (1)

thanks for the great info - changing my oil real soon so this will come in handy...
gomtingsuk is offline  
0
Reply With Quote
      03-13-2013, 09:10 AM   #68
Rockstar1487
Alonne Captain
 
Rockstar1487's Avatar
 
Drives: '08 135i Coupe
Join Date: Jan 2013
Location: Central, New Jersey

Posts: 146
iTrader: (0)

Quote:
Originally Posted by Dackelone View Post
Hi Guys,

I was playing around with my cars hidden board menu the other day and I think I discovered a way to reset the service due lights. Most of us won’t be doing this… but I think resetting the oil service light will come in handy for a lot of people once their car's go out of warranty.

I have not seen how to reset the service due lights… so I thought I would put together this little DIY.

I was fooling around on my car because I was wondering IF I would really need to buy a BT scan tool or not. My car has its first service due in a few thousand kilometers. Btw… the reason my fuel consumption reads high is because I took these pics just after refueling my car at the gas station! lol So don’t be concerned about my 39.9 liters/100kph!

Here is how to reset the oil service (oil change) light…

Start the engine and let it idle, then press and HOLD the trip reset button for a few seconds (about seven seconds). The center display will change to a yellow warning triangle and then the service due will be displayed. IF you hold the trip reset button too long… you will go into the BC hidden menu. At anytime of you wish to escape, just turn the car off. Then you can retry again.

FYI my car was bought in Jan, 2010. The first service is due at 25,000 kms or Jan, 2012! I have changed the oil four times already... but I never reset the BC service due lights. I will do that once my car goes out of warranty.

IF you want to reset the oil service light… confirm the RESET, with the button on the end of the stalk. This SHOULD reset your oil service light. But keep in mind I did not go THAT FAR on my cars BC. So I don’t know for sure. But it is a safe bet I think.

Good Luck,
Dackel

http://www.1addicts.com/forums/showt...48#post7775548
just one heads up to everyone that hasn't figured it out yet, in order to fully reset the service due light one must HOLD the BC button while on the reset icon until the tiny clock comes up next to reset. the car will not reset just by one press of the BC(or at least mine didn't). once it is done with the clock, it will take you back to the oil screen (or whatever screen you were resetting) and show you that it has been reset with 15000 miles and shit. this is the only reset i have needed to do but i would assume that the holding of the BC until the clock appears is going to be standard for all of them.

~Rock
__________________
Was ist die fragen?
Hey Frau Hey!
Geck! Wo ist mein Auto?
Rockstar1487 is offline   United_States
0
Reply With Quote
      03-22-2013, 01:08 PM   #69
Mr Kleen
teh porcupine
 
Mr Kleen's Avatar
 
Drives: 2012 135i "Nina"
Join Date: May 2011
Location: Wiesbaden

Posts: 1,530
iTrader: (1)

Garage List
2013 BMW X1  [0.00]
2012 BMW 135i  [3.50]
Thanks again, Dak. I had to reset the oil service due warning. It finally popped on when I did my THIRD oil change.
__________________
Mr Kleen is offline   Germany
0
Reply With Quote
      06-03-2013, 07:26 AM   #70
kenson
New Member
 
Drives: 135i
Join Date: May 2013
Location: Perth

Posts: 10
iTrader: (0)

Quote:
Originally Posted by Rockstar1487 View Post
just one heads up to everyone that hasn't figured it out yet, in order to fully reset the service due light one must HOLD the BC button while on the reset icon until the tiny clock comes up next to reset.
Thanks for the tip. I kept pressing the button and it wouldn't reset! Definitely need to hold it.
kenson is offline  
0
Reply With Quote
      06-11-2013, 10:54 AM   #71
Disco Stu
Private
 
Disco Stu's Avatar
 
Drives: 2012 128i M Sport
Join Date: Sep 2011
Location: Waterdown, Ontario

Posts: 51
iTrader: (0)

Brake reset successful

Thanks so much for this. I installed performance brakes on the front, plus Stoptech pads all around, and after my last track day, the computer thought my brakes were due for service (calculated by the onboard accelerometers and other wizardry). I did not replace the sensors as they hadn't gotten anywhere near the point of contact yet. Service advisor was no help when queried about a computer reset. He did offer to do a diagnostic check for $70, then charge full shop rate to repair whatever needed doing, plus change the sensors $$.

This procedure took under 1 minute to reset front and rear service, as well as fluid calendar change. My yellow SERVICE message on startup is now gone, and system checks OK. Probably saved me $400 plus a day without my car.
Attached Images
  
Disco Stu is offline   Canada
0
Reply With Quote
      06-11-2013, 12:05 PM   #72
Dackelone
Moderator
 
Dackelone's Avatar
 
Drives: 135i Silber mit/Rot 6MT N54
Join Date: Feb 2010
Location: Bayern, Germany

Posts: 15,692
iTrader: (1)

Quote:
Originally Posted by Disco Stu View Post
Thanks so much for this (DIY)...
...This procedure took under 1 minute to reset front and rear service, as well as fluid calendar change. My yellow SERVICE message on startup is now gone, and system checks OK. Probably saved me $400 plus a day without my car.
Thanks for the update. Its always nice to know I have been of help.
Dackelone is offline   Germany
0
Reply With Quote
      06-16-2013, 06:54 PM   #73
Hprockets
New Member
 
Drives: 128i
Join Date: Apr 2011
Location: Toronto, ON

Posts: 14
iTrader: (0)

Thanks Dackel for the awesome writeup. I have successfully resetted brake pad sensor using your guide.

A couple of things to point out:
- I didn't have the engine running.
- I had to press and HOLD the BC button to 'confirm' the reset
Hprockets is offline   Canada
0
Reply With Quote
      06-17-2013, 10:42 AM   #74
FIRST1
Captain
 
Drives: '08 135i Titanium Silver
Join Date: Sep 2010
Location: LI

Posts: 706
iTrader: (3)

Garage List
2008 BMW 135i  [0.00]
Quote:
Originally Posted by Hprockets View Post
- I had to press and HOLD the BC button to 'confirm' the reset
same here! Lol thought I was crazy until I figured out it had to be held for a couple seconds to reset.
__________________
FIRST1 is offline   United_States
0
Reply With Quote
      06-17-2013, 03:42 PM   #75
Dackelone
Moderator
 
Dackelone's Avatar
 
Drives: 135i Silber mit/Rot 6MT N54
Join Date: Feb 2010
Location: Bayern, Germany

Posts: 15,692
iTrader: (1)

Quote:
Originally Posted by Hprockets View Post
Thanks Dackel for the awesome writeup. I have successfully resetted brake pad sensor using your guide.

A couple of things to point out:
- I didn't have the engine running.
- I had to press and HOLD the BC button to 'confirm' the reset

Ok, thanks. I will update my DIY. I think I forgot to write that in my directions.
Dackelone is offline   Germany
0
Reply With Quote
      07-01-2013, 08:43 PM   #76
Aj20034
New Member
 
Drives: Alpine White, Red Interior
Join Date: Jul 2013
Location: Jupiter Fl

Posts: 17
iTrader: (0)

+1
Aj20034 is offline  
0
Reply With Quote
      08-19-2013, 09:27 AM   #77
e82n54
Private First Class
 
e82n54's Avatar
 
Drives: '09 135i 6MT Alpine White
Join Date: Jan 2011
Location: Houston, TX

Posts: 197
iTrader: (1)

It works! Thank you!!!
e82n54 is offline   United_States
0
Reply With Quote
      08-24-2013, 03:35 PM   #78
n2djazz
Private
 
n2djazz's Avatar
 
Drives: 2009 135i Coupe (T. Silver)
Join Date: Oct 2009
Location: Georgia

Posts: 93
iTrader: (0)

Success !!! This is a super simple procedure. I have the I-Drive option and it took a few seconds for the display to catch up with the dashboard indicator. But now they're in sync and we're all good.
n2djazz is offline  
0
Reply With Quote
      09-01-2013, 04:17 PM   #79
Guam135i
Private First Class
 
Guam135i's Avatar
 
Drives: 08 BMW 135i, 08 128 Cab
Join Date: Oct 2011
Location: Guam

Posts: 158
iTrader: (0)

Awesome!
__________________

70 Morris Cooper S * 08 BMW 135i Coupe * 08 BMW 128i Convertible * 03 BMW 525i Touring
Guam135i is offline   Guam
0
Reply With Quote
      12-16-2013, 06:09 PM   #80
Isdaako
Private First Class
 
Isdaako's Avatar
 
Drives: 128i Convertible
Join Date: Sep 2012
Location: Devils Tower

Posts: 160
iTrader: (0)

I've used this several times since it posted and realized that I'd never said thanks. Thanks!
Isdaako is offline   United_States
0
Reply With Quote
      12-17-2013, 04:11 PM   #81
Dackelone
Moderator
 
Dackelone's Avatar
 
Drives: 135i Silber mit/Rot 6MT N54
Join Date: Feb 2010
Location: Bayern, Germany

Posts: 15,692
iTrader: (1)

Quote:
Originally Posted by Isdaako View Post
I've used this several times since it posted and realized that I'd never said thanks. Thanks!
You are quite Welcome sir.
Dackelone is offline   Germany
0
Reply With Quote
      03-11-2014, 06:46 PM   #82
titsataki
New Member
 
Drives: 2013 135is
Join Date: Jul 2007
Location: CT

Posts: 22
iTrader: (1)

I just did this on my 2013 135is. Worked fine. Odd part was that the i-drive screen for vehicle status/info still said oil service needed but I highlighted with the i-drive and held down the button and it rest itself (all green and happy )

Thank you for the good info.

Nick
titsataki is offline  
0
Reply With Quote
      04-18-2014, 03:56 PM   #83
N61WP
New Member
 
Drives: 2008 135i Convertible
Join Date: Dec 2012
Location: Covington, La

Posts: 10
iTrader: (0)

Just changed oil in my 08 135i conv. Reset oil reminder as stated in this thread, worked perfectly...Then the change brake pad warning came on for front and back, (was never on before, 28K miles). I have tried repeatedly to reset, but when I do it shows just blanks on the mls and does not go to the little clock if I continue to hold button as with the oil setting.
I just uninstalled my Cobb tune just in case that had something to do with it, but no dice.
N61WP is offline  
0
Reply With Quote
      04-18-2014, 05:18 PM   #84
Motohip
Second Lieutenant
 
Motohip's Avatar
 
Drives: 128i
Join Date: Mar 2012
Location: Oxnard, CA

Posts: 256
iTrader: (5)

Quote:
Originally Posted by N61WP View Post
Just changed oil in my 08 135i conv. Reset oil reminder as stated in this thread, worked perfectly...Then the change brake pad warning came on for front and back, (was never on before, 28K miles). I have tried repeatedly to reset, but when I do it shows just blanks on the mls and does not go to the little clock if I continue to hold button as with the oil setting.
I just uninstalled my Cobb tune just in case that had something to do with it, but no dice.
It's not related to the Cobb. My car did the exact same thing. I'm not sure how to help cause my dealership reset it. I couldn't do it.
Motohip is offline   United_States
0
Reply With Quote
      04-18-2014, 06:09 PM   #85
Dackelone
Moderator
 
Dackelone's Avatar
 
Drives: 135i Silber mit/Rot 6MT N54
Join Date: Feb 2010
Location: Bayern, Germany

Posts: 15,692
iTrader: (1)

Quote:
Originally Posted by N61WP View Post
Just changed oil in my 08 135i conv. Reset oil reminder as stated in this thread, worked perfectly...Then the change brake pad warning came on for front and back, (was never on before, 28K miles). I have tried repeatedly to reset, but when I do it shows just blanks on the mls and does not go to the little clock if I continue to hold button as with the oil setting.
I just uninstalled my Cobb tune just in case that had something to do with it, but no dice.
Sounds like you will need your dealer to reset this. Sorry.


Dack
Dackelone is offline   Germany
0
Reply With Quote
      05-01-2014, 08:52 PM   #86
Tony D
Registered
 
Drives: 2008 135i
Join Date: Apr 2014
Location: United States

Posts: 2
iTrader: (0)

Dackel your a BMW wizard! How do you know so much about these cars?
Tony D is offline  
0
Reply With Quote
Post Reply

Bookmarks

Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Forum Jump


All times are GMT -5. The time now is 07:34 AM.




1addicts
Powered by vBulletin® Version 3.7.0
Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.
1Addicts.com, BIMMERPOST.com, E90Post.com, F30Post.com, M3Post.com, ZPost.com, 5Post.com, 6Post.com, 7Post.com, XBimmers.com logo and trademark are properties of BIMMERPOST