BMW 1 Series Coupe Forum / 1 Series Convertible Forum (1M / tii / 135i / 128i / Coupe / Cabrio / Hatchback) (BMW E82 E88 128i 130i 135i)
 





 

Post Reply
 
Thread Tools Search this Thread
      07-16-2013, 10:54 PM   #925
BmwECY
Banned
 
Drives: Bmw
Join Date: Sep 2012
Location: Earth

Posts: 337
iTrader: (0)

Bump
BmwECY is offline  
0
Reply With Quote
      07-24-2013, 09:37 AM   #926
fmowry
New Member
 
Drives: '08 135i
Join Date: Jun 2013
Location: Severn, MD

Posts: 10
iTrader: (0)

New to the forum but been a car guy for quite some time. Picked up an '08 135i a couple months ago and just popped a CEL.

P054B - Coldstart Camshaft B position timing over-retarded.

A quick search didn't come up with any hits. Used Torque App to scan the code. Not much info.

Anyone have any other information on possible cause/fix?

A search on NAM Mini forum shows:

P054B - VANOS, exhaust-side, cold start: No closed-loop control possible

But that is just a partial list.

Car is out of warranty but had all the recalls done and I had the history checked at a BMW dealership and it had no history issues.
fmowry is offline  
0
Reply With Quote
      07-25-2013, 06:01 PM   #927
brusk
Lieutenant
 
brusk's Avatar
 
Drives: 2008 135i Coupe
Join Date: Jan 2012
Location: Cleveland, TN

Posts: 530
iTrader: (1)

My guess on anything like that would be the vanos solenoids, I've seen plenty of posts on people that's had to replace them.
__________________
2008 135i - Cobb AP, MS DP's, Berk street exhaust, AMS IC, BMS DCI, CDV delete, Quaife LSD, M3 control arms, M3 rear SF bushings, SS brake lines.
brusk is offline  
0
Reply With Quote
      08-02-2013, 09:27 AM   #928
BmwECY
Banned
 
Drives: Bmw
Join Date: Sep 2012
Location: Earth

Posts: 337
iTrader: (0)

Quote:
Originally Posted by brusk View Post
My guess on anything like that would be the vanos solenoids, I've seen plenty of posts on people that's had to replace them.
x2 good advice
BmwECY is offline  
0
Reply With Quote
      08-02-2013, 06:34 PM   #929
BmwECY
Banned
 
Drives: Bmw
Join Date: Sep 2012
Location: Earth

Posts: 337
iTrader: (0)

Quote:
Originally Posted by nema
Quote:
Originally Posted by BmwECY View Post
anyone know if jb4 or procede can monitor individual cylinder timing corrections yet? i remember it was in the works a while back. cobb, of course, has it. just curious if there's any news on the topic that i missed...
Not yet. Last thing I remember Terry@BMS saying was that if customers began requesting it in large numbers he would work on implementing it.

Shiv hasn't mentioned it(AFAIK) since he said a long time ago that he was going to implement it, but of coarse he was going to do it better than anyone else lol
Just read that only certain ROMs have native 2-6 cyl. monitoring.
BmwECY is offline  
0
Reply With Quote
      08-05-2013, 10:19 AM   #930
BmwECY
Banned
 
Drives: Bmw
Join Date: Sep 2012
Location: Earth

Posts: 337
iTrader: (0)

bump
BmwECY is offline  
0
Reply With Quote
      08-05-2013, 05:29 PM   #931
BmwECY
Banned
 
Drives: Bmw
Join Date: Sep 2012
Location: Earth

Posts: 337
iTrader: (0)

Quote:
Originally Posted by nema
Quote:
Originally Posted by BmwECY View Post
anyone know if jb4 or procede can monitor individual cylinder timing corrections yet? i remember it was in the works a while back. cobb, of course, has it. just curious if there's any news on the topic that i missed...
Not yet. Last thing I remember Terry@BMS saying was that if customers began requesting it in large numbers he would work on implementing it.

Shiv hasn't mentioned it(AFAIK) since he said a long time ago that he was going to implement it, but of coarse he was going to do it better than anyone else lol
Any updates?
mike@n54tuning
shiv@vishnu
BmwECY is offline  
0
Reply With Quote
      08-08-2013, 08:27 AM   #932
Tiny Chainsaw
Second Lieutenant
 
Tiny Chainsaw's Avatar
 
Drives: 135i
Join Date: Jul 2013
Location: United States

Posts: 299
iTrader: (-1)

Noob question-

What does the n54 135i engine's exhaust compose of?

A mid pipe, down pipe and catback exhaust? Or what is it?
Tiny Chainsaw is offline  
0
Reply With Quote
      08-18-2013, 01:19 PM   #933
AJundEinser
Beast Mode
 
AJundEinser's Avatar
 
Drives: 2008 135i Dinan S2
Join Date: Oct 2012
Location: Germany

Posts: 19
iTrader: (0)

Garage List
2008 BMW 135i  [0.00]
The N54 has two turbos which need 2 down pipes to start the exhaust path, each having a catalytic converter. The mid pipe has 2 more sub-cats and a resonator leading into the axle back exhaust with muffler.
__________________
2008 135i - M sport - Dinan S2, OC, AB exhaust, BMS DCI
AJundEinser is offline   Germany
0
Reply With Quote
      10-05-2013, 01:59 AM   #934
sean_persi
New Member
 
sean_persi's Avatar
 
Drives: 2007 335i/ 2011 328xi
Join Date: Mar 2010
Location: Northern Virginia

Posts: 20
iTrader: (0)

Hello,

Did you find out what was wrong with your vehicle? I have a 2011 328XI and recently cel light came up and my engine started to shake. Mine shows the same code " P054B - Coldstart Camshaft B position timing over-retarded". I changed my vanos solenoids and spark plugs but the cel is still on and engine still shaking. My car is out of warranty as well!

Quote:
Originally Posted by fmowry View Post
New to the forum but been a car guy for quite some time. Picked up an '08 135i a couple months ago and just popped a CEL.

P054B - Coldstart Camshaft B position timing over-retarded.

A quick search didn't come up with any hits. Used Torque App to scan the code. Not much info.

Anyone have any other information on possible cause/fix?

A search on NAM Mini forum shows:

P054B - VANOS, exhaust-side, cold start: No closed-loop control possible

But that is just a partial list.

Car is out of warranty but had all the recalls done and I had the history checked at a BMW dealership and it had no history issues.
sean_persi is offline   United_States
0
Reply With Quote
      11-09-2013, 12:18 AM   #935
FROtuning
Banned
 
Drives: e90 6at
Join Date: Oct 2013
Location: texas

Posts: 36
iTrader: (0)

Quote:
Originally Posted by sean_persi View Post
Hello,

Did you find out what was wrong with your vehicle? I have a 2011 328XI and recently cel light came up and my engine started to shake. Mine shows the same code " P054B - Coldstart Camshaft B position timing over-retarded". I changed my vanos solenoids and spark plugs but the cel is still on and engine still shaking. My car is out of warranty as well!
your cam timing could be off, that's one guess
FROtuning is offline  
0
Reply With Quote
      11-09-2013, 06:46 PM   #936
FROtuning
Banned
 
Drives: e90 6at
Join Date: Oct 2013
Location: texas

Posts: 36
iTrader: (0)

up for general questions
FROtuning is offline  
0
Reply With Quote
      11-09-2013, 06:56 PM   #937
Dackelone
Moderator
 
Dackelone's Avatar
 
Drives: 135i Silber mit/Rot 6MT N54
Join Date: Feb 2010
Location: Bayern, Germany

Posts: 16,412
iTrader: (1)

FROtuning &

Quote:
Originally Posted by sean_persi View Post
Hello,

Did you find out what was wrong with your vehicle? I have a 2011 328XI and recently cel light came up and my engine started to shake. Mine shows the same code " P054B - Coldstart Camshaft B position timing over-retarded". I changed my vanos solenoids and spark plugs but the cel is still on and engine still shaking. My car is out of warranty as well!
There are TWO vanos sensors. One for each camshaft. Did you change both or only one? I really do not see how a bad sensor could make the engine shake. I suspect you did not use BMW spark plugs bought at a dealer. Or you have a bad plug/coil or fuel injector or carbon buildup. I would start there.
Dackelone is offline   Germany
0
Reply With Quote
      11-09-2013, 07:12 PM   #938
FROtuning
Banned
 
Drives: e90 6at
Join Date: Oct 2013
Location: texas

Posts: 36
iTrader: (0)

Quote:
Originally Posted by Dackelone View Post
FROtuning &



There are TWO vanos sensors. One for each camshaft. Did you change both or only one? I really do not see how a bad sensor could make the engine shake. I suspect you did not use BMW spark plugs bought at a dealer. Or you have a bad plug/coil or fuel injector or carbon buildup. I would start there.
vanos solenoids were cleaned (both) per his description. the code indicates timing is off, so i'm not sure how injectors or carbon build up would play a role there. not bad ideas for any cars though
FROtuning is offline  
0
Reply With Quote
      11-09-2013, 07:18 PM   #939
Dackelone
Moderator
 
Dackelone's Avatar
 
Drives: 135i Silber mit/Rot 6MT N54
Join Date: Feb 2010
Location: Bayern, Germany

Posts: 16,412
iTrader: (1)

Quote:
Originally Posted by FROtuning View Post
vanos solenoids were cleaned (both) per his description. the code indicates timing is off, so i'm not sure how injectors or carbon build up would play a role there. not bad ideas for any cars though
IF you got a code for the vanos sensors... cleaning them will not help. You must replace them both. They typically fail. Some suggest due to long oil change intervals. The sensors are relatively cheap at around $120 each.

Did you use BMW bought spark plugs? Many people buy OEM aftermarket plugs and experience a misfire. And new plugs are cheap-er than new injectors!

Carbon buildup is a big problem on our cars. The carbon dries up over night and will act like a sponge when you first start the car. All that carbon can cause a misfire also. But I have not heard of case where it would cause a problem on cold start. I still suspect either a bad plug or vanos sensor(s).

What codes keep coming back? You need to start there.
Dackelone is offline   Germany
0
Reply With Quote
      11-10-2013, 11:04 AM   #940
Dackelone
Moderator
 
Dackelone's Avatar
 
Drives: 135i Silber mit/Rot 6MT N54
Join Date: Feb 2010
Location: Bayern, Germany

Posts: 16,412
iTrader: (1)

sean_persi

FROtuning

Sound familiar?


Vanos replacement on any BMW with the 6 cylinder engine N51 N52 N52K N54 engine...
Dackelone is offline   Germany
0
Reply With Quote
      11-11-2013, 05:43 PM   #941
FROtuning
Banned
 
Drives: e90 6at
Join Date: Oct 2013
Location: texas

Posts: 36
iTrader: (0)

thanks for sharing, dack
FROtuning is offline  
0
Reply With Quote
Post Reply

Bookmarks

Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Forum Jump


All times are GMT -5. The time now is 06:38 AM.




1addicts
Powered by vBulletin® Version 3.7.0
Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.
1Addicts.com, BIMMERPOST.com, E90Post.com, F30Post.com, M3Post.com, ZPost.com, 5Post.com, 6Post.com, 7Post.com, XBimmers.com logo and trademark are properties of BIMMERPOST