BMW 1 Series Coupe Forum / 1 Series Convertible Forum (1M / tii / 135i / 128i / Coupe / Cabrio / Hatchback) (BMW E82 E88 128i 130i 135i)
 





 

Post Reply
 
Thread Tools Search this Thread
      11-01-2013, 05:56 PM   #1
ThePredator1987
New Member
ThePredator1987's Avatar
United_States
4
Rep
9
Posts

Drives: BMW 135i
Join Date: Dec 2008
Location: Socal

iTrader: (0)

Left Cornering Light Malfunction

Ive been having an issue with this error. It popped up a year or so ago and was fixed by tightening up the bulbs inside the headlight but recently it seemed to of come back with a vengeance.

I took it to an independent maintainer (because my car is out of warranty) and first the reprogrammed the module. Fixed for a couple days then it came back. Then they replaced the H3 bulbs and cleaned/tightened all the bulbs inside and it came back within the week. The next step they say is to replace the entire lighting assembly which can be very costly.

The CCID code it give me is 380: FRM 380 Turn Signal Lights Defective - Left

I want to know if anyone has encountered a similar problem and if so what they did to fix it. I've searched everywhere but I haven't found a suitable solution aside from throwing money at it with a maintainer.

Thanks in advance.
Appreciate 0
      11-02-2013, 04:24 AM   #2
delta-9-ginseng
OG Tray Deee
delta-9-ginseng's Avatar
United_States
5
Rep
194
Posts

Drives: BMW 135i
Join Date: Jul 2011
Location: LA and SF

iTrader: (0)

Unfortunately, I had a very similar problem to what you are describing. Instead, it was my right turn-signal. I took it to a shop where they found that the plastic housing/casing of the bulb was actually burning through the plastic and causing a short. I went into the dealer and showed them the problem and they replaced the entire headlight unit since technically it was a manufacturers defect on my end.
Appreciate 0
      11-04-2013, 02:26 PM   #3
Miko226
Captain
Miko226's Avatar
United_States
22
Rep
623
Posts

Drives: 11' 335d
Join Date: Nov 2012
Location: Boca Raton, FL

iTrader: (0)

I had this issue happen when my angel eye wires dry rotted and copper touched copper and created a short which also affected my turn light creating an annoying dash light. i stripped and recoated/covered the wires put it back together and had a local indy shop reset the headlight module with auto logic
__________________
11' 335d 95k Miles - JR 2.5 Race, ATM Full Exhaust, ATM CAI + Scoops, Wagner FMIC, AAR Boost Pipe, AAR Swirl Delete
Next Mods - AAR Race pipe

08' n54 135i FBO - SOLD
Appreciate 0
      11-05-2013, 02:17 PM   #4
ThePredator1987
New Member
ThePredator1987's Avatar
United_States
4
Rep
9
Posts

Drives: BMW 135i
Join Date: Dec 2008
Location: Socal

iTrader: (0)

Thanks for the information guys, I changed out the light bulb for my left then signal and now I don't get any errors or faults. I think maybe the worn out bulb was causing the rest of the system to act up. I'll just have to wait and see.
Appreciate 0
      04-01-2014, 04:22 PM   #5
josemh23
Private First Class
josemh23's Avatar
Puerto Rico
7
Rep
173
Posts

Drives: 135i
Join Date: Jan 2011
Location: PR

iTrader: (1)

Garage List
2011 135i  [0.00]
Same problem, took it to dealer , changed bulbs twice.. Error continues
Appreciate 0
      04-03-2014, 03:32 PM   #6
Brake_L8
Ambitious But Rubbish
Brake_L8's Avatar
2
Rep
95
Posts

Drives: '09 128i | '97 M3
Join Date: Dec 2013
Location: Northern VA

iTrader: (0)

My '09 has started doing this, too. All of the bulbs (left and right side) work fine, but I haven't bothered to poke around and make sure they are fully seated in sockets and all that jazz.

After owning several E36's, I'm used to the dash telling me something is falsely wrong. I'm just glad it's not "Low Beam Failure" or "Coolant Low Owner's Manual" - I've seen those for years
__________________
Now: '09 128i/6 Sport/Premium/Cold Weather | '97 M3/4/5 #404 TTD

Then: '95 Miata | '91 535i | '96 328i | '95 325i | '13 Focus ST
Appreciate 0
      04-22-2014, 04:19 PM   #7
josemh23
Private First Class
josemh23's Avatar
Puerto Rico
7
Rep
173
Posts

Drives: 135i
Join Date: Jan 2011
Location: PR

iTrader: (1)

Garage List
2011 135i  [0.00]
third time in the dealer, same error, on off now they blame my aftermarket precious white headlights! WTF!!
Appreciate 0
      04-22-2014, 05:34 PM   #8
135Pats
Major General
135Pats's Avatar
United_States
304
Rep
6,491
Posts

Drives: A few BMWs
Join Date: May 2012
Location: Maryland

iTrader: (3)

My ’08 just started this a week or two ago. Left turn signal bulb malfunction. Of course, there is no malfunction what so ever. Electronic gremlins FTL, I’ll see if I can code it out or something.
__________________
E88 N54 Alpinweiss/Coral Red/Motiv HTA 3586r Tial .82AR/Other stuff...652WHP

F30 N55 XDrive EBII
Appreciate 0
      04-23-2014, 05:16 PM   #9
CM
Enlisted Member
Canada
0
Rep
45
Posts

Drives: 2011 135i Coupe
Join Date: Apr 2010
Location: Vancouver

iTrader: (0)

I had both my headlights replaced because of a left cornering light malfunction and right front turn signal malfunction. As someone mentioned it was due to burning of the socket.
Appreciate 0
      05-09-2014, 03:17 PM   #10
Brake_L8
Ambitious But Rubbish
Brake_L8's Avatar
2
Rep
95
Posts

Drives: '09 128i | '97 M3
Join Date: Dec 2013
Location: Northern VA

iTrader: (0)

With warmer weather, my error went away. If I had to guess, the cold was making things shrink just enough to not make proper contact and threw the error message.
__________________
Now: '09 128i/6 Sport/Premium/Cold Weather | '97 M3/4/5 #404 TTD

Then: '95 Miata | '91 535i | '96 328i | '95 325i | '13 Focus ST
Appreciate 0
      06-01-2014, 10:42 PM   #11
merlinbk
First Lieutenant
6
Rep
303
Posts

Drives: None (yet)
Join Date: Aug 2009
Location: Fl

iTrader: (1)

I had this issue. I checked the bulbs a few times and they were working fine. (However it finally went bad.) I replaced the bulbs and the error went away. Perhaps it detected a fluctuation in voltage... telling me the bulb was going bad. I'm glad the warning is gone.
__________________
Automotive Photography
Appreciate 0
      06-02-2014, 07:48 PM   #12
spray
Private First Class
5
Rep
137
Posts

Drives: 2008 bmw 135i
Join Date: Nov 2012
Location: toronto

iTrader: (0)

Is this the thing that makes your light blink really fast? Because that's what mine was doing, so I replaced the bulb and it was fine for 2 weeks. Now it's blinking fast again.
Appreciate 0
      06-12-2014, 07:34 PM   #13
Rated-M3
Enlisted Member
5
Rep
33
Posts

Drives: '98 M3, '10 128i
Join Date: Oct 2010
Location: Maryland

iTrader: (0)

I have been experiencing intermittent bulb out warnings. The code is CC ID 381, right turn signal defective. However, I noticed the adaptive lights don't work when this happens. I have read it could be due to corroded bulb sockets, shorting, or faulty wiring. I will post back when I get a chance to look at it. Apparently the warning light becomes permanent if it displays it more than 50 time. If this happens, you have to get the module reset after you repair it to get rid of the warning.
Appreciate 0
      06-20-2014, 08:04 PM   #14
Rated-M3
Enlisted Member
5
Rep
33
Posts

Drives: '98 M3, '10 128i
Join Date: Oct 2010
Location: Maryland

iTrader: (0)

Quote:
Originally Posted by Rated-M3 View Post
I have been experiencing intermittent bulb out warnings. The code is CC ID 381, right turn signal defective. However, I noticed the adaptive lights don't work when this happens. I have read it could be due to corroded bulb sockets, shorting, or faulty wiring. I will post back when I get a chance to look at it. Apparently the warning light becomes permanent if it displays it more than 50 time. If this happens, you have to get the module reset after you repair it to get rid of the warning.
Replaced the turn signal bulb and it's been about a week with no error. The bulb still worked and the filament was solid. I guess it was on its way out???
Appreciate 0
      08-19-2014, 12:32 PM   #15
mikeseli
Private
mikeseli's Avatar
11
Rep
71
Posts

Drives: 2009 335i
Join Date: Apr 2014
Location: Montreal, QC or Massena, NY

iTrader: (0)

I need more info on what was done, can you guys chime in.
Appreciate 0
      08-19-2014, 02:10 PM   #16
ThePredator1987
New Member
ThePredator1987's Avatar
United_States
4
Rep
9
Posts

Drives: BMW 135i
Join Date: Dec 2008
Location: Socal

iTrader: (0)

I found the fix and it isn't cheat. Pretty much the metallic contact for the turn signal is surrounded by cheap materials so over time it melts and loses it's contact. The only fix is to replace the entire headlamp assembly which runs from 700-1300 depending on where you purchase it. Installing it isn't fun either as you need to remove the entire front bumper.
Appreciate 0
      08-24-2014, 10:33 PM   #17
mikeseli
Private
mikeseli's Avatar
11
Rep
71
Posts

Drives: 2009 335i
Join Date: Apr 2014
Location: Montreal, QC or Massena, NY

iTrader: (0)

Quote:
Originally Posted by ThePredator1987 View Post
I found the fix and it isn't cheat. Pretty much the metallic contact for the turn signal is surrounded by cheap materials so over time it melts and loses it's contact. The only fix is to replace the entire headlamp assembly which runs from 700-1300 depending on where you purchase it. Installing it isn't fun either as you need to remove the entire front bumper.
Which turn signal bulb are we talking about? Front headlight or rear lights?
The front headlights are led.
Appreciate 0
      08-25-2014, 01:58 PM   #18
ThePredator1987
New Member
ThePredator1987's Avatar
United_States
4
Rep
9
Posts

Drives: BMW 135i
Join Date: Dec 2008
Location: Socal

iTrader: (0)

Front bulb, I haven't had any experience with the rear lights acting up.
Appreciate 0
      09-02-2014, 02:24 PM   #19
shah269
Major
United_States
207
Rep
1,036
Posts

Drives: 2009
Join Date: Oct 2011
Location: NJ

iTrader: (0)

Does CPO cover this? =(
Appreciate 0
      10-14-2014, 02:13 PM   #20
lmlevine
Registered
0
Rep
1
Posts

Drives: E82 2011 135i
Join Date: Oct 2014
Location: Northern Colorado

iTrader: (0)

Three things that seem to be true about light malfunctions

Just went through a similar problem. The following seems to be true:
1) The error code is not always correct. Mine was CC ID 380, left cornering light. Those bulbs were good.
2) That became codes 134 and 136 - left and right brake lights, again, both bulbs seemed good, were working. In about two days, with both codes still appearing, the right outer brake light bulb failed (bulb 1057 or P21W). Replaced it, code went away, that morning. That evening, the left outer brake light bulb burned out, this time with just the one correct code! Replaced it, code went away. So it seems that a code or codes can appear when a bulb is getting ready to go?
3) I was told by a mechanic, in replacing bulbs in a BMW (and all other cars?), to be sure that the contacts are silver, not copper, it can make a difference in whether the car throws a code even though the bulb is good?

Maybe the left cornering lights will now actually fail? Whatever!
Appreciate 0
      02-16-2016, 07:20 PM   #21
Twhill19
hungry
Twhill19's Avatar
United_States
53
Rep
1,099
Posts

Drives: 2012-135i-N55
Join Date: May 2012
Location: Boston, MA

iTrader: (0)

Reviving this....

I get CC-ID 381...and the car says "right cornering light malfunction" but it always goes away when im driving...the cornering lights seem to work fine...help?
__________________
2012-135i-N55 - Dinan Stage 2. Berk Mids. Berk Street Axle-Back. AR Design Catless-DP. AA Charge-Pipe. ETS FMIC. 19" Forgestar F-14's 8.5"/9.0". Michelin Pilot SS (225/35/19 front-255/30/19 rear). AutoCarbon CF Trunk-Spoiler. BMW M Performance Rotors/Pads. Dinan Springs. 20% tints
Appreciate 0
      02-17-2016, 07:03 AM   #22
LeMansBeauty
Private
2
Rep
52
Posts

Drives: 2012 135i Lemans Blue M Sport
Join Date: Jan 2016
Location: Vancouver

iTrader: (0)

I just had this issue fixed at my dealer. Left corner light malfunction. At first, they thought it was the bulb, then the bulb socket. Ended up having to replace the entire headlight assembly because the socket housing had melted causing a short or something.
Appreciate 0
Post Reply

Bookmarks

Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off


All times are GMT -4. The time now is 10:13 AM.




1addicts
Powered by vBulletin® Version 3.7.0
Copyright ©2000 - 2017, Jelsoft Enterprises Ltd.
1Addicts.com, BIMMERPOST.com, E90Post.com, F30Post.com, M3Post.com, ZPost.com, 5Post.com, 6Post.com, 7Post.com, XBimmers.com logo and trademark are properties of BIMMERPOST