BMW 1 Series Coupe Forum / 1 Series Convertible Forum (1M / tii / 135i / 128i / Coupe / Cabrio / Hatchback) (BMW E82 E88 128i 130i 135i)
 





 

Post Reply
 
Thread Tools Search this Thread
      08-26-2011, 04:22 AM   #1
BMW86
Major General
 
Drives: 135i CLA45 AMG Ninja
Join Date: Jul 2008
Location: Australia

Posts: 8,953
iTrader: (0)

Can't get headlights to turn on automatically when unlocking

I can't get my headlights to turn on when I unlock my car. It used to always function this way.

I have recently installed the LUX angel eyes but don't think it has had any affect on it. I have been turning the headlights to the 0 position lately as I've had to work on the car with the ignition on so I try and preserve the battery but I always turn it back to Auto.

Car is an 08 build with iDrive. I have ticked all the options in the Settings>Lights including Welcome Lights. I have left the headlights in the Auto position.

Also, not sure if it's relevant but I've had the low battery light come on a few times in the last month or so.


Any ideas?
__________________
BMW 135i N54
MERCEDES CLA45 AMG

Last edited by BMW86; 08-26-2011 at 06:56 AM.
BMW86 is offline   Australia
0
Reply With Quote
      08-26-2011, 06:53 AM   #2
AW128i
Major
 
AW128i's Avatar
 
Drives: E82 N51
Join Date: Nov 2010
Location: Southeastern, PA

Posts: 1,004
iTrader: (1)

Send a message via AIM to AW128i
If you leave the switch in the off position (0), then the lights will not turn on when you unlock the car. You have to leave the switch in the Auto position in order for the pathway lighting to come on when you unlock the car.
AW128i is offline   United_States
0
Reply With Quote
      08-26-2011, 06:57 AM   #3
BMW86
Major General
 
Drives: 135i CLA45 AMG Ninja
Join Date: Jul 2008
Location: Australia

Posts: 8,953
iTrader: (0)

Quote:
Originally Posted by AW128i View Post
If you leave the switch in the off position (0), then the lights will not turn on when you unlock the car. You have to leave the switch in the Auto position in order for the pathway lighting to come on when you unlock the car.
Just to clarify I do put it back to Auto but it doesn't work. I think it's an issue with the battery.
__________________
BMW 135i N54
MERCEDES CLA45 AMG
BMW86 is offline   Australia
0
Reply With Quote
      08-26-2011, 10:41 AM   #4
Tom K.
Major General
 
Tom K.'s Avatar
 
Drives: '07 328iT, '13 Boxster
Join Date: Mar 2008
Location: Maryland

Posts: 5,377
iTrader: (0)

When I got occaisional "low battery" warnings on my E91, the problem turned out to be an intermittent IBS fault, which can apparently cause all sorts of electrical gremlins.

Tom
Tom K. is offline   United_States
0
Reply With Quote
      08-26-2011, 11:08 AM   #5
Ash83
Major
 
Ash83's Avatar
 
Drives: 10' 135i (sold)/14' Audi RS5
Join Date: Jan 2010
Location: Miami, FL

Posts: 1,168
iTrader: (1)

did you check if you have the day running light option ON?
__________________
Alpine White, Coral RED , Glacier Silver Aluminum trim, M sport, 6MT, NAV, HiFi, USB-iPod, Bluetooth

Performance: JB4|BMW PE|DP Cosmetics: BMW Sport Pedals|Black Kidney Grill
Ash83 is offline   United_States
0
Reply With Quote
      08-26-2011, 11:24 AM   #6
Boxtyp3
Major
 
Boxtyp3's Avatar
 
Drives: E82AW N54/ e92 BSM N55
Join Date: Apr 2010
Location: SF Bay Area

Posts: 1,043
iTrader: (0)

Garage List
2010 E82 135i  [0.00]
2013 E92 335i  [0.00]
Must be the battery. As the car is trying to save power.
Boxtyp3 is offline   Philippines
0
Reply With Quote
      08-26-2011, 02:33 PM   #7
LuxAngelEyes
 
LuxAngelEyes's Avatar
 
Drives: 2006 325xi, Sparkling Graphite
Join Date: Jan 2011
Location: New Haven, CT

Posts: 3,110
iTrader: (12)

you are probably trying to do it too often. You will need to let the car sit for a while because if you unlock / lock the car too often it times out.
LuxAngelEyes is offline   United_States
0
Reply With Quote
      08-26-2011, 02:38 PM   #8
wolfe
Lieutenant
 
wolfe's Avatar
 
Drives: 128i M-Sport / 944 Turbo S
Join Date: Apr 2010
Location: USA

Posts: 491
iTrader: (1)

Quote:
Originally Posted by Boxtyp3 View Post
Must be the battery. As the car is trying to save power.
I've seen mine do this after not being driven for a while, and I'm almost positive this is the reason.
wolfe is offline  
0
Reply With Quote
      08-26-2011, 04:42 PM   #9
adobeee
Captain
 
adobeee's Avatar
 
Drives: slow
Join Date: Jul 2011
Location: SF Bay Area, CA

Posts: 719
iTrader: (0)

Quote:
Originally Posted by LuxAngelEyes View Post
you are probably trying to do it too often. You will need to let the car sit for a while because if you unlock / lock the car too often it times out.
+1
adobeee is offline   United_States
0
Reply With Quote
      08-26-2011, 05:25 PM   #10
GotM
Second Lieutenant
 
GotM's Avatar
 
Drives: 2013 Subaru BRZ 6MT
Join Date: Oct 2009
Location: Chandler, AZ

Posts: 232
iTrader: (0)

Are you using a different key now? They can operate the car differently if they are not programmed the same.
__________________
13 Subaru BRZ, WR Blue, 6M
09 BMW135i, Alpine White, Sport, 6M - sold
99 BMW M roadster, Estoril Blue - sold
GotM is offline   United_States
0
Reply With Quote
      08-26-2011, 06:57 PM   #11
Kcc
First Lieutenant
 
Kcc's Avatar
 
Drives: 4 Wheels with a turbo
Join Date: Jul 2010
Location: Markham, Toronto

Posts: 359
iTrader: (0)

I manually turn OFF and ON my head light and my signal light down flash if I leave it at OFF. No I-drive and it's a 2011 N55.

Kcc
__________________
135i - AW
Kcc is offline   Canada
0
Reply With Quote
      08-26-2011, 07:18 PM   #12
BMW86
Major General
 
Drives: 135i CLA45 AMG Ninja
Join Date: Jul 2008
Location: Australia

Posts: 8,953
iTrader: (0)

Thanks for the responses. I think it is my battery as it worked when I pressed unlock last night so it's random. I know if I repeatedly press lock/unlock the headlights stop working after a while but that is not the problem.

I think it is unrelated to LUX as I've had them in for a couple of weeks with no issues. I'm 99% sure it's the battery as I've had to jump start my car about 3 weeks ago as well.
__________________
BMW 135i N54
MERCEDES CLA45 AMG
BMW86 is offline   Australia
0
Reply With Quote
      08-26-2011, 07:56 PM   #13
x5mad
Major
 
x5mad's Avatar
 
Drives: F30 328i
Join Date: May 2009
Location: Australia

Posts: 1,017
iTrader: (0)

It is definately because of low battery. This happens on my x5 if the battery is low. The ecu shuts off all unecessary peripherals so as to preserve the battery so that the car will start. It has an algorithim based on highest priority being able to start the car and so it will preserve as much power as possible by shutting off various modules.

Before you kill the battery it is advisable you hook it up to a charger at least overnight.
x5mad is offline  
0
Reply With Quote
      08-26-2011, 08:04 PM   #14
BMW86
Major General
 
Drives: 135i CLA45 AMG Ninja
Join Date: Jul 2008
Location: Australia

Posts: 8,953
iTrader: (0)

Quote:
Originally Posted by x5mad View Post
It is definately because of low battery. This happens on my x5 if the battery is low. The ecu shuts off all unecessary peripherals so as to preserve the battery so that the car will start. It has an algorithim based on highest priority being able to start the car and so it will preserve as much power as possible by shutting off various modules.

Before you kill the battery it is advisable you hook it up to a charger at least overnight.
That makes sense. Wouldn't it be better if the battery completely died and replaced rather than charging it? How long does charging prolong the life of the battery for? I'm still under warranty and would prefer BMW to replace it altogether.
__________________
BMW 135i N54
MERCEDES CLA45 AMG
BMW86 is offline   Australia
0
Reply With Quote
      08-26-2011, 08:31 PM   #15
x5mad
Major
 
x5mad's Avatar
 
Drives: F30 328i
Join Date: May 2009
Location: Australia

Posts: 1,017
iTrader: (0)

True. But in the first instance BMW would just charge the battery and then if happens again they will look into replacing it. I know mine died a few times before they would replace. They also fiddle around with the alternator settings so that it starts charging at lower thresholds.
x5mad is offline  
0
Reply With Quote
      08-26-2011, 08:42 PM   #16
BMW86
Major General
 
Drives: 135i CLA45 AMG Ninja
Join Date: Jul 2008
Location: Australia

Posts: 8,953
iTrader: (0)

Quote:
Originally Posted by x5mad View Post
True. But in the first instance BMW would just charge the battery and then if happens again they will look into replacing it. I know mine died a few times before they would replace. They also fiddle around with the alternator settings so that it starts charging at lower thresholds.
I've complained to them about the battery before and they said it looked normal during service It's annoying though, if it gets worse I'll take it in.
__________________
BMW 135i N54
MERCEDES CLA45 AMG
BMW86 is offline   Australia
0
Reply With Quote
Post Reply

Bookmarks

Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Forum Jump


All times are GMT -5. The time now is 01:15 AM.




1addicts
Powered by vBulletin® Version 3.7.0
Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.
1Addicts.com, BIMMERPOST.com, E90Post.com, F30Post.com, M3Post.com, ZPost.com, 5Post.com, 6Post.com, 7Post.com, XBimmers.com logo and trademark are properties of BIMMERPOST