BMW 1 Series Coupe Forum / 1 Series Convertible Forum (1M / tii / 135i / 128i / Coupe / Cabrio / Hatchback) (BMW E82 E88 128i 130i 135i)
 





 

Post Reply
 
Thread Tools Search this Thread
      08-26-2011, 04:22 AM   #1
BMW86
Major General
Australia
138
Rep
8,956
Posts

 
Drives: 135i CLA45 AMG Ninja
Join Date: Jul 2008
Location: Australia

iTrader: (0)

Can't get headlights to turn on automatically when unlocking

I can't get my headlights to turn on when I unlock my car. It used to always function this way.

I have recently installed the LUX angel eyes but don't think it has had any affect on it. I have been turning the headlights to the 0 position lately as I've had to work on the car with the ignition on so I try and preserve the battery but I always turn it back to Auto.

Car is an 08 build with iDrive. I have ticked all the options in the Settings>Lights including Welcome Lights. I have left the headlights in the Auto position.

Also, not sure if it's relevant but I've had the low battery light come on a few times in the last month or so.


Any ideas?
__________________
BMW 135i N54
MERCEDES CLA45 AMG

Last edited by BMW86; 08-26-2011 at 06:56 AM.
Appreciate 0
      08-26-2011, 06:53 AM   #2
AW128i
Major
AW128i's Avatar
United_States
18
Rep
1,004
Posts

 
Drives: E82 N51
Join Date: Nov 2010
Location: Southeastern, PA

iTrader: (1)

Send a message via AIM to AW128i
If you leave the switch in the off position (0), then the lights will not turn on when you unlock the car. You have to leave the switch in the Auto position in order for the pathway lighting to come on when you unlock the car.
Appreciate 0
      08-26-2011, 06:57 AM   #3
BMW86
Major General
Australia
138
Rep
8,956
Posts

 
Drives: 135i CLA45 AMG Ninja
Join Date: Jul 2008
Location: Australia

iTrader: (0)

Quote:
Originally Posted by AW128i View Post
If you leave the switch in the off position (0), then the lights will not turn on when you unlock the car. You have to leave the switch in the Auto position in order for the pathway lighting to come on when you unlock the car.
Just to clarify I do put it back to Auto but it doesn't work. I think it's an issue with the battery.
__________________
BMW 135i N54
MERCEDES CLA45 AMG
Appreciate 0
      08-26-2011, 10:41 AM   #4
Tom K.
Major General
Tom K.'s Avatar
United_States
54
Rep
5,409
Posts

 
Drives: '07 328iT, '13 Boxster
Join Date: Mar 2008
Location: Maryland

iTrader: (0)

When I got occaisional "low battery" warnings on my E91, the problem turned out to be an intermittent IBS fault, which can apparently cause all sorts of electrical gremlins.

Tom
Appreciate 0
      08-26-2011, 11:08 AM   #5
Ash83
Major
Ash83's Avatar
United_States
14
Rep
1,168
Posts

 
Drives: 10' 135i (sold)/14' Audi RS5
Join Date: Jan 2010
Location: Miami, FL

iTrader: (1)

did you check if you have the day running light option ON?
__________________
Alpine White, Coral RED , Glacier Silver Aluminum trim, M sport, 6MT, NAV, HiFi, USB-iPod, Bluetooth

Performance: JB4|BMW PE|DP Cosmetics: BMW Sport Pedals|Black Kidney Grill
Appreciate 0
      08-26-2011, 11:24 AM   #6
Boxtyp3
Major
Boxtyp3's Avatar
Philippines
13
Rep
1,044
Posts

 
Drives: E82AW N54/ e92 BSM N55
Join Date: Apr 2010
Location: SF Bay Area

iTrader: (0)

Garage List
2010 E82 135i  [0.00]
2013 E92 335i  [0.00]
Must be the battery. As the car is trying to save power.
Appreciate 0
      08-26-2011, 02:33 PM   #7
LuxAngelEyes
Banned
United_States
71
Rep
3,086
Posts

 
Drives: 2006 325xi, Sparkling Graphite
Join Date: Jan 2011
Location: New Haven, CT

iTrader: (12)

you are probably trying to do it too often. You will need to let the car sit for a while because if you unlock / lock the car too often it times out.
Appreciate 0
      08-26-2011, 02:38 PM   #8
wolfe
Lieutenant
wolfe's Avatar
15
Rep
491
Posts

 
Drives: 128i M-Sport / 944 Turbo S
Join Date: Apr 2010
Location: USA

iTrader: (1)

Quote:
Originally Posted by Boxtyp3 View Post
Must be the battery. As the car is trying to save power.
I've seen mine do this after not being driven for a while, and I'm almost positive this is the reason.
Appreciate 0
      08-26-2011, 04:42 PM   #9
adobeee
Captain
adobeee's Avatar
United_States
22
Rep
724
Posts

 
Drives: slow
Join Date: Jul 2011
Location: SF Bay Area, CA

iTrader: (0)

Quote:
Originally Posted by LuxAngelEyes View Post
you are probably trying to do it too often. You will need to let the car sit for a while because if you unlock / lock the car too often it times out.
+1
Appreciate 0
      08-26-2011, 05:25 PM   #10
GotM
Second Lieutenant
GotM's Avatar
United_States
3
Rep
232
Posts

 
Drives: 2013 Subaru BRZ 6MT
Join Date: Oct 2009
Location: Chandler, AZ

iTrader: (0)

Are you using a different key now? They can operate the car differently if they are not programmed the same.
__________________
13 Subaru BRZ, WR Blue, 6M
09 BMW135i, Alpine White, Sport, 6M - sold
99 BMW M roadster, Estoril Blue - sold
Appreciate 0
      08-26-2011, 06:57 PM   #11
Kcc
First Lieutenant
Kcc's Avatar
Canada
4
Rep
359
Posts

 
Drives: 4 Wheels with a turbo
Join Date: Jul 2010
Location: Markham, Toronto

iTrader: (0)

I manually turn OFF and ON my head light and my signal light down flash if I leave it at OFF. No I-drive and it's a 2011 N55.

Kcc
__________________
135i - AW
Appreciate 0
      08-26-2011, 07:18 PM   #12
BMW86
Major General
Australia
138
Rep
8,956
Posts

 
Drives: 135i CLA45 AMG Ninja
Join Date: Jul 2008
Location: Australia

iTrader: (0)

Thanks for the responses. I think it is my battery as it worked when I pressed unlock last night so it's random. I know if I repeatedly press lock/unlock the headlights stop working after a while but that is not the problem.

I think it is unrelated to LUX as I've had them in for a couple of weeks with no issues. I'm 99% sure it's the battery as I've had to jump start my car about 3 weeks ago as well.
__________________
BMW 135i N54
MERCEDES CLA45 AMG
Appreciate 0
      08-26-2011, 07:56 PM   #13
x5mad
Major
x5mad's Avatar
20
Rep
1,040
Posts

 
Drives: F30 328i
Join Date: May 2009
Location: Australia

iTrader: (0)

It is definately because of low battery. This happens on my x5 if the battery is low. The ecu shuts off all unecessary peripherals so as to preserve the battery so that the car will start. It has an algorithim based on highest priority being able to start the car and so it will preserve as much power as possible by shutting off various modules.

Before you kill the battery it is advisable you hook it up to a charger at least overnight.
Appreciate 0
      08-26-2011, 08:04 PM   #14
BMW86
Major General
Australia
138
Rep
8,956
Posts

 
Drives: 135i CLA45 AMG Ninja
Join Date: Jul 2008
Location: Australia

iTrader: (0)

Quote:
Originally Posted by x5mad View Post
It is definately because of low battery. This happens on my x5 if the battery is low. The ecu shuts off all unecessary peripherals so as to preserve the battery so that the car will start. It has an algorithim based on highest priority being able to start the car and so it will preserve as much power as possible by shutting off various modules.

Before you kill the battery it is advisable you hook it up to a charger at least overnight.
That makes sense. Wouldn't it be better if the battery completely died and replaced rather than charging it? How long does charging prolong the life of the battery for? I'm still under warranty and would prefer BMW to replace it altogether.
__________________
BMW 135i N54
MERCEDES CLA45 AMG
Appreciate 0
      08-26-2011, 08:31 PM   #15
x5mad
Major
x5mad's Avatar
20
Rep
1,040
Posts

 
Drives: F30 328i
Join Date: May 2009
Location: Australia

iTrader: (0)

True. But in the first instance BMW would just charge the battery and then if happens again they will look into replacing it. I know mine died a few times before they would replace. They also fiddle around with the alternator settings so that it starts charging at lower thresholds.
Appreciate 0
      08-26-2011, 08:42 PM   #16
BMW86
Major General
Australia
138
Rep
8,956
Posts

 
Drives: 135i CLA45 AMG Ninja
Join Date: Jul 2008
Location: Australia

iTrader: (0)

Quote:
Originally Posted by x5mad View Post
True. But in the first instance BMW would just charge the battery and then if happens again they will look into replacing it. I know mine died a few times before they would replace. They also fiddle around with the alternator settings so that it starts charging at lower thresholds.
I've complained to them about the battery before and they said it looked normal during service It's annoying though, if it gets worse I'll take it in.
__________________
BMW 135i N54
MERCEDES CLA45 AMG
Appreciate 0
Post Reply

Bookmarks

Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Forum Jump


All times are GMT -5. The time now is 10:10 AM.




1addicts
Powered by vBulletin® Version 3.7.0
Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.
1Addicts.com, BIMMERPOST.com, E90Post.com, F30Post.com, M3Post.com, ZPost.com, 5Post.com, 6Post.com, 7Post.com, XBimmers.com logo and trademark are properties of BIMMERPOST