BMW 1 Series Coupe Forum / 1 Series Convertible Forum (1M / tii / 135i / 128i / Coupe / Cabrio / Hatchback) (BMW E82 E88 128i 130i 135i)
 





 

Post Reply
 
Thread Tools Search this Thread
      03-15-2014, 08:27 PM   #1
-cj-
First Lieutenant
Canada
10
Rep
378
Posts

 
Drives: 2011 AW 1M | 2009 Red M3 DCT
Join Date: Dec 2011
Location: Toronto

iTrader: (2)

Cobb FMIC

Hi guys,

Anyone running the Cobb FMIC on their 1Ms? Any fitment issues, or trimming necessary? How are the Stage1/2+ maps?
Appreciate 0
      04-18-2014, 11:53 PM   #2
-cj-
First Lieutenant
Canada
10
Rep
378
Posts

 
Drives: 2011 AW 1M | 2009 Red M3 DCT
Join Date: Dec 2011
Location: Toronto

iTrader: (2)

Fitment issues. The clips on the bottom of the FMIC don't line up with the fan. I don't think Cobb tested the FMIC on the 1M, even though it's supported... Be warned.
Appreciate 0
      06-09-2014, 04:53 AM   #3
1MOz
Captain
1MOz's Avatar
Australia
11
Rep
627
Posts

 
Drives: BMW 1M AW
Join Date: Apr 2008
Location: Sydney, Australia

iTrader: (0)

QUOTE=-cj-;15809874]Fitment issues. The clips on the bottom of the FMIC don't line up with the fan. I don't think Cobb tested the FMIC on the 1M, even though it's supported... Be warned.[/quote]

Just read this post. I have a Cobb FMIC and running stage 1+ FMIC ST Aggressive map. I didn't have any issue with fitment and everything lined up nicely. It has been at least 12 months since installation and no problem with it or the map I have been running.

Here's a little write up on my build thread: http://www.1addicts.com/forums/showt...=734281&page=5
__________________

Last edited by 1MOz; 06-09-2014 at 04:58 AM.
Appreciate 0
      06-11-2014, 10:05 PM   #4
mike@x-ph.com
Major General
mike@x-ph.com's Avatar
United_States
180
Rep
8,720
Posts

 
Drives: 2007 e92 335i
Join Date: Sep 2013
Location: Las Vegas

iTrader: (6)

Quote:
Originally Posted by -cj- View Post
Hi guys,

Anyone running the Cobb FMIC on their 1Ms? Any fitment issues, or trimming necessary? How are the Stage1/2+ maps?
It should fit with no issues, no trimming needed.
Appreciate 0
      06-19-2014, 09:48 PM   #5
-cj-
First Lieutenant
Canada
10
Rep
378
Posts

 
Drives: 2011 AW 1M | 2009 Red M3 DCT
Join Date: Dec 2011
Location: Toronto

iTrader: (2)

Something either changed in the later 1Ms (Mine was produced late 2011 and was the final batch for NA), or Cobb changed something. I looked at the linked pictures and here's how my FMIC lined up:




That was relatively easy to fix. The spacers that hold the FMIC in place were sized differently somehow. I barely got one of them screwed in... Very hackish. The FMIC was produced in late 2013 IIRC. This was the model #:



Edit: I noticed your box said 9B and mine said 7B... Hmm!
Appreciate 0
Post Reply

Bookmarks

Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Forum Jump


All times are GMT -5. The time now is 05:11 PM.




1addicts
Powered by vBulletin® Version 3.7.0
Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.
1Addicts.com, BIMMERPOST.com, E90Post.com, F30Post.com, M3Post.com, ZPost.com, 5Post.com, 6Post.com, 7Post.com, XBimmers.com logo and trademark are properties of BIMMERPOST