BMW 1 Series Coupe Forum / 1 Series Convertible Forum (1M / tii / 135i / 128i / Coupe / Cabrio / Hatchback) (BMW E82 E88 128i 130i 135i)
 





 

Post Reply
 
Thread Tools Search this Thread
      04-11-2012, 06:53 AM   #1
Taki
Private First Class
 
Drives: 2011 135i
Join Date: Jul 2007
Location: SP, MD, USA

Posts: 148
iTrader: (0)

Excessive (?) rotor wear

My 2011 135i has some serious grooving on the front rotors. There's a picture below but it doesn't quite do it justice. It's beyond just the level where you could catch a fingernail; you can easily feel the different levels of wear just running a finger across it.

I haven't done any autocross or other harsh braking. Most of my 21k miles are highway. The braking power feels fine, and the rear rotors are worn more evenly. I don't recall my 2008 looking like this before it died.

I'll probably take it to the dealer when I have some time in the next week or two, but I was wondering if this is normal and I'm crazy or if there's something else going on.

__________________
2008 135i Coupe - Jet Black, Black 'ette, Sport, Sat, iPod, Tooth, Heat, CA - Born 4-2-8, Died 12-1-10 RIP
2011 135i Coupe - Jet Black, Black leather, M Sport, Sat, iPod, Tooth, Heat, CA, HK Audio - Born 1-19-11
Horsepower is a safety feature (and so are crumple zones, apparently)
Taki is offline  
0
Reply With Quote
      04-19-2012, 05:44 PM   #2
Pixer14
Private First Class
 
Pixer14's Avatar
 
Drives: 135i N54
Join Date: Apr 2012
Location: Australia

Posts: 112
iTrader: (1)

It's normal man!..
Pixer14 is offline  
0
Reply With Quote
      04-19-2012, 07:53 PM   #3
Spitfire007
Second Lieutenant
 
Spitfire007's Avatar
 
Drives: 09 328i Sport 6MT
Join Date: Dec 2011
Location: Baltimore, MD

Posts: 290
iTrader: (0)

Garage List
2009 BMW 328i  [0.00]
I don't think it is normal.
Also why did your 2008 die?
Spitfire007 is offline  
0
Reply With Quote
      04-19-2012, 09:09 PM   #4
Eddie135
N55 Commando
 
Eddie135's Avatar
 
Drives: 135i - DCT - N55
Join Date: Jul 2011
Location: Melbourne

Posts: 744
iTrader: (0)

Send a message via MSN to Eddie135
It's normal also, I got that on my rotors.
Eddie135 is offline   Australia
0
Reply With Quote
      04-19-2012, 10:15 PM   #5
roo97ss
Captain
 
Drives: 135i, x6, C6 vette
Join Date: Apr 2010
Location: Delaware

Posts: 658
iTrader: (5)

mine did the same, made it 28k miles before replacement.

new ones look better but don't feel as good as originals did
__________________
08 135 vert, 10 x6 5.0 sport, 10 750I xdrive, 12 ram hemi quad cab
roo97ss is offline  
0
Reply With Quote
Post Reply

Bookmarks

Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Forum Jump


All times are GMT -5. The time now is 01:25 AM.




1addicts
Powered by vBulletin® Version 3.7.0
Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.
1Addicts.com, BIMMERPOST.com, E90Post.com, F30Post.com, M3Post.com, ZPost.com, 5Post.com, 6Post.com, 7Post.com, XBimmers.com logo and trademark are properties of BIMMERPOST