BMW 1 Series Coupe Forum / 1 Series Convertible Forum (1M / tii / 135i / 128i / Coupe / Cabrio / Hatchback) (BMW E82 E88 128i 130i 135i)
 





 

Post Reply
 
Thread Tools Search this Thread
      05-27-2017, 03:05 PM   #1
EndOfAnEra
N54 ftw
United_States
87
Rep
1,091
Posts

Drives: 07 E90 335i
Join Date: May 2012
Location: Tampa, FL

iTrader: (9)

Send a message via Yahoo to EndOfAnEra
Question Adaptive headlight not panning laterally while driving

Okay guys, I need some help here.



When I start the car, the headlights level vertically correctly without issue, and there are no adaptive error warnings on the cluster.

The lateral projector position always looks like it does in the photo, like I have the wheel turned all the way. This is always its position. Is there some connection in the headlight that I can look for to see if it's broken?

Does anyone know how the mechanism inside the headlight works that turns the projector when the steering wheel is turned?
__________________

Last edited by EndOfAnEra; 06-08-2017 at 10:18 PM.
Appreciate 0
      06-08-2017, 10:19 PM   #2
EndOfAnEra
N54 ftw
United_States
87
Rep
1,091
Posts

Drives: 07 E90 335i
Join Date: May 2012
Location: Tampa, FL

iTrader: (9)

Send a message via Yahoo to EndOfAnEra
Has anyone ever taken apart a headlight and noticed how its put together? Does anyone have a picture of the light disassembled?
__________________
Appreciate 0
      06-08-2017, 10:32 PM   #3
Dackelone
European Editor
Dackelone's Avatar
Germany
6009
Rep
21,914
Posts

Drives: N54 e82
Join Date: Feb 2010
Location: Bayern, Germany

iTrader: (1)

Looks like you need a new AHL headlight. People change the AE bulbs or put HID ballast in there... then the motor that moves the headlight side to side burns out.

You do know that the AHL function only works when the headlight switch is in the AUTO position. Double check that. But in looking at your photo... it looks to me that the headlight motor is broken.
__________________
Appreciate 0
      06-08-2017, 10:38 PM   #4
EndOfAnEra
N54 ftw
United_States
87
Rep
1,091
Posts

Drives: 07 E90 335i
Join Date: May 2012
Location: Tampa, FL

iTrader: (9)

Send a message via Yahoo to EndOfAnEra
Yes, my headlight switch is always on auto. The driver's side headlight works perfect as it should. It's only the passenger's headlight that is giving me issues. I was thinking something could have just came undone causing the lateral pan function to not work.

I wish someone had a picture close-up of the inside of the headlight with it taken apart. It's worth fixing this headlight rather than buying new ones because this is a Euro LCI. It would be cheaper for me to buy a donor light and use the parts from that to fix this one, even if it is just a motor.
__________________
Appreciate 0
      07-01-2017, 06:50 AM   #5
brytom
Level 1 BMW Tech
brytom's Avatar
United_States
12
Rep
62
Posts

Drives: 2010 | N52K | 6MT
Join Date: Jun 2017
Location: Kentucky

iTrader: (0)

I've seen it on E90 where the rod comes out of the ball socket.
I would say the motor is working cause the thing moves up and down.
I'd remove the back cover and see for yourself. I assume only one is having the issue? If so, take both apart and compare.
BTW, it normally only works in one direction horizontally. It shouldn't work towards the right as that would blind oncoming traffic and that would be a safety hazard.
__________________
Options: Sunroof delete, Sport Package, Xenon
Mods: M Performance Suspension, BMW Style 197 Wheels/ PSS Tires, M Sport Steering Wheel
Appreciate 0
      07-01-2017, 07:07 AM   #6
Dackelone
European Editor
Dackelone's Avatar
Germany
6009
Rep
21,914
Posts

Drives: N54 e82
Join Date: Feb 2010
Location: Bayern, Germany

iTrader: (1)

Quote:
Originally Posted by brytom View Post
I've seen it on E90 where the rod comes out of the ball socket.
I would say the motor is working cause the thing moves up and down.
I'd remove the back cover and see for yourself. I assume only one is having the issue? If so, take both apart and compare.
BTW, it normally only works in one direction horizontally. It shouldn't work towards the right as that would blind oncoming traffic and that would be a safety hazard.
As long as the headlight switch is in AUTO... both headlights will move left/right when driving - the SAME amount. I think you need to be going over 30 kph for them to do so - though.

Also... when the car is not moving... the driver's light won't move the same amount of arch/sweep as the passenger side light. I'd say its like 15' degrees of movement for the driver side headlight vs 30' degrees of movement for the passenger side. But once your moving... both headlights will move the same amount of "sweep"(degrees) in a turn.


Here is my 135i lights that are coded to the European AHL mode. The drivers headlight will dip down and swing more to the left at lower speeds... but after 80 kph that headlight will center itself. Also the highbeams put out more light(LUX) than the US coding/DOT allows.








brytom has a good point about the internal linkage coming apart. Other than that... I'm afraid your looking at a new headlight.

Dackel
__________________
Appreciate 0
      07-01-2017, 04:21 PM   #7
MightyMouseTech
Brigadier General
MightyMouseTech's Avatar
1710
Rep
4,386
Posts

Drives: 13 135i 6MT LeMans Blue MSport
Join Date: Feb 2013
Location: Ottawa, Canada

iTrader: (0)

Quote:
Originally Posted by brytom View Post
I've seen it on E90 where the rod comes out of the ball socket.
I would say the motor is working cause the thing moves up and down.
I'd remove the back cover and see for yourself. I assume only one is having the issue? If so, take both apart and compare.
BTW, it normally only works in one direction horizontally. It shouldn't work towards the right as that would blind oncoming traffic and that would be a safety hazard.
There are two motors, one for up down, and one for left right. Looks like the socket for the left right motor has become detached. Might be able to push it back in. Pull out the headlight and look.
Appreciate 1
      07-06-2017, 10:13 AM   #8
EndOfAnEra
N54 ftw
United_States
87
Rep
1,091
Posts

Drives: 07 E90 335i
Join Date: May 2012
Location: Tampa, FL

iTrader: (9)

Send a message via Yahoo to EndOfAnEra
I will take the passenger headlight out again and have a look inside. I did look for the linkage, but it was hard to see which linkage was for the left/right motion. I will take a closer look and hopefully I can snap it back into place.

Would anyone have pictures of the exact linkage for the left/right motion of the headlight?
__________________
Appreciate 0
      07-06-2017, 01:55 PM   #9
Rikx1M
MSgt (ret)
Rikx1M's Avatar
Germany
162
Rep
1,898
Posts

Drives: VO 1M #739/740
Join Date: May 2010
Location: Where the car was born

iTrader: (2)

Garage List
do you have aftermarket bulbs? if so, maybe the ballast and wires have caused the motors to hang up or catch on the wires.
__________________
Appreciate 0
      07-06-2017, 03:15 PM   #10
EndOfAnEra
N54 ftw
United_States
87
Rep
1,091
Posts

Drives: 07 E90 335i
Join Date: May 2012
Location: Tampa, FL

iTrader: (9)

Send a message via Yahoo to EndOfAnEra
No sir, the light and all bulbs are all OEM.
__________________
Appreciate 0
Post Reply

Bookmarks

Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off


All times are GMT -4. The time now is 03:05 AM.




1addicts
Powered by vBulletin® Version 3.7.0
Copyright ©2000 - 2017, Jelsoft Enterprises Ltd.
1Addicts.com, BIMMERPOST.com, E90Post.com, F30Post.com, M3Post.com, ZPost.com, 5Post.com, 6Post.com, 7Post.com, XBimmers.com logo and trademark are properties of BIMMERPOST