BMW 1 Series Coupe Forum / 1 Series Convertible Forum (1M / tii / 135i / 128i / Coupe / Cabrio / Hatchback) (BMW E82 E88 128i 130i 135i)
 





 

Post Reply
 
Thread Tools Search this Thread
      05-09-2012, 08:40 PM   #1
danmcg
Private First Class
United_States
5
Rep
127
Posts

Drives: '08 BSM 135i
Join Date: Aug 2008
Location: Sunny Fort Lauderdale

iTrader: (0)

2c31 Code

So today I was cruising home on the highway and about 10 mins from my house the SES light comes on. Got home and plugged in the handy dandy laptop to my JB4 and this is the code that I pulled:

2C31 Lambda probe in front of catalytic converter, trimming control

I didn't notice the car behaving weird or anything although I didn't goose it since obviously there was something that triggered the light. I cleared the code out and shut the car off in the driveway.

From Googleing around a bit it seems to be an o2 sensor perhaps? The only thing I have done to the car is install the JB4 about 5 days ago. I was running map 1 until yesterday when I moved it to map 5. I put about 5 gallons of gas in it from a crappy gas station cause I was super low and towards the middle of the state where you take what you can get. I'm hoping that this gas wasn't SO bad that it fouled up the o2 sensor (if that indeed is what is going on here). Is that even something to worry about anymore?
Appreciate 0
      05-10-2012, 08:15 AM   #2
shodanusmc
Captain
9
Rep
759
Posts

Drives: 09 135 Vert
Join Date: Feb 2009
Location: Chicago burb

iTrader: (0)

Maybe it is nothing, but it could be a lot if you have to take the car in to BMW. Naturally remove the JB, clear everything, and hope they do not dig. If the car is running fine outside of the code, I would not think it is the gas, but just a guess.
Appreciate 0
      06-07-2012, 12:19 AM   #3
BMW86
Major General
Australia
156
Rep
9,087
Posts

Drives: BMW 135i CLA45 AMG MacanS
Join Date: Jul 2008
Location: Australia

iTrader: (0)

Any updates on this? My car throws 2C31. Replaced front o2 sensors but still get the codes.
__________________
Current: BMW 135i N54, Mercedes CLA45 AMG, Porsche Macan S Petrol
Past: Ninja 300 ABS, BMW E46
Best 1/4 Time: 2009 BMW 135i : 12.042 @ 119.970 MPH
Appreciate 0
      06-07-2012, 12:22 AM   #4
danmcg
Private First Class
United_States
5
Rep
127
Posts

Drives: '08 BSM 135i
Join Date: Aug 2008
Location: Sunny Fort Lauderdale

iTrader: (0)

This ended up being because I had the DP fix still installed. Once I removed it the codes went away. Haven't had an issue since.

Thanks Terry!
Appreciate 0
      06-07-2012, 02:23 AM   #5
BMW86
Major General
Australia
156
Rep
9,087
Posts

Drives: BMW 135i CLA45 AMG MacanS
Join Date: Jul 2008
Location: Australia

iTrader: (0)

Quote:
Originally Posted by danmcg View Post
This ended up being because I had the DP fix still installed. Once I removed it the codes went away. Haven't had an issue since.

Thanks Terry!
Thanks for the reply mate. How long after removing the DP fix did it go away? Did you have any symptoms or just the code itself? My car hesitates under WOT and eventually limps.
__________________
Current: BMW 135i N54, Mercedes CLA45 AMG, Porsche Macan S Petrol
Past: Ninja 300 ABS, BMW E46
Best 1/4 Time: 2009 BMW 135i : 12.042 @ 119.970 MPH
Appreciate 0
      06-07-2012, 07:44 AM   #6
danmcg
Private First Class
United_States
5
Rep
127
Posts

Drives: '08 BSM 135i
Join Date: Aug 2008
Location: Sunny Fort Lauderdale

iTrader: (0)

I cleared the codes and removed the DP fix and all was well immediately.
Appreciate 0
      06-11-2012, 09:09 AM   #7
J-Sud
Captain
J-Sud's Avatar
United_States
17
Rep
811
Posts

Drives: 2015 BMW M235i
Join Date: Aug 2007
Location: Houston, TX

iTrader: (1)

Garage List
2015 BMW M235i  [0.00]
2009 135i  [0.00]
2014 Audi TTS  [0.00]
2012 Lexus IS-F  [0.00]
why would the DP fix throw a code? Are you not using catless DPs?
__________________
2015 M235i 8AT | Alpine White | Black Leather | All M Perf Carbon Interior bits | M Perf Grills | M Perf Mirror Caps | M Perf Diffuser | M Perf Exhaust | Dinan Stage 1
Appreciate 0
      06-11-2012, 09:12 AM   #8
danmcg
Private First Class
United_States
5
Rep
127
Posts

Drives: '08 BSM 135i
Join Date: Aug 2008
Location: Sunny Fort Lauderdale

iTrader: (0)

Nope. It was a used JB4 that I installed that was running a car that had FBO and meth. I just didn't realize what the DP fix was because I thought it was something that was built in is all. My car is just the tune.
Appreciate 0
      06-11-2012, 01:10 PM   #9
J-Sud
Captain
J-Sud's Avatar
United_States
17
Rep
811
Posts

Drives: 2015 BMW M235i
Join Date: Aug 2007
Location: Houston, TX

iTrader: (1)

Garage List
2015 BMW M235i  [0.00]
2009 135i  [0.00]
2014 Audi TTS  [0.00]
2012 Lexus IS-F  [0.00]
cool...makes more sense now
__________________
2015 M235i 8AT | Alpine White | Black Leather | All M Perf Carbon Interior bits | M Perf Grills | M Perf Mirror Caps | M Perf Diffuser | M Perf Exhaust | Dinan Stage 1
Appreciate 0
Post Reply

Bookmarks

Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Forum Jump


All times are GMT -4. The time now is 10:39 AM.




1addicts
1addicts
Powered by vBulletin® Version 3.7.0
Copyright ©2000 - 2015, Jelsoft Enterprises Ltd.
1Addicts.com, BIMMERPOST.com, E90Post.com, F30Post.com, M3Post.com, ZPost.com, 5Post.com, 6Post.com, 7Post.com, XBimmers.com logo and trademark are properties of BIMMERPOST