BMW 1 Series Coupe Forum / 1 Series Convertible Forum (1M / tii / 135i / 128i / Coupe / Cabrio / Hatchback) (BMW E82 E88 128i 130i 135i)
 





 

Post Reply
 
Thread Tools Search this Thread
      10-30-2012, 10:47 AM   #1
gio
Captain
15
Rep
613
Posts

 
Drives:
Join Date: Apr 2008

iTrader: (0)

Send a message via AIM to gio
135 idling funny

y 135 coupe has about 45,000 miles on it. I've noticed it idling a little funny, especially when the engine is still cool. It would skip a beat or something every once in a while. I thought it might be the spark plugs and when I took it in for service about a month ago, they did replace the spark plugs since it was due. It didn't help.

Since the service still idling funny and has slowly gotten worse. Today it seemed to start bucking slightly when accelerating and when I stopped it was idling much harsher and at a higher RPM. I was driving around in the hurricane yesterday and although I didn't go through any large puddles perhaps the intake got a little wet? Still, it should have dried out.

Any ideas as to what could be wrong? I'm thinking maybe an oxygen sensor? Also I have a JB3 - the plug-in-the-wires-yourself version - and I always worry a connection is going to come lose and screw up my engine.
__________________
Waiting on a 2015 M235

Last edited by gio; 10-30-2012 at 11:23 AM. Reason: delete this duplicate please
Appreciate 0
Post Reply

Bookmarks

Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Forum Jump


All times are GMT -5. The time now is 12:28 PM.




1addicts
Powered by vBulletin® Version 3.7.0
Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.
1Addicts.com, BIMMERPOST.com, E90Post.com, F30Post.com, M3Post.com, ZPost.com, 5Post.com, 6Post.com, 7Post.com, XBimmers.com logo and trademark are properties of BIMMERPOST