BMW 1 Series Coupe Forum / 1 Series Convertible Forum (1M / tii / 135i / 128i / Coupe / Cabrio / Hatchback) (BMW E82 E88 128i 130i 135i)
 





 

Post Reply
 
Thread Tools Search this Thread
      09-16-2015, 08:25 PM   #1
thatoneguy...
Private
7
Rep
52
Posts

Drives: '09 135i
Join Date: Aug 2015
Location: 3rd Rock from the Sun

iTrader: (1)

After JB4 install, 30FF. Charge pipe/DV?

Hello all! Just got done installing my JB4, and WOW does the car pull! Only problem is, I have yet to experience a problem-free drive. I keep tripping a 30ff code, and the safety mechanism on the JB4 kicks it back to a factory map (really neat feature, and I like the safety catch). Now, I know this is related to a boost leak somewhere in the system, and wanted to conduct a quick poll to see where people think the primary culprit is. My understanding is that the factory charge pipe is pretty fragile, and the diverter valve system isn't the strongest. That would be convenient if this was what went wrong, as both those things are on my to-mod list and would cut down on the price of repairs. Any other problems? Wastegates? Thank you so much!

Edit: I should add that I don't think it's the wastegates, as boost doesn't really seem to suffer much. It's definitely still there when I push the fun pedal (not too much lag). Code gets thrown at seemingly random times, I'm trying to correlate an act to the code being thrown. I'll also add that I am running a DCI, if that changes anything.

Last edited by thatoneguy...; 09-16-2015 at 09:22 PM.
Appreciate 0
      09-17-2015, 11:22 AM   #2
Mike@N54Tuning.com
General
Canada
1706
Rep
29,988
Posts

Drives: 2007 335i, 2015 M3
Join Date: Dec 2008
Location: N54tuning.com

iTrader: (89)

Charge Pipe or Vacuum lines.. What codes are you getting exactly? Only the 30FF?

Mike
__________________
ALL ER PRODUCTS ON SALE @ 10% OFF - www.n54tuning.com - Email; Mike@n54tuning.com
NEW PERFORMANCE LINE N54 DOWNPIPES & M3/M4 & F30 ER DOWNPIPES NOW IN STOCK - ER N54 CHARPE PIPE SPECIALS - NEW JB4 G5 ISO for N54 and F30 N55 ON SALE - NEW S55 M3/M4 JB4 NOW SHIPPING
Appreciate 1
      09-17-2015, 12:39 PM   #3
Jeff@TopGearSolutions
Jeff@TopGearSolutions's Avatar
United_States
1159
Rep
33,561
Posts

Drives: C6 Z06, 09 335i, 10 335xi
Join Date: Dec 2008
Location: www.TopGearSolutions.com

iTrader: (33)

In regards to the charge pipe, it would usually show a sign of being cracked if that was the culprit.

That being said, the stock DV could still be leaking while the CP is intact.

Other common problems are vacuum lines in which there are several around the engine bay.

Only thing you can really do is inspect and start replacing things. Unfortunately a 30FF doesn't tell you where in the charge system there is a leak.
__________________
|Facebook Discounts||Evolution Racewerks| |Active Autowerke| |ETS| |Burger Tuning| |Cobb| |Mishimoto||VRSF| |AWE| |Wagner|

|HPB LED Angel Eyes| |VTT| |KW| |Spec| |ST Coilovers| |Koni| |Bilstein| |Borla| |Magnaflow| |AFE| |Shifteck| |Injen|Coding / PPK / Alpina
Appreciate 0
      09-17-2015, 06:16 PM   #4
thatoneguy...
Private
7
Rep
52
Posts

Drives: '09 135i
Join Date: Aug 2015
Location: 3rd Rock from the Sun

iTrader: (1)

Hey all, thanks for the replies. Yes, just a 30FF. I wouldn't be surprised if it was the diverter valves. During my late-night search last night, I stumbled across a member who mentioned that the OEM DV's could only handle around 12-14psi, and they are 6 years old at this point. I'd probably opt for the Synapse CP/BOV option configured as a recirculator. I'll be sure to check integrity of vacuum lines as well.
Appreciate 0
      09-23-2015, 02:57 AM   #5
Traf
Private
Traf's Avatar
11
Rep
61
Posts

Drives: 2009 135i Coupe
Join Date: Jun 2015
Location: Paris

iTrader: (0)

4/2 without a backend flash will trigger 30FF, make sure you are set to 4/3.
Appreciate 0
      09-23-2015, 11:25 AM   #6
thatoneguy...
Private
7
Rep
52
Posts

Drives: '09 135i
Join Date: Aug 2015
Location: 3rd Rock from the Sun

iTrader: (1)

Quote:
Originally Posted by Traf View Post
4/2 without a backend flash will trigger 30FF, make sure you are set to 4/3.
I'll definitely double check this! Seems like something I could have bumped around. Thank you!
Appreciate 0
Post Reply

Bookmarks

Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Forum Jump


All times are GMT -4. The time now is 09:25 AM.




1addicts
1addicts
Powered by vBulletin® Version 3.7.0
Copyright ©2000 - 2016, Jelsoft Enterprises Ltd.
1Addicts.com, BIMMERPOST.com, E90Post.com, F30Post.com, M3Post.com, ZPost.com, 5Post.com, 6Post.com, 7Post.com, XBimmers.com logo and trademark are properties of BIMMERPOST