BMW 1 Series Coupe Forum / 1 Series Convertible Forum (1M / tii / 135i / 128i / Coupe / Cabrio / Hatchback) (BMW E82 E88 128i 130i 135i)
 





 

Post Reply
 
Thread Tools Search this Thread
      04-28-2012, 03:45 PM   #1
Ihave1
Private First Class
 
Drives: 2008 135i
Join Date: Jan 2011
Location: NC, USA

Posts: 127
iTrader: (0)

OEM sport springs bend

I ordered some sport springs since I need to put my stock suspension back on the front so my KW's can be rebuilt. I noticed the center line is not straight. Is this normal and they correct themselves once assembled?
Attached Images
  
Ihave1 is offline   United_States
0
Reply With Quote
      04-28-2012, 03:57 PM   #2
Fireflyer239
First Lieutenant
 
Drives: BMW, Jeep, Ducati & Harley
Join Date: Jul 2009
Location: New Haven, CT

Posts: 346
iTrader: (0)

Just received my BMWP springs, exact same thing. I assume this is normal, not thinking about it!
Fireflyer239 is offline   United_States
0
Reply With Quote
      04-28-2012, 04:40 PM   #3
Ihave1
Private First Class
 
Drives: 2008 135i
Join Date: Jan 2011
Location: NC, USA

Posts: 127
iTrader: (0)

Cool thanks!
Ihave1 is offline   United_States
0
Reply With Quote
      04-29-2012, 09:45 PM   #4
1Pirate
Lieutenant
 
1Pirate's Avatar
 
Drives: 2009 BMW 135i
Join Date: Aug 2011
Location: Greenville, NC

Posts: 580
iTrader: (2)

Yes that is normal for the fronts.
__________________
2009 BMW LeMans Blue 135i/Dinan Stage 2 tune/Alufelgen SF-71s/M3 suspension components/Koni Sport adjustable dampers/ETS FMIC/M3 paddle shifters/Alpina B3 TCU flash
1Pirate is offline   United_States
0
Reply With Quote
      04-29-2012, 10:35 PM   #5
Dackelone
Moderator
 
Dackelone's Avatar
 
Drives: 135i Silber mit/Rot 6MT N54
Join Date: Feb 2010
Location: Bayern, Germany

Posts: 15,131
iTrader: (1)

Why aren't these springs yellow? I thought all Perf Springs were yellow. ???
Dackelone is offline   Germany
0
Reply With Quote
      04-30-2012, 06:16 AM   #6
Focusedintntions
Colonel
 
Drives: 2011 135i M-Sport :D
Join Date: Nov 2010
Location: NoVA

Posts: 2,662
iTrader: (1)

Quote:
Originally Posted by Dackelone View Post
Why aren't these springs yellow? I thought all Perf Springs were yellow. ???
Dack he ordered the sport springs, not the performance springs...
__________________
Faster, faster, faster, until the thrill of speed overcomes the fear of death… – Hunter Thompson
Focusedintntions is offline   United_States
0
Reply With Quote
      05-09-2012, 07:51 PM   #7
Ihave1
Private First Class
 
Drives: 2008 135i
Join Date: Jan 2011
Location: NC, USA

Posts: 127
iTrader: (0)

Yeah these are used and I just need them to hold me over while my KW's are getting rebuilt so I don't care too much how they perform. Thanks for the help!
Ihave1 is offline   United_States
0
Reply With Quote
      11-23-2012, 02:16 PM   #8
Ihave1
Private First Class
 
Drives: 2008 135i
Join Date: Jan 2011
Location: NC, USA

Posts: 127
iTrader: (0)

Any tips on getting the OEM springs compressed enough to get the upper bearing on? KW's are a piece of cake compared to the OEM springs.
Attached Images
 
Ihave1 is offline   United_States
0
Reply With Quote
      11-23-2012, 09:41 PM   #9
Southjersey128
Private First Class
 
Southjersey128's Avatar
 
Drives: 2008 128i
Join Date: Mar 2011
Location: South Jersey

Posts: 176
iTrader: (0)

Garage List
2008 BMW 128i  [0.00]
Wall mount spring compressor. A local garage should just charge a few bucks to get them together.
__________________
AW, Coral, HID's, Afe Scoops and CAI, PBX, 264M's, 225/255 Ventus V12's, (BMW Performance: BBK, Illuminated Door Sills, Shifter Knob and Boot, E-Brake Handle, Steering Wheel, Front Strut Bar), E93 FSB, E92 RSB, M3 Rear Subframe Bushings, M3 Front Control Arms, HPA coilover kit (Koni Adjustables and Swift Springs), Steel Brake Hoses, Black Kidneys, Smoked LED side markers, LED angel eyes, Blacklines, Carbon fiber spoiler, Ambergones...
Southjersey128 is offline   United_States
0
Reply With Quote
      11-23-2012, 11:46 PM   #10
Ihave1
Private First Class
 
Drives: 2008 135i
Join Date: Jan 2011
Location: NC, USA

Posts: 127
iTrader: (0)

After wrestling with it a little more I decided that's what I'm going to do. Thanks for the tip!
Ihave1 is offline   United_States
0
Reply With Quote
Post Reply

Bookmarks

Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Forum Jump


All times are GMT -5. The time now is 12:08 AM.




1addicts
Powered by vBulletin® Version 3.7.0
Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.
1Addicts.com, BIMMERPOST.com, E90Post.com, F30Post.com, M3Post.com, ZPost.com, 5Post.com, 6Post.com, 7Post.com, XBimmers.com logo and trademark are properties of BIMMERPOST