BMW 1 Series Coupe Forum / 1 Series Convertible Forum (1M / tii / 135i / 128i / Coupe / Cabrio / Hatchback) (BMW E82 E88 128i 130i 135i)
 





 

Post Reply
 
Thread Tools Search this Thread
      02-02-2013, 04:12 AM   #1
mkantari
New Member
 
Drives: 135i M-Berk Exhaust/Injen DCI
Join Date: Jan 2013
Location: Orange County

Posts: 10
iTrader: (0)

Check Engine Light- Reduced Power

First post on here and unfortunately its a problem that hopefully someone can help with. Currently have Downpipe Back Street Performance Exhaust, and Injen DCI ( SP1125P). Lately, have had a weird/low idle and overall the car has been running different. Today, a check engine light came on and severely lost power, I think it went into what's considered limp mode? Also, when I checked under the hood, it was extremely hot. 1. If anyone has any idea of what might be the issue, and 2. Im worried if I take it in, BMW will void my warranty. Any help would be greatly appreciated. Thanks!
mkantari is offline  
0
Reply With Quote
      02-02-2013, 04:23 AM   #2
adevangel84
Second Lieutenant
 
adevangel84's Avatar
 
Drives: 2006 E46 M3 (RIP)
Join Date: Aug 2012
Location: New Orleans

Posts: 259
iTrader: (2)

Get the codes checked to see what triggered the CEL...
adevangel84 is offline  
0
Reply With Quote
      02-02-2013, 04:37 AM   #3
mkantari
New Member
 
Drives: 135i M-Berk Exhaust/Injen DCI
Join Date: Jan 2013
Location: Orange County

Posts: 10
iTrader: (0)

Thanks for the reply. If I take it to the dealership, you think an intake and exhaust would justify them voiding my warranty? I have read that this is a common issue with the N54 engine.
mkantari is offline  
0
Reply With Quote
      02-02-2013, 05:14 AM   #4
sharkatron
First Lieutenant
 
Drives: `09 135i
Join Date: Mar 2012
Location: Melbourne

Posts: 392
iTrader: (0)

If they can explain why it causes a malfunction, your mods will void the warranty. Depends on how 'nice' your dealer is.
sharkatron is offline   Australia
0
Reply With Quote
      02-02-2013, 08:03 AM   #5
Pig Farmer
Captain
 
Drives: 2009 BMW 135i
Join Date: May 2010
Location: Florida

Posts: 681
iTrader: (0)

I suspect one (or more) of your spark plugs or coil packs are in need of replacement. This would cause a rough idle. Once up and running, the O2 sensors may be detecting too much unburnt fuel in the exhaust which would cause the ECU to lean out the engine resulting in excess heat. Hopefully the codes should confirm the problem. Good luck and keep us posted.
Pig Farmer is offline  
0
Reply With Quote
      02-05-2013, 04:46 AM   #6
mkantari
New Member
 
Drives: 135i M-Berk Exhaust/Injen DCI
Join Date: Jan 2013
Location: Orange County

Posts: 10
iTrader: (0)

Thank you everyone for your replies. I got word back today and apparently it was an issue with the turbo wastegate. After doing some research I saw that there was a class action lawsuit for the HPFP and wastegate issues. I got this from another post, "BMW will extend 1 extra year or 12,000 miles for all vehicles for the wastegate rattle issue. If this issue causes a problem, BMW will repair/replace the wastegate. If the turbo fails as a result of the wastegate, they will replace the turbo as well. So now it is 5 years, 60k miles on the wastegate/turbos." So I'm hoping they didn't just adjust it, but replaced my turbo as well. Luckily, when they mentioned my mods they didn't say anything about voiding warranty. Hopefully getting the car back tomorrow, will update with the final news.
mkantari is offline  
0
Reply With Quote
      02-06-2013, 12:58 AM   #7
abirmaher
Captain
 
abirmaher's Avatar
 
Drives: 2014 M235i Coupé (BSM/CR)
Join Date: Feb 2010
Location: Orlando, Florida

Posts: 962
iTrader: (7)

Garage List
2014 BMW M235i  [0.00]
Quote:
Originally Posted by mkantari View Post
First post on here and unfortunately its a problem that hopefully someone can help with. Currently have Downpipe Back Street Performance Exhaust, and Injen DCI ( SP1125P). Lately, have had a weird/low idle and overall the car has been running different. Today, a check engine light came on and severely lost power, I think it went into what's considered limp mode? Also, when I checked under the hood, it was extremely hot. 1. If anyone has any idea of what might be the issue, and 2. Im worried if I take it in, BMW will void my warranty. Any help would be greatly appreciated. Thanks!
Sounds like it could be charge pipe, just happened to me and all the symptoms seem to be very similar.
__________________
abirmaher is offline   United_States
0
Reply With Quote
      02-07-2013, 07:05 AM   #8
mkantari
New Member
 
Drives: 135i M-Berk Exhaust/Injen DCI
Join Date: Jan 2013
Location: Orange County

Posts: 10
iTrader: (0)

Picked it up today and all they did was adjust my wastegate actuator. Literally drove less than 5 minutes and on my downshift the car went into limp mode again throwing up a CEL. Dropped it right back off. They called me back and tried to convince me it was my intake and something popped off and it started sucking in air thus causing it to go into limp mode. I personally think its complete bs and they just dont want to replace the turbos.
mkantari is offline  
0
Reply With Quote
      02-07-2013, 10:49 AM   #9
BEAR-AvHistory
2014 435M-Sport/MPPK
 
BEAR-AvHistory's Avatar
 
Drives: 2014 435M-Sport MPPK
Join Date: Jun 2011
Location: NC - USA

Posts: 2,247
iTrader: (0)

It would not be unusual for downpipes to cause issues with the turbo warranty. That bring said check out & fix the intake if it really does have a problem.
__________________
Kevin

2014 435M-Sport MPPK - 2013 135is Cab 6MT - 2009 V-Star - 2009 Ford Expedition EL 4X4 - 2003 Xterra 4X4 - 1998 Ranger 4X4 - FFR Cobra MK-IV work in progress
BEAR-AvHistory is offline  
0
Reply With Quote
Post Reply

Bookmarks

Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Forum Jump


All times are GMT -5. The time now is 07:37 PM.




1addicts
Powered by vBulletin® Version 3.7.0
Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.
1Addicts.com, BIMMERPOST.com, E90Post.com, F30Post.com, M3Post.com, ZPost.com, 5Post.com, 6Post.com, 7Post.com, XBimmers.com logo and trademark are properties of BIMMERPOST