BMW 1 Series Coupe Forum / 1 Series Convertible Forum (1M / tii / 135i / 128i / Coupe / Cabrio / Hatchback) (BMW E82 E88 128i 130i 135i)
 





 

Post Reply
 
Thread Tools Search this Thread
      04-22-2013, 07:30 PM   #1
tommay248
1N'dONE
25
Rep
717
Posts

 
Drives: N54 135i / VO 1M
Join Date: May 2008
Location: CT

iTrader: (9)

Had GC (ground control) camber plates installed paired with kw v1 coilovers last Friday. I also have new wheels and tires fitted at the same time. I left the shop and there were some creaking noises that I didn't like. I figured that the camber plates are new and need to settle in. Track day on Saturday turned into a huge mess. All of the sudden my instructor and I noticed popping sounds coming from the from wheel well when turning and driving at 5 mph.
I jacked up the car and took of the wheels off today and noticed the tire severely rubbed the bottom adjuster of the coilover. (The perch where the spring sits). It turned it all around because I see tire marks around the whole perch. With the wheels off I started to turn the whole rotor manually and noticed the spring is twisting and making popping sounds.

Are my coilovers and camber plates destroyed from this???
Is this an easy fix or I am I about to have a terrible week?
Appreciate 0
      04-22-2013, 07:50 PM   #2
AKopp
Second Lieutenant
4
Rep
256
Posts

 
Drives: 2009 BMW 135i
Join Date: Feb 2011
Location: PA

iTrader: (0)

Who did the install? Sounds like the strut mount bearings weren't moved over to the new setup. Without them, you'll have those noises of springs popping and moving. You should've heard if the wheels/tires were rubbing immediately... A track day probably wasn't the best idea if you were hearing these noises. Sorry to be a downer here, take everything apart and inspect the parts.
__________________
2009 135i - SG/Coral - 19" Alufelgen SF-71 - ST Coilovers - Cobb Stage 2+ - AR Downpipes - Berk Sport Exhaust - Active Autowerke Charge Pipe - AMS FMIC - AFE DCI - LUX V3 Angel Eyes - LCI Blacklines - Active Autowerke Strut Tower Brace - BMW Performance CF Spoiler - Kerscher Carbon Splitter - Scopian CF Diffuser - MusicarNW Level 2
Appreciate 0
      04-22-2013, 08:00 PM   #3
Pig Farmer
Captain
8
Rep
753
Posts

 
Drives: 2009 BMW 135i
Join Date: May 2010
Location: Florida

iTrader: (0)

You can get Swift thrust bearing/sheets to keep the springs from binding/popping on the spring perch, however you probably have another issue you need to address at the same time. I suspect you are running an 8.5" wheel with a 245 or greater tire section, or have wheels with less than optimal offsets. Sometimes the length of the spring and location of the perch on the coilovers gives you less side clearance that the OEM strut. If you have enough space on the threads, you can get shorter springs which will lift the spring perch above the tire. I feel bad for you. It really sucks finding this out after the fact. Good luck.
Appreciate 0
      04-22-2013, 08:25 PM   #4
tommay248
1N'dONE
25
Rep
717
Posts

 
Drives: N54 135i / VO 1M
Join Date: May 2008
Location: CT

iTrader: (9)

I have 8.5" wheels with 235/40/18 tires et 44. Plates were professionally installed I had absolutely no issue with this "twisting" popping with oem camber plates and oem wheels and I've had the coilovers for over a year now. It looks as though the rubbing which you can't really hear when I went out on the road made it worse the more I drove and was a direct result of the wheels and camber plates. Unreal this really is sucky...
Is it possible the bearings are too tight or the nuts on top are too tight?
Appreciate 0
      04-22-2013, 08:42 PM   #5
AKopp
Second Lieutenant
4
Rep
256
Posts

 
Drives: 2009 BMW 135i
Join Date: Feb 2011
Location: PA

iTrader: (0)

I doubt they are "too" tight. Unless something is binding on the bearing... If you pop 'em off it should be pretty clear too see what is binding. It could look like nothing though. Hard to say without seeing them. Best of luck with it, let us know how you make out.
__________________
2009 135i - SG/Coral - 19" Alufelgen SF-71 - ST Coilovers - Cobb Stage 2+ - AR Downpipes - Berk Sport Exhaust - Active Autowerke Charge Pipe - AMS FMIC - AFE DCI - LUX V3 Angel Eyes - LCI Blacklines - Active Autowerke Strut Tower Brace - BMW Performance CF Spoiler - Kerscher Carbon Splitter - Scopian CF Diffuser - MusicarNW Level 2
Appreciate 0
      04-22-2013, 11:20 PM   #6
Bordia
Enlisted Member
0
Rep
37
Posts

 
Drives: Black 2009 135I
Join Date: Apr 2013
Location: Colorado

iTrader: (0)

There is a washer that is directional between the strut mount and the upper spring perch that can cause this issue if installed flipped or not at all. So best thing is as others stated you should take your struts apart and check for proper assembly.
Appreciate 0
      04-23-2013, 09:56 AM   #7
r0nd3L
Private First Class
United_States
1
Rep
125
Posts

 
Drives: 2009 135i
Join Date: Mar 2008
Location: Lombard, IL

iTrader: (0)

Which GC camber plates?
Appreciate 0
      04-23-2013, 02:45 PM   #8
tommay248
1N'dONE
25
Rep
717
Posts

 
Drives: N54 135i / VO 1M
Join Date: May 2008
Location: CT

iTrader: (9)

Quote:
Originally Posted by r0nd3L
Which GC camber plates?
Street plates for track use. The ones that are only with camber settings. Unless they sent it for the wrong springs. KW springs are 60mm and when I spoke with customer service when purchasing the plates they made sure it would fit the 60mm spring.
Really hope this issue can be resolved.
Appreciate 0
      04-23-2013, 09:58 PM   #9
fe1rx
Second Lieutenant
13
Rep
255
Posts

 
Drives: 2008 135i, 1989 RX-7 Turbo II
Join Date: Jan 2008
Location: Canada

iTrader: (1)

Quote:
Originally Posted by tommay248 View Post
Street plates for track use. The ones that are only with camber settings. Unless they sent it for the wrong springs. KW springs are 60mm and when I spoke with customer service when purchasing the plates they made sure it would fit the 60mm spring.
Really hope this issue can be resolved.
What spring rates are you using?

On race camber plates the upper spring perch stays aligned with the strut axis, so the spring is not required to bend as the front wheel steers.

On the Ground Control Street plates the upper spring perch remains aligned with the strut tower, not with the strut axis. Therefore when you steer, the spring is forced to bend as the strut articulates during steering (which it does because of a combination of the camber angle, and the interesting geometry produced by the BMW's double lower ball joint design). A stiff race spring will not like doing this. Street style springs with a large upper diameter and a small lower diameter are more accommodating in this respect.

I am using the street plates with OE springs with no issues except that the urethane top does transmit quite a bit of tire noise to the chassis. I have no strange noises from the camber plates though.
Appreciate 0
      04-23-2013, 10:59 PM   #10
r0nd3L
Private First Class
United_States
1
Rep
125
Posts

 
Drives: 2009 135i
Join Date: Mar 2008
Location: Lombard, IL

iTrader: (0)

Quote:
Originally Posted by tommay248 View Post
Street plates for track use. The ones that are only with camber settings. Unless they sent it for the wrong springs. KW springs are 60mm and when I spoke with customer service when purchasing the plates they made sure it would fit the 60mm spring.
Really hope this issue can be resolved.
This is confusing. KW springs are stock diameter at the top, not 60mm, so you should be using OE style GC spring perch. Unless, of course, you are using non KW springs. I'm kind of leaning towards something not being assembled correctly or mismatched parts.



Quote:
Originally Posted by fe1rx View Post
What spring rates are you using?

On race camber plates the upper spring perch stays aligned with the strut axis, so the spring is not required to bend as the front wheel steers.

On the Ground Control Street plates the upper spring perch remains aligned with the strut tower, not with the strut axis. Therefore when you steer, the spring is forced to bend as the strut articulates during steering (which it does because of a combination of the camber angle, and the interesting geometry produced by the BMW's double lower ball joint design). A stiff race spring will not like doing this. Street style springs with a large upper diameter and a small lower diameter are more accommodating in this respect.

I am using the street plates with OE springs with no issues except that the urethane top does transmit quite a bit of tire noise to the chassis. I have no strange noises from the camber plates though.
On my previous car, I had similar style camber plates where the spherical bearing was used only for the strut shaft and spring was resting on the mount secured to the body. I had no noises using linear 60mm KW spring (same type as comes with Clubsport kit, GC, TCK, etc).

I'm glad you mentioned your street places do no transmit any noise other than tire noise. I have full GC kit being shipped out soon and I'm excited!
Appreciate 0
      04-24-2013, 11:37 AM   #11
tommay248
1N'dONE
25
Rep
717
Posts

 
Drives: N54 135i / VO 1M
Join Date: May 2008
Location: CT

iTrader: (9)

Quote:
Originally Posted by r0nd3L
Quote:
Originally Posted by tommay248 View Post
Street plates for track use. The ones that are only with camber settings. Unless they sent it for the wrong springs. KW springs are 60mm and when I spoke with customer service when purchasing the plates they made sure it would fit the 60mm spring.
Really hope this issue can be resolved.
This is confusing. KW springs are stock diameter at the top, not 60mm, so you should be using OE style GC spring perch. Unless, of course, you are using non KW springs. I'm kind of leaning towards something not being assembled correctly or mismatched parts.



Quote:
Originally Posted by fe1rx View Post
What spring rates are you using?

On race camber plates the upper spring perch stays aligned with the strut axis, so the spring is not required to bend as the front wheel steers.

On the Ground Control Street plates the upper spring perch remains aligned with the strut tower, not with the strut axis. Therefore when you steer, the spring is forced to bend as the strut articulates during steering (which it does because of a combination of the camber angle, and the interesting geometry produced by the BMW's double lower ball joint design). A stiff race spring will not like doing this. Street style springs with a large upper diameter and a small lower diameter are more accommodating in this respect.

I am using the street plates with OE springs with no issues except that the urethane top does transmit quite a bit of tire noise to the chassis. I have no strange noises from the camber plates though.
On my previous car, I had similar style camber plates where the spherical bearing was used only for the strut shaft and spring was resting on the mount secured to the body. I had no noises using linear 60mm KW spring (same type as comes with Clubsport kit, GC, TCK, etc).

I'm glad you mentioned your street places do no transmit any noise other than tire noise. I have full GC kit being shipped out soon and I'm excited!
Turns out KW was wrong when I called them. I should be using the perches for the stock suspension and not 60mm. Looks like we found what the issue was...
GC has amazing service and they were able to send out the correct parts the next day. Props to them for being so so quick with the response.

My car will be in the shop tomorrow so I will post what I learned and if that was the only issue on Friday.

Thanks to everyone for their great input, I learned a lot by reading all the posts.
Appreciate 0
      04-29-2013, 04:18 PM   #12
r0nd3L
Private First Class
United_States
1
Rep
125
Posts

 
Drives: 2009 135i
Join Date: Mar 2008
Location: Lombard, IL

iTrader: (0)

Quote:
Originally Posted by tommay248 View Post
Turns out KW was wrong when I called them. I should be using the perches for the stock suspension and not 60mm. Looks like we found what the issue was...
GC has amazing service and they were able to send out the correct parts the next day. Props to them for being so so quick with the response.

My car will be in the shop tomorrow so I will post what I learned and if that was the only issue on Friday.

Thanks to everyone for their great input, I learned a lot by reading all the posts.
Glad you found the problem. Update us after you confirm the noise is gone
Appreciate 0
Post Reply

Bookmarks

Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Forum Jump


All times are GMT -5. The time now is 05:47 PM.




1addicts
Powered by vBulletin® Version 3.7.0
Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.
1Addicts.com, BIMMERPOST.com, E90Post.com, F30Post.com, M3Post.com, ZPost.com, 5Post.com, 6Post.com, 7Post.com, XBimmers.com logo and trademark are properties of BIMMERPOST