BMW 1 Series Coupe Forum / 1 Series Convertible Forum (1M / tii / 135i / 128i / Coupe / Cabrio / Hatchback) (BMW E82 E88 128i 130i 135i)
 





 

Post Reply
 
Thread Tools Search this Thread
      10-15-2013, 10:41 AM   #1
AJx
Private First Class
 
Drives: '09 135i Vert ///M-Sport 6 M-T
Join Date: Apr 2013
Location: Cali

Posts: 130
iTrader: (0)

Question Uhh, what the heck does this mean?...

Hi guys...

For the last week or so, I've been getting this strange light that keeps bugging me during early morning cold starts. At first, I was worried because it looked like a transmission light (I recently switched to Redline MTL, which has been great so far, imho)... but it looks like it has nothing to do with the transmission at all. Along with the light, I get extraordinarily high idle RPM's (jumps from 1000 to 2000, back and forth quickly, etc) and it sounds like the engine is working harder / noisier than normal.



Here's a pic of the warning light:









Am I overreacting? It does eventually go away (usually after turning off the car and restarting)... but I figured this can't be "normal"... even for a cold start






My Vehicle: 2009 135i Manual 6spd Conv.
AJx is offline   United_States
0
Reply With Quote
      10-15-2013, 10:45 AM   #2
Simsims
Captain
 
Drives: 119/220
Join Date: Jul 2009
Location: Ottawa

Posts: 607
iTrader: (0)

take it to dealer, right away
__________________
VO 1M - everything except sunroof
RIP BSM 135i 2009-2011
Simsims is offline   Canada
0
Reply With Quote
      10-15-2013, 10:55 AM   #3
AJx
Private First Class
 
Drives: '09 135i Vert ///M-Sport 6 M-T
Join Date: Apr 2013
Location: Cali

Posts: 130
iTrader: (0)

Quote:
Originally Posted by Simsims View Post
take it to dealer, right away


Yeah, I figured it wasn't a good sign...

Just made an appointment for tomorrow. These cars need more lovin' than a lonely woman.
AJx is offline   United_States
0
Reply With Quote
      10-15-2013, 11:15 AM   #4
GarrettF
Former E46Fanatic
 
Drives: 2010 E88 135i
Join Date: Nov 2007
Location: NYC

Posts: 278
iTrader: (3)

Send a message via AIM to GarrettF
happens to us all, limp mode, reset the car and it should go away. make a dealer appointment can be a number of things such as HPFP...
__________________
__________________
Cobb Stage 3 (Pro-Tune) | BMS DCI | VRSF FMIC 5" | BMS DPs | Berk Street Exhaust | ER Charge Pipe | Turbosmart Dual Port BOVs | cp-e Non-Resonated Midpipes | 35% Johnson Tint | MTEC Angel Eyes | Painted Reflectors | Colored Roundels | Shorty Antenna | Apex EC-7 |
GarrettF is offline   United_States
0
Reply With Quote
      10-15-2013, 11:40 AM   #5
3002 tii
Major General
 
3002 tii's Avatar
 
Drives: flat out
Join Date: Apr 2008
Location: NNJ

Posts: 8,100
iTrader: (44)

Garage List
No offense but a giant icon pops up, you don't know what it is but you wait few days to a week to post on forums... when in the end you could've just flipped through your user manual??
__________________

Recaro | Volk | AST | Vorshlag | Quaife | Stoptech | Active Autowerke | BMW Performance

Click here for my track videos
3002 tii is offline   United_States
0
Reply With Quote
      10-15-2013, 11:44 AM   #6
Worra
Captain
 
Worra's Avatar
 
Drives: 2013 135is
Join Date: Jul 2013
Location: SF Bay

Posts: 829
iTrader: (0)

Garage List
2013 BMW 135is  [0.00]
Quote:
Originally Posted by 3002 Tii View Post
No offense but a giant icon pops up, you don't know what it is but you wait few days to a week to post on forums... when in the end you could've just flipped through your user manual??
Consult the manual > Call the dealer > Google search > Post on the forums
__________________
2013 Black Sapphire 135is (526/586)
2009 Monaco Blue 328i - Sold
2000 VW Passat - Sold
1990 Calypso Red 325i - Died
Worra is offline  
0
Reply With Quote
      10-15-2013, 01:42 PM   #7
tuco44
Lieutenant Colonel
 
Drives: 2012 E82 135i MSport 6MT
Join Date: Apr 2007
Location: Western Canada

Posts: 1,594
iTrader: (0)

Quote:
Originally Posted by 3002 Tii View Post
No offense but a giant icon pops up, you don't know what it is but you wait few days to a week to post on forums... when in the end you could've just flipped through your user manual??
+1
__________________
2012 135i E82 MSport 6MT Jet Black

Previous BMWs - 2012 135i MSport LMB DCT(sold), 2011 X3 35i MSport VR (sold), 2009 M3 Sedan AW (sold), 2008 535xi MSport AW (sold), 2007 328xiT Barbera (sold), plus 11 others in the 70s & 80s.
tuco44 is offline   Canada
0
Reply With Quote
      10-15-2013, 03:51 PM   #8
rking117
Captain
 
Drives: Z4 3.0i & 330i
Join Date: Aug 2012
Location: Central Florida

Posts: 964
iTrader: (0)

The is the check engine indicator. it requires service to reset.
__________________
Enjoying an E89 Z4, F30 330i and Fiat Pop 500 //
E85 Z4 (sold), E82 128i (sold)
rking117 is offline  
0
Reply With Quote
      10-15-2013, 03:59 PM   #9
igzekyativ
Second Lieutenant
 
Drives: 2009 BMW 135i Alpine White
Join Date: Apr 2011
Location: Herndon, Va

Posts: 282
iTrader: (1)

Garage List
2009 BMW 135i  [0.00]
Mine meant I had a boost leak. Car went into limp mode. $900 at the dealer to replace a freaking plastic pipe...
__________________

2009 BMW 135i Alpine White.. Auto w/ Steptronic.. Purchased 3/29/2011.. MODS: COBB Accessport, CP-e catback, flat black kindney grills, ///M pedals, LUX V3, Trailer Hitch, Thule Hitch Mounted Bike Rack..
igzekyativ is offline  
0
Reply With Quote
      10-15-2013, 04:43 PM   #10
P90Puma
Would rather be driving.
 
Drives: 2008 135i 6MT M-Sport
Join Date: Aug 2013
Location: Ontario, Canada

Posts: 152
iTrader: (0)

Quote:
Originally Posted by igzekyativ View Post
Mine meant I had a boost leak. Car went into limp mode. $900 at the dealer to replace a freaking plastic pipe...
Charge pipe? You paid 900$ for another OEM plastic pos that will blow up again? Versus 550$ for an aluminum aftermarket one with a 250$ BOV included in the price?
P90Puma is offline   Canada
0
Reply With Quote
      10-15-2013, 05:40 PM   #11
AJx
Private First Class
 
Drives: '09 135i Vert ///M-Sport 6 M-T
Join Date: Apr 2013
Location: Cali

Posts: 130
iTrader: (0)

Quote:
Originally Posted by 3002 Tii View Post
No offense but a giant icon pops up, you don't know what it is but you wait few days to a week to post on forums... when in the end you could've just flipped through your user manual??
No offense taken... that's pretty fair criticism.

I couldn't find the manual (unfortunately), and I also figured it wasn't a big deal since it went away by itself and only happened during cold starts. It wasn't an every day thing for sure, but when it happened again this morning and longer than before... well, that was when I got worried.

I'm scheduled for a trip tot he dealer tomorrow (Probably would have gone their immediately, if I didn't hate going there so much)... I'll post their diagnostic tomorrow, just for fun.

Last edited by AJx; 10-15-2013 at 05:47 PM.
AJx is offline   United_States
0
Reply With Quote
      10-16-2013, 04:10 AM   #12
pinmagic
The Only Sane One Here
 
pinmagic's Avatar
 
Drives: 135i Convertible
Join Date: Jun 2010
Location: Arlington, VA

Posts: 1,130
iTrader: (1)

Quote:
Originally Posted by AJx View Post
I couldn't find the manual (unfortunately), and I also figured it wasn't a big deal since it went away by itself and only happened during cold starts.
It's on the BMW website. Don't have the link handy. I downloaded a copy to my computer. Convenient for consulting when I'm in my condo, not my car.
__________________
2011 135i VERT SGM/SB/MOONLIGHT - ED - with every single friggin' option they offered.
pinmagic is offline   United_States
0
Reply With Quote
      10-16-2013, 06:18 PM   #13
AJx
Private First Class
 
Drives: '09 135i Vert ///M-Sport 6 M-T
Join Date: Apr 2013
Location: Cali

Posts: 130
iTrader: (0)

(Update: As promised)

Well, just got the news from the Dealership... Looks like they are saying the rough idle + warning/malfunction light was caused by the HPFP failure (Who called it?... GarrettF?). The car will be repaired and it will stay at the dealer overnight.




...29K seems like a pretty short lifespan for an HPFP though.
AJx is offline   United_States
0
Reply With Quote
      10-16-2013, 06:28 PM   #14
2012_135i
Lieutenant
 
2012_135i's Avatar
 
Drives: 2012 135i, 6MT, M-Sport
Join Date: Sep 2011
Location: Honolulu, Hawaii

Posts: 440
iTrader: (0)

Quote:
Originally Posted by AJx View Post
(Update: As promised)

...29K seems like a pretty short lifespan for an HPFP though.

The HPFP has been an issue supposedly fixed (knock knock) on later models. You may be lucky to have gotten 29K out of it.
__________________
2012 135i M-Sport
2012_135i is offline   United_States
0
Reply With Quote
      10-16-2013, 07:32 PM   #15
gregthegr8
Colonel
 
gregthegr8's Avatar
 
Drives: 2013 Mineral Grey 135is
Join Date: Jan 2008
Location: Los Angeles, CA

Posts: 2,785
iTrader: (4)

Quote:
Originally Posted by AJx View Post
(Update: As promised)

Well, just got the news from the Dealership... Looks like they are saying the rough idle + warning/malfunction light was caused by the HPFP failure (Who called it?... GarrettF?). The car will be repaired and it will stay at the dealer overnight.




...29K seems like a pretty short lifespan for an HPFP though.
Just curious, did your car not have the HPFP recall done then? Or would this be your second one? Or was it used and you don't know for sure?
gregthegr8 is offline  
0
Reply With Quote
      10-16-2013, 07:45 PM   #16
AJx
Private First Class
 
Drives: '09 135i Vert ///M-Sport 6 M-T
Join Date: Apr 2013
Location: Cali

Posts: 130
iTrader: (0)

Quote:
Originally Posted by gregthegr8 View Post
Just curious, did your car not have the HPFP recall done then? Or would this be your second one? Or was it used and you don't know for sure?

Bought it Pre-owned from BMW with 22k on it... The only recall I've had done since I've owned it was the battery cable (earlier this year). Not sure if the HPFP was ever replaced before.

I'm guessing they would have a record of that though... so I'll inquire.
AJx is offline   United_States
0
Reply With Quote
Post Reply

Bookmarks

Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Forum Jump


All times are GMT -5. The time now is 10:30 AM.




1addicts
Powered by vBulletin® Version 3.7.0
Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.
1Addicts.com, BIMMERPOST.com, E90Post.com, F30Post.com, M3Post.com, ZPost.com, 5Post.com, 6Post.com, 7Post.com, XBimmers.com logo and trademark are properties of BIMMERPOST