BMW 1 Series Coupe Forum / 1 Series Convertible Forum (1M / tii / 135i / 128i / Coupe / Cabrio / Hatchback) (BMW E82 E88 128i 130i 135i)
 





 

Post Reply
 
Thread Tools Search this Thread
      08-04-2019, 10:06 PM   #1
Jeespinozar
135i fan
United_States
7
Rep
14
Posts

Drives: 2008 and 2013 BMW 135i
Join Date: Jan 2009
Location: Virginia

iTrader: (0)

XTRONS - Android head unit upgrade

Hello BMW lovers,

I have used over the years some many tips and advice from the forum and I would like to pay back a bit all that help. As I did not find much help aboput Xtrons unit, I will proceed to update this thread with my experience.

This is my 2nd 135i, the original one was a 2008 manual with Premium HIFI. When I took my 2013 Special Edition one, realized the mistake with the audio system. Now, I have upgraded my 2013 BMW 135i headunit with a brand new unit from Xtrons that I bought at amazon (model PA7981BIP):

https://www.amazon.com/gp/product/B0...?ie=UTF8&psc=1

My car came originally with HIFI system, which is basically the standard for the US version, I took the opportunitty to add:

- Bimmer-Tech Amp (which is basically an Audio-Tec Fischer PP86DSP)
https://www.audiotec-fischer.de/en/m...fiers/pp-86dsp

- Changed all speakers with Harman Kardon versions (adding the missing tweeters in the back)
P/N are:
Rear
65139143121 - Midrange speaker, stereo/HiFi
65139217912 - Harman Kardon tweeter
Front
65136945412 - midrange speaker, stereo HiFi
65139217910 - Harman Kardon tweeter
51337270889 - Harman Kardon cover
51337270890 - Harman Kardon cover

- Changed subs with Audio Tec Fischer MW 8BMW-D:
https://www.audiotec-fischer.de/en/m...kers/mw-8bmw-d

- Added backup camera from eBay: BMW E82 E88 E84 E90 E91 E92 E93 E60 E61 E70 E71 E72 CCD HD Backup Handle Camera

- Torque adapter
- TPMS adapter
- Carpaly adapter

Evererything is working but the carplay adapter (waiting from an update from support) and I did not have time to setup the OBD2 bluettoth adapter with the unit. In reality my challenge is that I am new w android (Mac fan to the core)

Will be updating the post as time permits and certainly sharing pictures
Attached Images
   
__________________
Jorge
Appreciate 2
      08-05-2019, 06:17 AM   #2
Rmtt
Major
Rmtt's Avatar
United_States
1283
Rep
1,230
Posts

Drives: 2011 BMW 128i, 2008 LS3 C6
Join Date: Jan 2019
Location: South Carolina

iTrader: (3)

Nice. I just did the same install of this head unit. Only thing I did not like was that there were no instructions with the unit itself.

My car (2011) has the Base Unit...so no amp. I would love to add an amp at some point, but car stereo work is something I have never done so not quite sure how to get started without doing some research first.

Also at some point, I need to connect the long yellow wire to my fuse box as I am losing all of my preset stations and clock settings. chris_flies helped me out a lot as he did the same install. I didn't know about the antenna (blue) wire needing 12 volts.I also didn't know about the memory wire. He suggested to use fuse #2 as my constant source of voltage for memory and add a circuit.

I leave for vacation in a few days, but plan to do so when I get back and will probably just load CarWebGuru on the system as it comes with quite a few nice "skins" and easy to setup apps.
__________________
2011 128i: 3:73 Rear Diff, 3SI Intake, AA Headers, Magnaflow Catback, AFE Scoops, Turner Silicone Hose, Charcoal Delete, StageFP Stage 2 Tune, APEX ARC8, MILVS Coming!!

2008 Z51 C6 LS3 w/ LG SuperPros, Ported Fast 102 Intake, RPM Level 2 Transmission, "Small Cam" Vararam SnakeCharmer CAI - 461whp / 467wtq
Appreciate 0
      08-06-2019, 08:19 PM   #3
Jeespinozar
135i fan
United_States
7
Rep
14
Posts

Drives: 2008 and 2013 BMW 135i
Join Date: Jan 2009
Location: Virginia

iTrader: (0)

Rmtt

Tips for XTRON installation learned the hard way:

1. Yellow - constant 12 Volts: Buy a MINI fuse tap at AutoZone. Use the third fusefuse from bottom left (5AMP). Will post a picture

2. iPhone Contacts sync with Xtron over Bluetooth: You have to go on Settings/Google and disable data sync with your Google account. Then the iPhone will show the option to sync contacts in Settings/Bluetooth/Xtrons (of whatever name you use for the head unit)

3. CP01 dongle for CarPlay: Still does not work with Android 9, despite the new patch Xtrons send me.

4. The antenna wire does not need a 12 V

5. The amp blue wire (female) from the main adapter has to be connected to the blue wire (male) part of the external amp wires. Use the sample principle for the AUX input

6. Do not put the mic close to the dash - Best place to put it=close to the original mic, around the interior reading lights (let me know if you need help removing that panel. I changed original rearview mirror for the one with compas (using retrofit kit) and I know it is a pain to remove.
__________________
Jorge
Appreciate 1
Rmtt1283.00

      08-06-2019, 08:22 PM   #4
Jeespinozar
135i fan
United_States
7
Rep
14
Posts

Drives: 2008 and 2013 BMW 135i
Join Date: Jan 2009
Location: Virginia

iTrader: (0)

12V Constant source behind glove box

Double check with a multimeter but that worked well with my 2013 135i - US spec.
Third fuse from bottom left (5AMP)
Note: Buy the MINI fuse tap (not the micro).
Attached Images
 
__________________
Jorge
Appreciate 0
      08-07-2019, 08:40 AM   #5
Rmtt
Major
Rmtt's Avatar
United_States
1283
Rep
1,230
Posts

Drives: 2011 BMW 128i, 2008 LS3 C6
Join Date: Jan 2019
Location: South Carolina

iTrader: (3)

Quote:
Originally Posted by Jeespinozar View Post
Double check with a multimeter but that worked well with my 2013 135i - US spec.
Third fuse from bottom left (5AMP)
Note: Buy the MINI fuse tap (not the micro).
Thanks....already have the mini fuse tap. I have an Android phone, so setting the unit up should be no issues.

I may have misstated #4 and #5. I did connect the blue wires the way you suggested.

Also chris_flies has the updated files for carplay to work. He ran into the same issue, but fixed it within days.

I really need to research what is need to add an amp and start upgrading some speakers. I thought about getting updated speakers for the doors to see if maybe the Xtron's unit may be pushing a little more power out than the original head unit.

However the more I have looked, the more I have seen that you really almost have to start over with the entire system.

I would be happy if it sounded as good as the stock system in my Corvette. I don't listen to loud or "booming" music...but it sounds sort of "tinny" and lacks depth the way it is.
__________________
2011 128i: 3:73 Rear Diff, 3SI Intake, AA Headers, Magnaflow Catback, AFE Scoops, Turner Silicone Hose, Charcoal Delete, StageFP Stage 2 Tune, APEX ARC8, MILVS Coming!!

2008 Z51 C6 LS3 w/ LG SuperPros, Ported Fast 102 Intake, RPM Level 2 Transmission, "Small Cam" Vararam SnakeCharmer CAI - 461whp / 467wtq
Appreciate 0
      09-18-2019, 06:05 PM   #6
Naimsito21
Registered
0
Rep
2
Posts

Drives: 135i 2010 m sport package
Join Date: May 2018
Location: chicago

iTrader: (0)

Just curious I recently bought this and was just wondering how you got the bottom piece fit properly. I know you have to cut the sides of the AC unit but I want to make sure that before I do it, it fits right how it’s suppose to.
Appreciate 0
Post Reply

Bookmarks

Tags
android, carplay, e82, radio, xtrons

Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off



All times are GMT -5. The time now is 11:31 PM.




1addicts
Powered by vBulletin® Version 3.8.11
Copyright ©2000 - 2019, vBulletin Solutions Inc.
1Addicts.com, BIMMERPOST.com, E90Post.com, F30Post.com, M3Post.com, ZPost.com, 5Post.com, 6Post.com, 7Post.com, XBimmers.com logo and trademark are properties of BIMMERPOST