BMW 1 Series Coupe Forum / 1 Series Convertible Forum (1M / tii / 135i / 128i / Coupe / Cabrio / Hatchback) (BMW E82 E88 128i 130i 135i)
 





 

Post Reply
 
Thread Tools Search this Thread
      09-12-2019, 06:47 PM   #1
MattH
New Member
MattH's Avatar
United_States
3
Rep
11
Posts

Drives: 2006 M5
Join Date: Dec 2013
Location: Montecito, CA

iTrader: (0)

Garage List
2011 135i  [0.00]
2006 M5  [0.00]
Smog Referee Hell

I am looking for help on the issues I have with my car if anyone is going through this or been there done that...please let me know what to do:

Truth about my car: 2011 135I M pack, DCT. has FBO and Cobb tune.

Two years ago took car into smog shop guy smogs and passes my car with FBO stuff on and Cobb tune installed. This year, same guy; scans dmv printout and says my car is flagged and I need to go to a referee. I say OK not knowing anything. Smog ref: you need an appointment to talk to me. I call 800 number to get an appointment. I also talk to my local indy shop explain the situation. Question is: why did it get flagged?

I go back to the smog tech: he says the car was flagged before he touched it. I say how? Smog guy can't and wouldn't tell me anything. So i only know that he is the guy that flagged my car. A shouting match ensues, I leave. I tell my indy guy: I have no clue why I was flagged, maybe there is magic fairies that flag peoples cars? My indy shop and I agree we must just put the car back to stock...Takes me a week or so to find where I put all this factory parts, I lose my appointment...I find all the factory parts, I bring them to my indy guy he installs, we uninstall the Cobb tune. Car is all stock again...I wait three days for my new referee appointment.

Before my appointment I notice there were some email attachments to the appointment notification and read them and it has some note specific to my car about the DME being flashed and that needs to get fixed. I figure I am good because I uninstalled the Cobb tune. I have an invoice for the smog referee that the car has been fixed to original. Today I fail the inspection because some number (i can't remember what he was saying, it was some computer b.s. didn't match another computer b.s. like a security number) I'm in disbelief, Smog ref tells me go to the BMW dealer and have them flash the original software on there. I asked what software is on there now? Smog ref says he's not sure. I call BMW dealer they want $188 to flash it back to factory specs, but tells me it's no guarantee that it will still pass the smog referee. When I am ready I need to send the referee proof my car was reflashed, and all sensors are in a ready state (perform drive cycle) and call for a new appointment. I am half shocked: one I get the state is spending our tax money faster than it comes in, and this it their way of creating tax dollars and screwing me out my right to modify my car. But seriously if the dealer flash won't fix it for CA standards what am I to do? Has anyone ever been in this sort of bureaucratic treadmill? what do you do buy a whole new computer? That wouldn't match either right?

Sorry for the rant; I do know "smog guys" that do hookups...but since I was flagged by magic, I was flagged by something or someone, so a smog shop wouldn't be able to fix me up anyway.

Update: Called Cobb, told them my story. Cobb employee tells me when I installed the tune it should have saved the factory flash. Asks me if I saved factory flash. I don't remember, but I am sure I wouldn't have deleted it...Cobb employee suggests maybe the factory tune was deleted. I can't verify what is done to it because it is not installed anymore. I did uninstall the tune. Cobb employee is quiet...I am waiting for more info...he has none...I ask if they have a BMW 135I factory tune they can send me. Cobb employee says no. I thanks him for all his non-help. (I will try again tomorrow and ask for someone who has been there a while or a supervisor or something.)

Thanks for all the replies! glad to know I am the only one going through this

Last edited by MattH; 09-13-2019 at 09:03 PM.. Reason: Update call with Cobb
Appreciate 0
      09-13-2019, 03:42 PM   #2
MattH
New Member
MattH's Avatar
United_States
3
Rep
11
Posts

Drives: 2006 M5
Join Date: Dec 2013
Location: Montecito, CA

iTrader: (0)

Garage List
2011 135i  [0.00]
2006 M5  [0.00]
Nobody huh? seems legit.

New guy gets 14 responses...nobody knows shit about CA smog OK. Thanks I will go back to lurking.
Appreciate 0
      09-13-2019, 03:50 PM   #3
Suprgnat
German cars and French tires.
Suprgnat's Avatar
United_States
930
Rep
1,750
Posts

Drives: 2013 128i LMB 6MT ZMP Slicktop
Join Date: Jan 2013
Location: California

iTrader: (7)

Garage List
Quote:
Originally Posted by MattH View Post
New guy gets 14 responses...nobody knows shit about CA smog OK. Thanks I will go back to lurking.
Damn, it hasn't even been 24 hours.
__________________
Inertia is the enemy.

Appreciate 2
dtla1341.00

      09-16-2019, 04:37 PM   #4
dtla1
Major
dtla1's Avatar
341
Rep
1,302
Posts

Drives: 2011 135i, Space Grey
Join Date: Apr 2014
Location: Silicon Valley

iTrader: (2)

From what I've read, you can get referred to the referee randomly, but the note in the email attachment about a DME something or other is weird.

You should get the referee to tell you exactly why the reason for failure is and a printout showing that. It would help to know exactly what the hell is not matching.

For example, when I read codes on my car, it sometimes tells me something about the radio not matching, and I could care less to be honest. I don't know if that's because I have an aftermarket amp or what it is, but I hope you get my point.

Getting that info from the ref will also help when you try to take to the dealer to explain what's going on, and there might be someone out there (here, somewhere) that does coding, that might be able to fix this.
Appreciate 0
      09-18-2019, 03:10 PM   #5
MattH
New Member
MattH's Avatar
United_States
3
Rep
11
Posts

Drives: 2006 M5
Join Date: Dec 2013
Location: Montecito, CA

iTrader: (0)

Garage List
2011 135i  [0.00]
2006 M5  [0.00]
Thanks for the reply, and no offense to you but I quit updating the situation because it seems nobody else has this issue or could give rats ass about helping me out. I have since learned a good deal of information on how this all happened and how to fix it. I'll bet I should post it all here right?

If you modded your 135i and live in CA...good luck. Don't ask me. I'm trying to just lurk.

I asked the moderators to delete this thread. Obviously they won't.
Appreciate 0
      09-18-2019, 04:05 PM   #6
Suprgnat
German cars and French tires.
Suprgnat's Avatar
United_States
930
Rep
1,750
Posts

Drives: 2013 128i LMB 6MT ZMP Slicktop
Join Date: Jan 2013
Location: California

iTrader: (7)

Garage List
Quote:
Originally Posted by MattH View Post
Thanks for the reply, and no offense to you but I quit updating the situation because it seems nobody else has this issue or could give rats ass about helping me out. I have since learned a good deal of information on how this all happened and how to fix it. I'll bet I should post it all here right?

If you modded your 135i and live in CA...good luck. Don't ask me. I'm trying to just lurk.

I asked the moderators to delete this thread. Obviously they won't.
I would have helped, but I haven't had to smog a car since 1997. The 128i will be the first car I've kept long enough to require a smog check since then. This is a good community, I think most GAS and would help too, if they could.

Please, post away!
__________________
Inertia is the enemy.

Appreciate 0
      09-19-2019, 01:20 PM   #7
kaiv
IG: limited.slip
United_States
193
Rep
1,731
Posts

Drives: E46 M3 in a 325i Touring body!
Join Date: Mar 2010
Location: San Diego, CA

iTrader: (25)

I'm running into a similar issue with the State Referee.

They are failing me for the same reason: some number not matching in the DME. This is the first I hear of someone else being given this reason. I think it's a new thing for 2019...

I have:

1) Gone to an official BMW dealer, paid an hour labor, had them issue paperwork confirming software is correct.

-> FAIL

2) Recorded the entire DME flashing process from start to finish at a reputable independent. Full overwrite, with genuine BMW software set on auto update (meaning that the software itself selects the latest and newest programming for that particular DME, I am not inputing any numbers).

-> FAIL

I have tried and tried to get more details on what that "software number doesn't match" means to no available.

Is it a software version? and if so which do they want me to flash? They won't tell me.

I am tired of wasting hours and hours with this. After each flash the monitors are reset. And each visit is a half day. I do not know what to do at this point. Keep flashing until I magically hit the software version they want? There's probably ~100 different revisions for my model. Sue the state? ( ) I know the car is 100% compliant. No resolution in sight.
Appreciate 0
      09-20-2019, 02:17 PM   #8
MattH
New Member
MattH's Avatar
United_States
3
Rep
11
Posts

Drives: 2006 M5
Join Date: Dec 2013
Location: Montecito, CA

iTrader: (0)

Garage List
2011 135i  [0.00]
2006 M5  [0.00]
Quote:
Originally Posted by kaiv View Post
I'm running into a similar issue with the State Referee.

They are failing me for the same reason: some number not matching in the DME. This is the first I hear of someone else being given this reason. I think it's a new thing for 2019...

I have:

1) Gone to an official BMW dealer, paid an hour labor, had them issue paperwork confirming software is correct.

-> FAIL

2) Recorded the entire DME flashing process from start to finish at a reputable independent. Full overwrite, with genuine BMW software set on auto update (meaning that the software itself selects the latest and newest programming for that particular DME, I am not inputing any numbers).

-> FAIL

I have tried and tried to get more details on what that "software number doesn't match" means to no available.

Is it a software version? and if so which do they want me to flash? They won't tell me.

I am tired of wasting hours and hours with this. After each flash the monitors are reset. And each visit is a half day. I do not know what to do at this point. Keep flashing until I magically hit the software version they want? There's probably ~100 different revisions for my model. Sue the state? ( ) I know the car is 100% compliant. No resolution in sight.
Damn Kaiv, thank you for confirming my situation, I seriously thought the state was just screwing with me. So I am at your stage 1, i have been putting drive cycles on the car to try and wake up the Evap monitor, it won't light up. I am really glad you have set my expectations because I might have choked that smog ref after all this. I had FBO and a Cobb tune. I put all the OEM parts on, un-installed the Cobb tune, Failed, was told to reflash at the dealer, and again: waiting for the Evap Monitor to wake up. I am going to fail anyway. This state can go to hell. I hope the Feds cancel these emission waivers and we can be free to modify and enjoy our cars again. Stay in touch, I am going to see if there is any lawyers doing a class action or something.
Appreciate 0
      09-20-2019, 03:08 PM   #9
MattH
New Member
MattH's Avatar
United_States
3
Rep
11
Posts

Drives: 2006 M5
Join Date: Dec 2013
Location: Montecito, CA

iTrader: (0)

Garage List
2011 135i  [0.00]
2006 M5  [0.00]
Quote:
Originally Posted by MattH View Post
Damn Kaiv, thank you for confirming my situation, I seriously thought the state was just screwing with me. So I am at your stage 1, i have been putting drive cycles on the car to try and wake up the Evap monitor, it won't light up. I am really glad you have set my expectations because I might have choked that smog ref after all this. I had FBO and a Cobb tune. I put all the OEM parts on, un-installed the Cobb tune, Failed, was told to reflash at the dealer, and again: waiting for the Evap Monitor to wake up. I am going to fail anyway. This state can go to hell. I hope the Feds cancel these emission waivers and we can be free to modify and enjoy our cars again. Stay in touch, I am going to see if there is any lawyers doing a class action or something.
Called Cobb, explained situation they have nothing, asked for my email to send them photos of rev #, smog paperwork etc. Says never heard this before, insists that uninstalling tune will resolve issue. Says should be fine I says no it isn't and Cobb needs to be aware this kills DME. Guy says there is disclaimer on website on emissions. I say yeah but that assumes if you uninstall car is stock again, but in CA this permanently fails DME and that is different than your disclaimer. Says will take it up with his chain of command.

Called Smog Ref (I have his cell phone number because of the frequency of this) I say I expect to fail after all this dealership flash. What is the next course of action? Smog ref says some people have to buy new computer, a "virgin" computer with dealer flash will correct this issue. I put him on hold so I can lose my shit, I get back on he says, definitely try to pass as is because you never know and I don't think you need a new computer just yet, 50% of cars with this issue will pass after the flash. I explain, I been without my car for months now, I spend $1500 on DMV, rental cars, auto repair bills I want to come in with 100% confidence I will pass. He says if i really want to try a new computer go ahead. I weigh cost benefit, time and money. He is right I should just try before I buy a new computer. I AM SO PISSED OFF.
Appreciate 0
      09-20-2019, 03:46 PM   #10
dtla1
Major
dtla1's Avatar
341
Rep
1,302
Posts

Drives: 2011 135i, Space Grey
Join Date: Apr 2014
Location: Silicon Valley

iTrader: (2)

Maybe try writing to the California BAR (Bureau of Automotive Repair, they seem to be in charge of the SMOG program) explaining what is going on and formally request that they disclose what exactly is not matching.

It seems pretty ridiculous that they can only tell you that {some values aren't matching, FAIL}, but won't tell you exactly what.
Appreciate 0
      09-23-2019, 04:09 PM   #11
lemansblau135is
Enlisted Member
lemansblau135is's Avatar
11
Rep
38
Posts

Drives: bmw 135is
Join Date: Apr 2019
Location: nor cal

iTrader: (0)

Garage List
2013 bmw 135is  [0.00]
Hey, I'm interested in what happens...I'm in Cali, too. I just got my DME flashed with a Dinan that was on sale and I'm wondering if I will run into same/similar problems, too. Keep the post updated, please.
Appreciate 0
      09-24-2019, 12:17 PM   #12
houtan
Colonel
houtan's Avatar
391
Rep
2,199
Posts

Drives: 2011 135i
Join Date: Jun 2013
Location: socal

iTrader: (13)

Garage List
2011 135i  [5.00]
Interesting issue. Did you guys ever find out what the actual error is? I have flashed cobb and mhd on my car over the last five or six years and going back to stock seems to not cause any issues when goi g for smog.
Appreciate 1
      09-25-2019, 08:44 AM   #13
sinclair21
New Member
2
Rep
20
Posts

Drives: 135i
Join Date: Jun 2015
Location: bakersfield ca

iTrader: (0)

I am going to be in the same boat it seems that I have software thats not bmw and i have to go to bmw and flash bmw software and try for my 2nt ref appointment
Appreciate 0
      09-25-2019, 08:52 AM   #14
sinclair21
New Member
2
Rep
20
Posts

Drives: 135i
Join Date: Jun 2015
Location: bakersfield ca

iTrader: (0)

Quote:
Originally Posted by dtla1 View Post
Maybe try writing to the California BAR (Bureau of Automotive Repair, they seem to be in charge of the SMOG program) explaining what is going on and formally request that they disclose what exactly is not matching.

It seems pretty ridiculous that they can only tell you that {some values aren't matching, FAIL}, but won't tell you exactly what.

Bar dont tell you anything besides only the ref can tell you what is wrong i tried that yesterday
Appreciate 0
      09-25-2019, 09:28 AM   #15
houtan
Colonel
houtan's Avatar
391
Rep
2,199
Posts

Drives: 2011 135i
Join Date: Jun 2013
Location: socal

iTrader: (13)

Garage List
2011 135i  [5.00]
Quote:
Originally Posted by sinclair21 View Post
Bar dont tell you anything besides only the ref can tell you what is wrong i tried that yesterday
So what is wrong? They are saying you have aftermarket software?
__________________
2011 LMB 135i DCT
Appreciate 0
      09-25-2019, 02:43 PM   #16
MattH
New Member
MattH's Avatar
United_States
3
Rep
11
Posts

Drives: 2006 M5
Join Date: Dec 2013
Location: Montecito, CA

iTrader: (0)

Garage List
2011 135i  [0.00]
2006 M5  [0.00]
Quote:
Originally Posted by sinclair21 View Post
I am going to be in the same boat it seems that I have software thats not bmw and i have to go to bmw and flash bmw software and try for my 2nt ref appointment
Thanks for speaking up sinclair21 My 2nd smog ref is tomorrow, I had my local dealer reflash to factory BMW programing. I will let you know what happens.
Appreciate 0
      09-25-2019, 03:10 PM   #17
sinclair21
New Member
2
Rep
20
Posts

Drives: 135i
Join Date: Jun 2015
Location: bakersfield ca

iTrader: (0)

Thanks man let me know
Appreciate 0
      09-25-2019, 03:30 PM   #18
houtan
Colonel
houtan's Avatar
391
Rep
2,199
Posts

Drives: 2011 135i
Join Date: Jun 2013
Location: socal

iTrader: (13)

Garage List
2011 135i  [5.00]
I still haven't heard exactly what the problem is but if you are needing to reflash your DME, have you contacted someone like bimmergeeks? Might be less expensive than going to the dealership.
__________________
2011 LMB 135i DCT
Appreciate 0
      09-25-2019, 08:57 PM   #19
sinclair21
New Member
2
Rep
20
Posts

Drives: 135i
Join Date: Jun 2015
Location: bakersfield ca

iTrader: (0)

Quote:
Originally Posted by houtan View Post
I still haven't heard exactly what the problem is but if you are needing to reflash your DME, have you contacted someone like bimmergeeks? Might be less expensive than going to the dealership.
Yeah im thinking its going to be a reflash the dtm to the factory software
Appreciate 0
      09-26-2019, 03:13 PM   #20
dtla1
Major
dtla1's Avatar
341
Rep
1,302
Posts

Drives: 2011 135i, Space Grey
Join Date: Apr 2014
Location: Silicon Valley

iTrader: (2)

Quote:
Originally Posted by sinclair21 View Post
Yeah im thinking its going to be a reflash the dtm to the factory software
kaiv Up there in post 7 said he tried that already...
Appreciate 0
      09-26-2019, 05:58 PM   #21
MattH
New Member
MattH's Avatar
United_States
3
Rep
11
Posts

Drives: 2006 M5
Join Date: Dec 2013
Location: Montecito, CA

iTrader: (0)

Garage List
2011 135i  [0.00]
2006 M5  [0.00]
Success! I did a walk-in appointment today. The BMW dealership flash fixed the issue.

Man, what a relief. I asked again for the details of the issue: I couldn't take notes but here is my attempt at explanation: So there are checksum codes that need to match the original code from the factory or dealer. They are all hexadecimal codes of combination of letters and number string, when you add them up you get a value. That value needs to match the security code from the factory.

I think he said that when you flash your car the original tune gets stored on the flash device, every time you install or uninstall this tune the checksum codes change. I asked directly: I says the tuners companies state if you install you can uninstall without any changes. The ref says: I wouldn't trust that because every time you go into the ECU the checksum hexadecimal codes will change. Went on to say if he were to do this he would have a spare ECU one with factory tune that you don't touch and run another ECU to play with. I need to report this all to Cobb and get confirmation that what the smog ref told me is factual. I want to also know if I put the tune back in how can I be sure it will come off undetected in 2 years when I go through this all over again. Also the damn ECU is under the intake so swapping in and out is a straight up hassle. I need to know if I stick with Cobb, or try a JB4 or MHD. I need to know for sure these tunes are undetectable or run another ECU.

So to my friends on here stuck with this issue go down to your local BMW dealer and ask them to reflash your ECU. Mine cost $188.00 in Santa Barbara, took a few hours had it back same day. I would try this since I had success. I will lurk on here if any question come up. The way I feel today vs. yesterday is like a ton of pressure off my body and mind, I hope this brings you guys some relief.
Appreciate 2
dtla1341.00
houtan391.00

      09-26-2019, 06:06 PM   #22
sinclair21
New Member
2
Rep
20
Posts

Drives: 135i
Join Date: Jun 2015
Location: bakersfield ca

iTrader: (0)

Well im glad you passed and i. Have my appointment Monday haha and tonlet you know mhd can be seen it is what i have
Appreciate 0
Post Reply

Bookmarks

Tags
smog

Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off



All times are GMT -5. The time now is 04:06 PM.




1addicts
Powered by vBulletin® Version 3.8.11
Copyright ©2000 - 2019, vBulletin Solutions Inc.
1Addicts.com, BIMMERPOST.com, E90Post.com, F30Post.com, M3Post.com, ZPost.com, 5Post.com, 6Post.com, 7Post.com, XBimmers.com logo and trademark are properties of BIMMERPOST