BMW 1 Series Coupe Forum / 1 Series Convertible Forum (1M / tii / 135i / 128i / Coupe / Cabrio / Hatchback) (BMW E82 E88 128i 130i 135i)
 





 

Post Reply
 
Thread Tools Search this Thread
      02-11-2019, 02:56 PM   #1
519.E82
Second Lieutenant
519.E82's Avatar
Canada
118
Rep
283
Posts

Drives: BMW 128i Sport (Non M)
Join Date: Apr 2016
Location: Ontario, Canada

iTrader: (0)

Ripped off + Bad DISA valves? [SOLVED]

[SOLVED SEE POST 9]

Hello,
While my car is in storage I have been preparing a list of items to fix/replace on the BMW and just to give it a general tune up. I decided while i enjoy using INPA i wanted to try out ISTA. Upon doing an initial scan i noticed I had some fault codes. majority of which can be ignored and just need to be cleared but 2 stood out to me.

002AA8 DME: Variable intake system, servomotor activation
002AA9 DME: Variable intake system, servomotor 2 activation

The codes have popped up previously and am now just further looking into it. When i first installed the 3-Stage IM I had mentioned it felt a bit lack luster (this was several months ago but only have but on less than 2k km since). Would its most probable cause be i was lied to on purchase and got a unit with bad DISA valves and should I look into replacing or rebuilding?

Thank you.

Car details: 2008 BMW 128i, 3 Stage intake manifold installed and tuned with the 130i Bimmerlabs conversion tune.
__________________
2008 SGM 128i - 3 Stage IM - 130i Tune - BMW PE - Injen Intake - 1M Mirrors - LCI Blacklines - M4 Spoiler - Blacked 263's - Aero Bumper - Aero Side Skirts - OMGSplitter - AFE Intake Scoops

Last edited by 519.E82; 02-15-2019 at 02:48 PM. Reason: answered
Appreciate 0
      02-11-2019, 03:39 PM   #2
Rmtt
Lieutenant
Rmtt's Avatar
United_States
200
Rep
437
Posts

Drives: 2011 BMW 128i
Join Date: Jan 2019
Location: Southeast

iTrader: (0)

Those are the two codes I've seen that most frequently represent DISA faults throughout my research.

I'm probably in the same boat as it seems to be a "roll of the dice".

I'm getting ready to put mine in, and the only way I know to check them is visually, and then by plugging them into the car to see if they actuate or sweep from what I've been reading.

But try to look on the bright side, if they are faulty....it will be like a whole new horse power mod that you should be able to notice since you were already tuned.

From what I have read, it should be a pretty noticble gain.
Appreciate 0
      02-11-2019, 03:42 PM   #3
desertman123
E82 Mudflap Ambassador
desertman123's Avatar
United_States
1495
Rep
1,701
Posts

Drives: '08 128i
Join Date: May 2016
Location: Orlando, FL

iTrader: (0)

Garage List
2008 BMW 128i  [5.00]
2014 BMW 528i  [5.00]
Replace. Chances are the motors inside are broken.

I got 2AA9 when my small DISA's motor broke. Once I replaced it my partial throttle-response became way smoother.
__________________

My 2008 128i - Sparkling Graphite/Beige - Sport pkg - 6MT - Click me!
Parents' 2014 528i - Mineral White/Ivory White - fully loaded
Instagram @Andreys_128i
Appreciate 0
      02-11-2019, 03:44 PM   #4
519.E82
Second Lieutenant
519.E82's Avatar
Canada
118
Rep
283
Posts

Drives: BMW 128i Sport (Non M)
Join Date: Apr 2016
Location: Ontario, Canada

iTrader: (0)

Quote:
Originally Posted by Rmtt View Post
Those are the two codes I've seen that most frequently represent DISA faults throughout my research.

I'm probably in the same boat as it seems to be a "roll of the dice".

I'm getting ready to put mine in, and the only way I know to check them is visually, and then by plugging them into the car to see if they actuate or sweep from what I've been reading.

But try to look on the bright side, if they are faulty....it will be like a whole new horse power mod that you should be able to notice since you were already tuned.

From what I have read, it should be a pretty noticble gain.
Well brightside its $800cad to replace or $150 to take it all apart again and rebuild
__________________
2008 SGM 128i - 3 Stage IM - 130i Tune - BMW PE - Injen Intake - 1M Mirrors - LCI Blacklines - M4 Spoiler - Blacked 263's - Aero Bumper - Aero Side Skirts - OMGSplitter - AFE Intake Scoops
Appreciate 0
      02-11-2019, 03:46 PM   #5
519.E82
Second Lieutenant
519.E82's Avatar
Canada
118
Rep
283
Posts

Drives: BMW 128i Sport (Non M)
Join Date: Apr 2016
Location: Ontario, Canada

iTrader: (0)

Quote:
Originally Posted by desertman123 View Post
Replace. Chances are the motors inside are broken.

I got 2AA9 when my small DISA's motor broke. Once I replaced it my partial throttle-response became way smoother.
So expensive thoughh more then the price i paid for it all.

It always felt smooth, sounded better, and maybe slight gains but nothing huge i don't think
__________________
2008 SGM 128i - 3 Stage IM - 130i Tune - BMW PE - Injen Intake - 1M Mirrors - LCI Blacklines - M4 Spoiler - Blacked 263's - Aero Bumper - Aero Side Skirts - OMGSplitter - AFE Intake Scoops
Appreciate 0
      02-11-2019, 06:23 PM   #6
Rmtt
Lieutenant
Rmtt's Avatar
United_States
200
Rep
437
Posts

Drives: 2011 BMW 128i
Join Date: Jan 2019
Location: Southeast

iTrader: (0)

Quote:
Originally Posted by 519.E82 View Post
Well brightside its $800cad to replace or $150 to take it all apart again and rebuild
Yeah....it sucks.

I didn't even realize you could rebuild them. Learn something new daily here. I've read of people getting manifolds with 100K + miles and no issues, and then also the flip side of getting a low mileage intake only to experience this issue and having to do it all over again.

Whatever you decide, best of luck.
Appreciate 0
      02-14-2019, 04:08 PM   #7
519.E82
Second Lieutenant
519.E82's Avatar
Canada
118
Rep
283
Posts

Drives: BMW 128i Sport (Non M)
Join Date: Apr 2016
Location: Ontario, Canada

iTrader: (0)

Potential follow up?
So i dug a little deeper on the computer and found a code inside the code details. So further into the 002AA8 and 002AA9 codes and found the code P1511. This code means DISA control circuit electrical.

So ontop of the valves being bad is it possible i hooked the connectors to the wrong valve? Or not fully in? Or bad wiring somewhere?

EDIT: i also tried activating the component on ISTA, should i be able to hear anything or get a notification? I had no knowledge as to if it did or did not complete the activation.
__________________
2008 SGM 128i - 3 Stage IM - 130i Tune - BMW PE - Injen Intake - 1M Mirrors - LCI Blacklines - M4 Spoiler - Blacked 263's - Aero Bumper - Aero Side Skirts - OMGSplitter - AFE Intake Scoops
Appreciate 0
      02-14-2019, 04:20 PM   #8
519.E82
Second Lieutenant
519.E82's Avatar
Canada
118
Rep
283
Posts

Drives: BMW 128i Sport (Non M)
Join Date: Apr 2016
Location: Ontario, Canada

iTrader: (0)

@desertman123 does your connector look like this? I feel like its as far in as i can push but wanted to double check.
Attached Images
 
__________________
2008 SGM 128i - 3 Stage IM - 130i Tune - BMW PE - Injen Intake - 1M Mirrors - LCI Blacklines - M4 Spoiler - Blacked 263's - Aero Bumper - Aero Side Skirts - OMGSplitter - AFE Intake Scoops
Appreciate 0
      02-15-2019, 02:47 PM   #9
519.E82
Second Lieutenant
519.E82's Avatar
Canada
118
Rep
283
Posts

Drives: BMW 128i Sport (Non M)
Join Date: Apr 2016
Location: Ontario, Canada

iTrader: (0)

So I believe I have solved it. The problem: my stupidity when installing. But also the electrical connectors. Idk if anyone else's connectors are like this but the shell/cover to my connectors rotate a full 360. So just the shell does, not the entire connector. So the problem was it would go in about 95% but not fully clip in and could not be pushed in any further because the inner bit of the lock tab was getting caught and not in its slot on the top. So basically it was pressure fitted almost fully in and would require force to remove but was just not quite 100% in.

Now i tested only 1 of the valves (using ISTA) the large one because its easier, and i switched both connectors around without removing the intake manifold. The small valve connector on the inner side of the manifold was a PIA to do.

I filmed a short video of how to do it with ISTA and filmed a small bit of it so i may make a DIY for others to know as an easy way to test,

EDIT: link to the DIY/testing https://www.1addicts.com/forums/show...3#post24386353
__________________
2008 SGM 128i - 3 Stage IM - 130i Tune - BMW PE - Injen Intake - 1M Mirrors - LCI Blacklines - M4 Spoiler - Blacked 263's - Aero Bumper - Aero Side Skirts - OMGSplitter - AFE Intake Scoops

Last edited by 519.E82; 02-15-2019 at 03:30 PM.
Appreciate 0
      02-15-2019, 05:03 PM   #10
Rmtt
Lieutenant
Rmtt's Avatar
United_States
200
Rep
437
Posts

Drives: 2011 BMW 128i
Join Date: Jan 2019
Location: Southeast

iTrader: (0)

Congrats on figuring it out!
Appreciate 1
519.E82117.50

Post Reply

Bookmarks

Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off


All times are GMT -5. The time now is 11:32 PM.




1addicts
Powered by vBulletin® Version 3.7.0
Copyright ©2000 - 2019, Jelsoft Enterprises Ltd.
1Addicts.com, BIMMERPOST.com, E90Post.com, F30Post.com, M3Post.com, ZPost.com, 5Post.com, 6Post.com, 7Post.com, XBimmers.com logo and trademark are properties of BIMMERPOST