BMW 1 Series Coupe Forum / 1 Series Convertible Forum (1M / tii / 135i / 128i / Coupe / Cabrio / Hatchback) (BMW E82 E88 128i 130i 135i)
 





 

Post Reply
 
Thread Tools Search this Thread
      07-12-2020, 01:27 PM   #1
Roboyle
Registered
0
Rep
2
Posts

Drives: 2008 BMW 128i Convertible
Join Date: May 2020
Location: Austin, Texas

iTrader: (0)

Oil Level Sensor Going Up

Hi all,

Here we go, another oil level sensor thread. I find myself in a bit of a (potentially) uncomfortable situation. A few months ago I purchased a 2008 128i with about 67k miles and have since added about 2k miles.

Changing the oil was one of the first things I did. It's consistently been about 3/4 of the way between min and max since then, until 2-3 days ago, when it suddenly started reading right at the full line.

Normally I might chalk this up to a weird sensor quirk and just watch it over time (I'll still be monitoring it), but something else has gotten me concerned. Since I bought the car I've replaced some of the fluids, including the coolant. I didn't fully drain the coolant because the thermostat/pump are original and I figure they'll be going soon, so I'll do a full coolant replacement when they go and probably change some old coolant hoses as well. So for now, all I did was drain through the radiator and molest the coolant hoses to push some more out.

Since then, my coolant has been slowly leaking, from the max to min mark on the coolant level gauge over the course of a couple days. At first I thought it was just air continuing to bleed out, and while the rate of "leaking" has slowed down I believe there still is some loss. I haven't gotten under the car yet to check it, but I hope it's either the radiator petcock that's pretty beat up and needs to be replaced, or a particular coolant hose I felt that has a very brittle spot that might have cracked a bit.

Because the coolant level has been going down slowly, I'm particularly concerned about how this might relate to the oil level sensor going up. I stuck a flashlight at the coolant expansion reservoir today and didn't notice any discoloration of the coolant in there from oil, nice blue all the way down.

I haven't looked into it too much, but I think I remember reading that the oil filter housing is a potential area where coolant and oil may mix if there's a leak.

Regardless, I'm going to just continue to monitor the levels of both fluids and see what happens. If, over the next couple of weeks, the oil level sensor stays at max and doesn't go into the over-filled range I'll just chalk it up to a BMW quirk and leave it be. I'm hoping some of y'all more experienced owners will read my essay above and weigh in with y'alls thoughts. Thanks!
Appreciate 0
      07-14-2020, 11:17 AM   #2
zx10guy
Colonel
2836
Rep
2,658
Posts

Drives: 2013 135i
Join Date: Feb 2014
Location: DC

iTrader: (0)

My coolant level started going down because there was a crack in the expansion tank. I heard this is another pretty common failure point in these cars and my car is much newer than yours.

If you think you might have a head gasket issue which I haven't really seen too many of, you can get a combustion gas tester to be sure. It's a chemical that changes from a blue color to a yellow color in the presence of combustion gases. The fluid gets loaded into a turkey baster type device. You just push one end into the expansion tank with the bulb squeezed and release to draw in air from the tank. Very easy test to do.
__________________
Quote:
Originally Posted by Lups View Post
We might not be in an agreement on Trump, but I'll be the first penis chaser here to say I'll rather take it up in the ass than to argue with you on this.
Appreciate 0
      07-14-2020, 02:48 PM   #3
gjm120
Colonel
United_States
1655
Rep
2,487
Posts

Drives: 2013 128i
Join Date: Jan 2016
Location: East Texas

iTrader: (0)

If you have any oil from the change lying maybe send it somewhere for an analysis.
__________________
E82 / BMWP Springs / Koni Yellows / M front control arms / Adjustable front endlinks / M rear guide rods / RSFB inserts / AT + paddles
Appreciate 0
      07-17-2020, 06:23 PM   #4
Edrift
Private First Class
Australia
66
Rep
180
Posts

Drives: BMW 135i E88
Join Date: Jun 2019
Location: Melbourne Australia

iTrader: (0)

Does your coolant or oil look like a chocolate milkshake? If so, the fluids are mixing. Replace your ofhg. It's a very cheap part and easy to do, especially on non turbo engines like yours. It's also inexpensive ($A19 in Australia, so probably $US5 for OEM)

I replaced mine on my n54 135i recently as it started to seep at 51000km.
The coolant part of the gasket was wrecked.
I didn't have fluids mixing, only an external oil seep.
Appreciate 0
Post Reply

Bookmarks

Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off



All times are GMT -5. The time now is 09:48 AM.




1addicts
Powered by vBulletin® Version 3.8.11
Copyright ©2000 - 2020, vBulletin Solutions Inc.
1Addicts.com, BIMMERPOST.com, E90Post.com, F30Post.com, M3Post.com, ZPost.com, 5Post.com, 6Post.com, 7Post.com, XBimmers.com logo and trademark are properties of BIMMERPOST