BMW Garage BMW Meets Register Search Today's Posts Mark Forums Read




 

Post Reply
 
Thread Tools Search this Thread
      01-16-2020, 01:40 AM   #1
frenzy757
Private First Class
28
Rep
115
Posts

Drives: AW 1M coupe
Join Date: Oct 2014
Location: San Francisco

iTrader: (0)

Noticing a bit of turbo lag

So my 1m has: Forge intercooler, GAIC Stg 1 tune, intake/midpipe. The car has some turbo lag where it feels like a normal turbo cars of old.

I remember my 100% stock 1m having almost instant thrust...a bit of lag, but the power came on FAST. This car seems to build up like a normal car. Do you all know why this could be the case? Did the tune do that? Larger IC?
__________________
Current: Back in an AW 1M =)
Past: 86 Starion, 350z, Supra TT Auto, Supra TT 6 spd, E46 M3, BMW 1m Coupe, S2000, 987.2 CS, ND2 MX5, LSB e46 M3
Appreciate 0
      01-16-2020, 11:17 AM   #2
hunterl41
First Lieutenant
hunterl41's Avatar
United_States
74
Rep
351
Posts

Drives: 2011 1M
Join Date: Jun 2013
Location: Detroit

iTrader: (10)

Garage List
2011 BMW 1M  [0.00]
How long since last walnut blasting? The more carbon build up the more sluggish mine starts to feel over time.
Appreciate 0
      01-16-2020, 11:44 AM   #3
ShocknAwe
1Addict
ShocknAwe's Avatar
United_States
2309
Rep
6,977
Posts

Drives: E82 N54 Mutt
Join Date: Jul 2012
Location: Charleston

iTrader: (20)

Try a throttle reset. Other possibilities are that your tune adjusted the wastegate adaptation.

Doubt a small increase in FMIC size would produce tangible lag.
__________________
2010 135i M-Sport 6MT Jet Black
N54 | BUILD THREAD | GARAGE SALE
Appreciate 0
      01-23-2020, 07:04 PM   #4
dtla1
Lieutenant Colonel
dtla1's Avatar
538
Rep
1,567
Posts

Drives: 2011 135i, Space Grey
Join Date: Apr 2014
Location: Silicon Valley

iTrader: (2)

OP also mentioned in another thread that it he saw the boost was being limited "I also ran some highway pulls and boost seems to be limited to 6-7PSI in 1st and 2nd gear, 3rd gear goes up to 15psi, which seems more normal. Just wondering what could have caused this as mods were installed by a PO and not me."

And I suggested "Are you sure you have a GIAC tune installed on the car? Boost limiting by gear is a pretty common setting using a JB4, not saying you have a JB4, just that what you describe is a common and easily achievable modification by the JB4."

I understand now they confirmed there's a GIAC tune on the car, my theory about a possible JB4 may still be relevant though due to the boost by gear settings.

OP, try pressing the down button on both steering wheel buttons at the same time (minus volume and down arrow), if the guages do anything then that'll confirm there's a JB4 in there.
Appreciate 0
      02-21-2020, 10:40 AM   #5
frenzy757
Private First Class
28
Rep
115
Posts

Drives: AW 1M coupe
Join Date: Oct 2014
Location: San Francisco

iTrader: (0)

Tried it and the guages didnt do anything. Might have to take it into a shop.
__________________
Current: Back in an AW 1M =)
Past: 86 Starion, 350z, Supra TT Auto, Supra TT 6 spd, E46 M3, BMW 1m Coupe, S2000, 987.2 CS, ND2 MX5, LSB e46 M3
Appreciate 0
Post Reply

Bookmarks

Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off



All times are GMT -5. The time now is 04:40 AM.




1addicts
Powered by vBulletin® Version 3.8.11
Copyright ©2000 - 2020, vBulletin Solutions Inc.
1Addicts.com, BIMMERPOST.com, E90Post.com, F30Post.com, M3Post.com, ZPost.com, 5Post.com, 6Post.com, 7Post.com, XBimmers.com logo and trademark are properties of BIMMERPOST