BMW 1 Series Coupe Forum / 1 Series Convertible Forum (1M / tii / 135i / 128i / Coupe / Cabrio / Hatchback) (BMW E82 E88 128i 130i 135i)
 





 

Post Reply
 
Thread Tools Search this Thread
      12-08-2018, 11:06 AM   #397
E30ROB
Private
74
Rep
93
Posts

Drives: 128i AW3 6MT slicktop
Join Date: Feb 2017
Location: Raleigh NC

iTrader: (0)

Quote:
Originally Posted by chris_flies View Post
Here's my cluster now:
Attachment 1849727

It is a 135i cluster that came off a car with 89k miles. I think it was an '08, but I'm not sure, it was $99.

After tearing into it, I found that the EEPROM was the same model (080D0WQ) as was on my 128i's cluster. I then thought, heck, I'll just swap the EEPROMs around since they're the same model, they must communicate and work the same way. They did, and everything worked right off the bat; odometer, tacho, speedo, fuel, but the oil temp needle was indicating the instant MPG.

I then delved into Google, and found a few E90 threads about people wanting to change the MPG gauge into an oil temp gauge. I followed the coding instructions, using Tool32, and ended up with a successful code, and it was all done.

Here's a link to a Google Doc I was typing up for my DIY (which I pretty much just wrote here): https://docs.google.com/document/d/1...it?usp=sharing
That's interesting that the 135i cluster acted that way with the oil temp gauge. I installed a 1M cluster into my 128i and everything works as it should, I was lazy and did not do eeprom so I have tamper dot lol
Appreciate 0
      12-08-2018, 11:42 AM   #398
chris_flies
Sideways and Smiling
chris_flies's Avatar
United_States
1540
Rep
1,912
Posts

Drives: Enthusiastically...
Join Date: Mar 2017
Location: Woodbridge, VA, USA

iTrader: (0)

Garage List
2009 BMW 128i  [5.00]
Quote:
Originally Posted by E30ROB View Post
Quote:
Originally Posted by chris_flies View Post
Here's my cluster now:
Attachment 1849727

It is a 135i cluster that came off a car with 89k miles. I think it was an '08, but I'm not sure, it was $99.

After tearing into it, I found that the EEPROM was the same model (080D0WQ) as was on my 128i's cluster. I then thought, heck, I'll just swap the EEPROMs around since they're the same model, they must communicate and work the same way. They did, and everything worked right off the bat; odometer, tacho, speedo, fuel, but the oil temp needle was indicating the instant MPG.

I then delved into Google, and found a few E90 threads about people wanting to change the MPG gauge into an oil temp gauge. I followed the coding instructions, using Tool32, and ended up with a successful code, and it was all done.

Here's a link to a Google Doc I was typing up for my DIY (which I pretty much just wrote here): https://docs.google.com/document/d/1...it?usp=sharing
That's interesting that the 135i cluster acted that way with the oil temp gauge. I installed a 1M cluster into my 128i and everything works as it should, I was lazy and did not do eeprom so I have tamper dot lol
I swappes the 128i EEPROM which must've been programmed for the instant MPG guage from the factory when there's an additional dial present.
__________________
2009 128i 6-Speed Coupé | Monaco Blue with Black Sensatec | chris_flies' 128i Build
N/A Supremacy Propagandist at Large
Appreciate 0
Post Reply

Bookmarks

Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off


All times are GMT -5. The time now is 03:11 AM.




1addicts
Powered by vBulletin® Version 3.7.0
Copyright ©2000 - 2018, Jelsoft Enterprises Ltd.
1Addicts.com, BIMMERPOST.com, E90Post.com, F30Post.com, M3Post.com, ZPost.com, 5Post.com, 6Post.com, 7Post.com, XBimmers.com logo and trademark are properties of BIMMERPOST