BMW 1 Series Coupe Forum / 1 Series Convertible Forum (1M / tii / 135i / 128i / Coupe / Cabrio / Hatchback) (BMW E82 E88 128i 130i 135i)
 





 

Post Reply
 
Thread Tools Search this Thread
      08-04-2020, 11:18 PM   #1
DakarDoug
Private
DakarDoug's Avatar
United_States
6
Rep
57
Posts

Drives: '09 BMW 135i Coupe
Join Date: Jan 2009
Location: Dove Canyon, CA

iTrader: (0)

Lighting Issue on 2009 135i

My angel eyes went out on the driver side then I started having some weird problems. I next had a code for the adaptive headlight failure, then my high and low beam stopped working and now throwing yet another code for cc-id 120. When I went to initially look at the angel eye bulb, the wired had lost all the insulation due to dry rot. I separated them and re-wrapped the wires and still nothing. Any ideas? Ballast? Control module? Need new car? Thanks.
Appreciate 0
      08-07-2020, 09:21 PM   #2
DakarDoug
Private
DakarDoug's Avatar
United_States
6
Rep
57
Posts

Drives: '09 BMW 135i Coupe
Join Date: Jan 2009
Location: Dove Canyon, CA

iTrader: (0)

Update: throwing 3 codes, CC-ID 120, 295, and 378. Switched headlamp bulb and angel eye bulb from passenger side to driver side and no change. So bulbs are good. Thinking I might need to pull bumper off, remove the headlight assembly and perhaps replace the ballast. Anyone else experience this or think I am on the right track?
Appreciate 0
      08-08-2020, 06:14 AM   #3
Gangplank
Colonel
Gangplank's Avatar
United_States
1401
Rep
2,885
Posts

Drives: 2011 e82 135i n55 Sprt DCT - S
Join Date: Nov 2015
Location: Port St. Lucie, FL

iTrader: (1)

Garage List
2011 135i  [0.00]
What year is your 1er? The FRM modules had a warranty extension to 10 years or 150,000 miles. It's a known failure and controls lighting functions.

https://www.1addicts.com/forums/show....php?t=1556106

https://bimmerscan.com/wp-content/up.../B012016-1.pdf
__________________
2011 135i w/ DCT | Sport Pkg | PPK | Ohlins R&T Swift Springs | M3 Front Control Arms | Diff. Brace | RSFB Inserts
Appreciate 0
      08-11-2020, 11:18 PM   #4
DakarDoug
Private
DakarDoug's Avatar
United_States
6
Rep
57
Posts

Drives: '09 BMW 135i Coupe
Join Date: Jan 2009
Location: Dove Canyon, CA

iTrader: (0)

I ordered a ballast/headlight control unit believing it to have gone bad. When I took the old one out, it was corroded on the connector so assume this to be the issue. Will follow up once part is installed.
Appreciate 0
Post Reply

Bookmarks

Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off



All times are GMT -5. The time now is 04:43 PM.




1addicts
Powered by vBulletin® Version 3.8.11
Copyright ©2000 - 2020, vBulletin Solutions Inc.
1Addicts.com, BIMMERPOST.com, E90Post.com, F30Post.com, M3Post.com, ZPost.com, 5Post.com, 6Post.com, 7Post.com, XBimmers.com logo and trademark are properties of BIMMERPOST