BMW 1 Series Coupe Forum / 1 Series Convertible Forum (1M / tii / 135i / 128i / Coupe / Cabrio / Hatchback) (BMW E82 E88 128i 130i 135i)
 





 

Post Reply
 
Thread Tools Search this Thread
      03-06-2019, 03:01 AM   #1
Kdubs88
Enlisted Member
20
Rep
49
Posts

Drives: 2007 e90 328i
Join Date: Aug 2016
Location: Hawaii

iTrader: (0)

Key fob buttons not working, just bought car

Hey guys, yesterday I picked up a 135i m package 6mt. The car came equipped with comfort access, it has the removable key battery and the lines on the door handle. Anyhow, my key buttons don't work, and neither do any of the comfort features. I have to physically take the key out of the fob and stick it in the cylinder to lock/unlock.

So far I've replaced the battery to the key with a brand new one, and checked the fuses. Fuse #6 (5amp) was toast, so I put in a new one. All the other fuses were fine. Still no luck. I'm new to the e82, I've had 2 e92s and 2 e90s. I know most of the stuff is the same but what else should I be checking?

Also, on a side note is there way to calibrate the active steering with inpa? The car just got an alignment but the shop couldn't figure out the active steering. Wheels are straight and car tracks straight but the steering wheel is cocked almost 45° to the left and it's bugging me.

Thanks for any help you guys might offer!
Appreciate 0
      03-06-2019, 03:41 AM   #2
Kdubs88
Enlisted Member
20
Rep
49
Posts

Drives: 2007 e90 328i
Join Date: Aug 2016
Location: Hawaii

iTrader: (0)

Update: the car came with a new diversity antenna not installed. I just installed it and now the buttons on the keys work, but the comfort features do not. What should I look at next?
Appreciate 0
      03-06-2019, 12:28 PM   #3
Kdubs88
Enlisted Member
20
Rep
49
Posts

Drives: 2007 e90 328i
Join Date: Aug 2016
Location: Hawaii

iTrader: (0)

Bump
Appreciate 0
      03-06-2019, 12:48 PM   #4
MightyMouseTech
Major General
MightyMouseTech's Avatar
3478
Rep
5,467
Posts

Drives: 13 135i 6MT LeMans Blue MSport
Join Date: Feb 2013
Location: Ottawa, Canada

iTrader: (0)

Check for water/corrosion in the comfort access module. In the trunk, underneath right tail light.
Appreciate 0
      03-06-2019, 12:49 PM   #5
Kdubs88
Enlisted Member
20
Rep
49
Posts

Drives: 2007 e90 328i
Join Date: Aug 2016
Location: Hawaii

iTrader: (0)

Quote:
Originally Posted by MightyMouseTech View Post
Check for water/corrosion in the comfort access module. In the trunk, underneath right tail light.
Thank you I will go check and report back
Appreciate 0
      03-06-2019, 04:49 PM   #6
atch417
New Member
atch417's Avatar
18
Rep
16
Posts

Drives: 2011 BMW 135i
Join Date: Dec 2018
Location: St. Louis

iTrader: (0)

Quote:
Originally Posted by Kdubs88 View Post
Hey guys, yesterday I picked up a 135i m package 6mt. The car came equipped with comfort access, it has the removable key battery and the lines on the door handle. Anyhow, my key buttons don't work, and neither do any of the comfort features. I have to physically take the key out of the fob and stick it in the cylinder to lock/unlock.

So far I've replaced the battery to the key with a brand new one, and checked the fuses. Fuse #6 (5amp) was toast, so I put in a new one. All the other fuses were fine. Still no luck. I'm new to the e82, I've had 2 e92s and 2 e90s. I know most of the stuff is the same but what else should I be checking?

Also, on a side note is there way to calibrate the active steering with inpa? The car just got an alignment but the shop couldn't figure out the active steering. Wheels are straight and car tracks straight but the steering wheel is cocked almost 45° to the left and it's bugging me.

Thanks for any help you guys might offer!
I had this same problem on my 1 series I bought back in November. Took it to the dealer bc it was still covered and they replaced my driver side door handle (🤷*♂️), battery and did a bunch of programming on the comfort accessory computer in the trunk. Was a heafty price rag but it all works now.
Appreciate 0
      03-08-2019, 09:15 AM   #7
swunder
Second Lieutenant
272
Rep
260
Posts

Drives: 135is, X3
Join Date: Apr 2018
Location: New Jersey

iTrader: (0)

If you picked it up yesterday you don't do anything besides bring it back to whoever you bought it from and have them fix it or reimburse you.
Appreciate 0
      03-09-2019, 05:19 AM   #8
Kdubs88
Enlisted Member
20
Rep
49
Posts

Drives: 2007 e90 328i
Join Date: Aug 2016
Location: Hawaii

iTrader: (0)

Quote:
Originally Posted by swunder View Post
If you picked it up yesterday you don't do anything besides bring it back to whoever you bought it from and have them fix it or reimburse you.
I got the car for super cheap knowing it would need some fixing. Mechanically the car is great. The seller let me know before hand what I was buying. That's why I'm here and not there asking for money back.
Appreciate 0
      04-26-2019, 03:06 AM   #9
jamespaoli
Private
12
Rep
83
Posts

Drives: 128i
Join Date: May 2017
Location: NYC

iTrader: (0)

Quote:
Originally Posted by Kdubs88 View Post
I got the car for super cheap knowing it would need some fixing. Mechanically the car is great. The seller let me know before hand what I was buying. That's why I'm here and not there asking for money back.
I have the same issue and cannot figure it out... May i ask the diversity antenna do you have photos or can you tell me where it was physically?
Appreciate 0
      04-26-2019, 03:08 AM   #10
Kdubs88
Enlisted Member
20
Rep
49
Posts

Drives: 2007 e90 328i
Join Date: Aug 2016
Location: Hawaii

iTrader: (0)

Quote:
Originally Posted by jamespaoli View Post
Quote:
Originally Posted by Kdubs88 View Post
I got the car for super cheap knowing it would need some fixing. Mechanically the car is great. The seller let me know before hand what I was buying. That's why I'm here and not there asking for money back.
I have the same issue and cannot figure it out... May i ask the diversity antenna do you have photos or can you tell me where it was physically?
The diversity antenna is inside of the headliner, all the way at the back by the rear windshield in the middle
Appreciate 0
      04-26-2019, 03:36 AM   #11
jamespaoli
Private
12
Rep
83
Posts

Drives: 128i
Join Date: May 2017
Location: NYC

iTrader: (0)

Thanks Kdubs, i wanted to be sure.. Yes ive replaced this and still same issue..

How is your progress on fixing this issue?
Appreciate 0
      10-24-2019, 11:02 PM   #12
Razorrx
Registered
0
Rep
2
Posts

Drives: 2009 135i and 2008 535i
Join Date: Sep 2018
Location: CA

iTrader: (0)

Any updates?
Appreciate 0
Post Reply

Bookmarks

Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off



All times are GMT -5. The time now is 01:34 PM.




1addicts
Powered by vBulletin® Version 3.8.11
Copyright ©2000 - 2019, vBulletin Solutions Inc.
1Addicts.com, BIMMERPOST.com, E90Post.com, F30Post.com, M3Post.com, ZPost.com, 5Post.com, 6Post.com, 7Post.com, XBimmers.com logo and trademark are properties of BIMMERPOST