BMW 1 Series Coupe Forum / 1 Series Convertible Forum (1M / tii / 135i / 128i / Coupe / Cabrio / Hatchback) (BMW E82 E88 128i 130i 135i)
 





 

Post Reply
 
Thread Tools Search this Thread
      06-17-2016, 12:50 PM   #1
TSum75
Member
United_States
0
Rep
6
Posts

Drives: 2008 BMW 135i Coupe 6-spd man
Join Date: Jun 2012
Location: Atlanta, GA

iTrader: (0)

1/2 Yellow Engine Malfunction & Missing Bolt?

Hello everyone,

I have a 2008 BMW 135i Coupe with 6-speed manual transmission, that I bought brand new... It now has over 102K miles; it's completely stock (for now); and I've always maintained my car (oil changes every 4K miles, etc...); I've had water pump replaced twice (1st time was July 2014 at ~65K miles, 2nd time almost exactly 1 year later to the day in July 2015 at ~82K miles); I've also had valve cover gasket replaced twice (however, the first time, the shop, which is highly reputable shop referred to me by persons in BMW CCA, screwed up, & got lazy & did poor job setting valve cover gasket);

Anyway, last night, I got a 1/2 Yellow Engine Malfunction light... Please see image #1. So, today, I plugged in My BMW Carly OBD II adapter & initially, My BMW Carly adapter showed 2 ENGINE FAULT CODES...

(1) Fault: Fuel pressure sensor, electric - Code: 0029F3, and
(2) Fault: :Boost pressure control 2 - Code: 0030FF

However, per the instructions for use of My BMW Carly adapter, it says to clear all codes, and then run another diagnostic check, which I did, in an effort to narrow down fault codes. So, after I had cleared all codes and ran another diagnostic check, it showed only 1 FAULT CODE -- Fuel Pressure Sensor, Electric 0029F3. Anyway, please see image #1 for the 1/2 yellow engine light.

Anyway, I was checking under the hood just to make sure everything was properly plugged in and that nothing was out of whack, and then I found what appears to be a missing bolt. Please see images #2, #3, and #4.

So, my questions to all of you is: Should there actually be a bolt in that spot under the engine cover, and to the left of the oil filter housing? And then, do you think it's possible that the 1/2 Yellow Engine Light is related to that missing bolt?
Attached Images
    
Appreciate 0
      06-17-2016, 12:57 PM   #2
TSum75
Member
United_States
0
Rep
6
Posts

Drives: 2008 BMW 135i Coupe 6-spd man
Join Date: Jun 2012
Location: Atlanta, GA

iTrader: (0)

And I clicked submit too soon... And my last question is: If that is, in fact, a missing bolt in that spot, what bolt (part number) is it? I've been searching and searching, but I can't seem to find a part number... I'd greatly appreciate any help anyone could offer.

Thanks.
Appreciate 0
      06-17-2016, 01:20 PM   #3
TSum75
Member
United_States
0
Rep
6
Posts

Drives: 2008 BMW 135i Coupe 6-spd man
Join Date: Jun 2012
Location: Atlanta, GA

iTrader: (0)

And I'm reading a lot of stuff re: the low pressure fuel sensor going bad... But I haven't seen any specific DIY re: how to replace it. Does anyone have a link, or any such DIY instructions? I'm reading through everything, and it would be really helpful.

Thanks again.
Appreciate 0
      06-17-2016, 03:12 PM   #4
MightyMouseTech
Major General
MightyMouseTech's Avatar
3421
Rep
5,399
Posts

Drives: 13 135i 6MT LeMans Blue MSport
Join Date: Feb 2013
Location: Ottawa, Canada

iTrader: (0)

There is no missing bolt. That is what all the cars look like.
Appreciate 0
      06-17-2016, 03:13 PM   #5
TSum75
Member
United_States
0
Rep
6
Posts

Drives: 2008 BMW 135i Coupe 6-spd man
Join Date: Jun 2012
Location: Atlanta, GA

iTrader: (0)

Thanks for clarifying for me.
Appreciate 0
      06-27-2016, 07:40 AM   #6
dm874
Lieutenant
dm874's Avatar
57
Rep
482
Posts

Drives: 15' M4
Join Date: Jul 2014
Location: Bucks County,PA

iTrader: (0)

The area is used to screw in a tow-hook looking bolt in order to lift the engine when work is being done on the car by a mechanic (or you)
Appreciate 0
Post Reply

Bookmarks

Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off



All times are GMT -5. The time now is 09:24 PM.




1addicts
Powered by vBulletin® Version 3.8.11
Copyright ©2000 - 2019, vBulletin Solutions Inc.
1Addicts.com, BIMMERPOST.com, E90Post.com, F30Post.com, M3Post.com, ZPost.com, 5Post.com, 6Post.com, 7Post.com, XBimmers.com logo and trademark are properties of BIMMERPOST