BMW 1 Series Coupe Forum / 1 Series Convertible Forum (1M / tii / 135i / 128i / Coupe / Cabrio / Hatchback) (BMW E82 E88 128i 130i 135i)
 





 

Post Reply
 
Thread Tools Search this Thread
      12-04-2019, 08:51 PM   #1
-nexus-
New Member
0
Rep
10
Posts

Drives: 2010 N55 135i
Join Date: Jun 2018
Location: Wollongong, Australia

iTrader: (0)

E82 N55 RHD Heater Core Replacement?

I've spent the last couple of hours looking up how to replace the heater core on a RHD E82, but have found next to no information on doing it on the E82. One guy did a detailed DIY for a LHD E90, and the job looks awful, as well as somewhat different to an E82.

Looking at a few other forums it seems like it might be easier to do on a RHD vehicle as access would be via the passenger (left) side footwell, and possibly without removing large parts of the dashboard. Does anyone have any experience with doing one?
Appreciate 0
      12-08-2019, 06:17 PM   #2
-nexus-
New Member
0
Rep
10
Posts

Drives: 2010 N55 135i
Join Date: Jun 2018
Location: Wollongong, Australia

iTrader: (0)

Bump.
Any ideas?
Appreciate 0
      12-09-2019, 12:39 PM   #3
desertman123
E82 Mudflap Ambassador
desertman123's Avatar
United_States
1753
Rep
1,926
Posts

Drives: '08 128i
Join Date: May 2016
Location: Orlando, FL

iTrader: (0)

Garage List
2008 BMW 128i  [5.00]
2014 BMW 528i  [5.00]
Are you 100% sure you need to replace the heater core?
__________________

My 2008 128i - Sparkling Graphite/Beige - Sport pkg - 6MT - Click me!
Parents' 2014 528i - Mineral White/Ivory White - fully loaded
Instagram @Andreys_128i
Appreciate 0
      12-09-2019, 06:15 PM   #4
-nexus-
New Member
0
Rep
10
Posts

Drives: 2010 N55 135i
Join Date: Jun 2018
Location: Wollongong, Australia

iTrader: (0)

Not 100%, as I have some more fault finding to do before I can be completely certain. However, I am getting a visible fog from the air-conditioning vents (driver side only, strangely) which leaves a greasy sheen on the windscreen. The car has also prompted me twice in the last 3 months for low coolant, so I am hypothesising a pinhole leak in the heater core which is the cause of these symptoms.
Appreciate 0
Post Reply

Bookmarks

Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off



All times are GMT -5. The time now is 07:09 PM.




1addicts
Powered by vBulletin® Version 3.8.11
Copyright ©2000 - 2019, vBulletin Solutions Inc.
1Addicts.com, BIMMERPOST.com, E90Post.com, F30Post.com, M3Post.com, ZPost.com, 5Post.com, 6Post.com, 7Post.com, XBimmers.com logo and trademark are properties of BIMMERPOST