BMW 1 Series Coupe Forum / 1 Series Convertible Forum (1M / tii / 135i / 128i / Coupe / Cabrio / Hatchback) (BMW E82 E88 128i 130i 135i)
 





 

Post Reply
 
Thread Tools Search this Thread
      02-21-2020, 06:07 PM   #1
Hybrid G
New Member
0
Rep
21
Posts

Drives: 135i
Join Date: Dec 2019
Location: Toronto

iTrader: (0)

what is these two boxes in engine bay

Hey I am struggling to find out what these two boxes are in the engine bay and plug as I am trying to clean up the wiring here for my oil catch can, is this OEM? also what is it?





https://photos.app.goo.gl/aswMFNRuCUdELyjX7

https://photos.app.goo.gl/U8CzX8CY8WFxz2KQ8
Attached Images
   

Last edited by Hybrid G; 02-21-2020 at 07:40 PM..
Appreciate 0
      02-21-2020, 06:14 PM   #2
Hybrid G
New Member
0
Rep
21
Posts

Drives: 135i
Join Date: Dec 2019
Location: Toronto

iTrader: (0)

can anyone see the images?
Appreciate 0
      02-21-2020, 06:36 PM   #3
ShocknAwe
1Addict
ShocknAwe's Avatar
United_States
2323
Rep
7,006
Posts

Drives: E82 N54 Mutt
Join Date: Jul 2012
Location: Charleston

iTrader: (20)

no. please just upload them using manage attachments
__________________
2010 135i M-Sport 6MT Jet Black
N54 | BUILD THREAD | GARAGE SALE
Appreciate 0
      02-21-2020, 06:39 PM   #4
dtla1
Lieutenant Colonel
dtla1's Avatar
540
Rep
1,567
Posts

Drives: 2011 135i, Space Grey
Join Date: Apr 2014
Location: Silicon Valley

iTrader: (2)

Yeah, I can see the pictures. This looks like all the wiring pieces for the PPK 2 kit. If you didn't know you had that, now you know!!

See this thread: https://www.1addicts.com/forums/show....php?t=1005490 Post 16 has a link to the install instructions with all the parts and a diagram of the wiring, etc.
Appreciate 0
      02-21-2020, 06:44 PM   #5
MightyMouseTech
Major General
MightyMouseTech's Avatar
3591
Rep
5,609
Posts

Drives: 13 135i 6MT LeMans Blue MSport
Join Date: Feb 2013
Location: Ottawa, Canada

iTrader: (0)

Quote:
Originally Posted by dtla1 View Post
Yeah, I can see the pictures. This looks like all the wiring pieces for the PPK 2 kit. If you didn't know you had that, now you know!!

See this thread: https://www.1addicts.com/forums/show....php?t=1005490 Post 16 has a link to the install instructions with all the parts and a diagram of the wiring, etc.
Yup. That is the wiring retrofit for the upgraded rad fan that comes with the PPK2. Means you should also have the additional coolant rad in the drivers side front bumper, and the factory upgraded tune.
Appreciate 0
      02-21-2020, 07:35 PM   #6
Hybrid G
New Member
0
Rep
21
Posts

Drives: 135i
Join Date: Dec 2019
Location: Toronto

iTrader: (0)

yes well I just bought the car from a dealer that had no clue, i also have the steering wheel with the lights on it..... but it lights up on start up but that is it.
Appreciate 0
      02-21-2020, 08:14 PM   #7
Hybrid G
New Member
0
Rep
21
Posts

Drives: 135i
Join Date: Dec 2019
Location: Toronto

iTrader: (0)

anyone know what that plug is for?
Appreciate 0
      02-21-2020, 10:34 PM   #8
Esteban
Major General
United_States
4157
Rep
6,417
Posts

Drives: 2016 VW GLI SEL
Join Date: Jun 2014
Location: The Golden State

iTrader: (0)

Quote:
Originally Posted by Hybrid G View Post
anyone know what that plug is for?
https://www.1addicts.com/forums/show....php?t=1223338
Appreciate 0
      02-22-2020, 06:17 AM   #9
RJ019
Private
Australia
47
Rep
77
Posts

Drives: 2009 135i Low Mount ST
Join Date: May 2017
Location: ACT

iTrader: (0)

Quote:
Originally Posted by Hybrid G View Post
yes well I just bought the car from a dealer that had no clue, i also have the steering wheel with the lights on it..... but it lights up on start up but that is it.
You need to hold the two steering wheel buttons to turn the steering wheel display and functions on.
Appreciate 0
      02-23-2020, 09:01 PM   #10
Hybrid G
New Member
0
Rep
21
Posts

Drives: 135i
Join Date: Dec 2019
Location: Toronto

iTrader: (0)

Quote:
Originally Posted by RJ019 View Post
You need to hold the two steering wheel buttons to turn the steering wheel display and functions on.
Thanks a lot it works.... the dealership said it did not.
Appreciate 0
Post Reply

Bookmarks

Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off



All times are GMT -5. The time now is 02:55 PM.




1addicts
Powered by vBulletin® Version 3.8.11
Copyright ©2000 - 2020, vBulletin Solutions Inc.
1Addicts.com, BIMMERPOST.com, E90Post.com, F30Post.com, M3Post.com, ZPost.com, 5Post.com, 6Post.com, 7Post.com, XBimmers.com logo and trademark are properties of BIMMERPOST