BMW Garage BMW Meets Register Search Today's Posts Mark Forums Read




 

Post Reply
 
Thread Tools Search this Thread
      11-18-2018, 03:59 PM   #1
dkat
Private
80
Rep
68
Posts

Drives: 2000 BMW Z8 & 2011 1M
Join Date: Dec 2012
Location: New York

iTrader: (0)

ABS Malfunction!

Was just out for a Sunday cruise. At highway speed, ABS Malfunction warning light came on. Had not done any hard braking. The car has just 8,700 miles on it.
Additional warnings on screen show:
Braking/chassis stabilization malfunction!
DBC Malfunction!
Start-off assistance inactive!

Anyone know what went bad? What will the dealer (stealer) charge to make the repair?
Appreciate 0
      11-19-2018, 07:37 AM   #2
dkat
Private
80
Rep
68
Posts

Drives: 2000 BMW Z8 & 2011 1M
Join Date: Dec 2012
Location: New York

iTrader: (0)

Does this particular forum get no traction after 8 years? Should I move question to main forum? It would be hard to believe that this is an isolated incident. Attached are some photos. I can really use some help here
Attached Images
  
Appreciate 0
      11-20-2018, 03:06 AM   #3
Alby_416
Private First Class
Alby_416's Avatar
No_Country
109
Rep
134
Posts

Drives: BMW M2 Coupé (BSM)
Join Date: Aug 2014
Location: IT

iTrader: (0)

Garage List
Happened on my previous 1 series... turned out to be a wheel speed sensor which went bad and caused all those issues you listed.

My advice is to get a scan tool and check which error code the car gives you, you should be able to isolate which sensor went bad
Appreciate 0
      11-20-2018, 03:09 AM   #4
Alby_416
Private First Class
Alby_416's Avatar
No_Country
109
Rep
134
Posts

Drives: BMW M2 Coupé (BSM)
Join Date: Aug 2014
Location: IT

iTrader: (0)

Garage List
PS: there is also a little plastic box in the wheel wells that contains all the connectors for the various wheel sensors...

It may be worth to check inside for any moisture since it's exposed to the elements and see if the connection is solid
Appreciate 0
      11-20-2018, 07:27 AM   #5
dkat
Private
80
Rep
68
Posts

Drives: 2000 BMW Z8 & 2011 1M
Join Date: Dec 2012
Location: New York

iTrader: (0)

Thanks for the info. Hope it is not ABS hydro unit
Appreciate 0
      11-21-2018, 07:24 AM   #6
dkat
Private
80
Rep
68
Posts

Drives: 2000 BMW Z8 & 2011 1M
Join Date: Dec 2012
Location: New York

iTrader: (0)

I made an appointment at the BMW stealer. I am still on the original battery, from what I have been reading, this might be a potential cause for the car to act loopy. Just seems so odd that a car with so few miles has ABS issues.
Since it will be there, We will see what error codes come up after the battery switch. Hoping nothing comes up after battery replacement and at worst a sensor failure. To be continued.....
Appreciate 0
      11-21-2018, 01:57 PM   #7
nachob
Brigadier General
United_States
1516
Rep
3,821
Posts

Drives: 2011 1M, 2003 330i ZHP
Join Date: Apr 2008
Location: California

iTrader: (5)

Quote:
Originally Posted by dkat View Post
I made an appointment at the BMW stealer. I am still on the original battery, from what I have been reading, this might be a potential cause for the car to act loopy. Just seems so odd that a car with so few miles has ABS issues.
Since it will be there, We will see what error codes come up after the battery switch. Hoping nothing comes up after battery replacement and at worst a sensor failure. To be continued.....
ABS sensors can get damaged doing brake jobs or swapping tires etc. If you accidentally tug or damage a wire etc. Despite mileage. Have you done any work recently?
Appreciate 0
      11-21-2018, 02:17 PM   #8
dkat
Private
80
Rep
68
Posts

Drives: 2000 BMW Z8 & 2011 1M
Join Date: Dec 2012
Location: New York

iTrader: (0)

The only work done about 300 miles ago was airbag recall and fluid change.
Appreciate 0
      11-22-2018, 04:17 PM   #9
nachob
Brigadier General
United_States
1516
Rep
3,821
Posts

Drives: 2011 1M, 2003 330i ZHP
Join Date: Apr 2008
Location: California

iTrader: (5)

Quote:
Originally Posted by dkat View Post
The only work done about 300 miles ago was airbag recall and fluid change.
Brake fluid or something else?
Appreciate 0
      11-24-2018, 08:47 AM   #10
dkat
Private
80
Rep
68
Posts

Drives: 2000 BMW Z8 & 2011 1M
Join Date: Dec 2012
Location: New York

iTrader: (0)

brake fluid was changed
Appreciate 0
      11-24-2018, 11:05 AM   #11
nachob
Brigadier General
United_States
1516
Rep
3,821
Posts

Drives: 2011 1M, 2003 330i ZHP
Join Date: Apr 2008
Location: California

iTrader: (5)

Quote:
Originally Posted by dkat View Post
brake fluid was changed
That's what I thought. While bleeding brakes possible they might have pulled abs sensor wire. Unlikely but seems coincidental that they do that work and then you have issue. That is if ABS sensor is the issue. My friend is a BMW independent mechanic and he accidentally damaged ABS sensor on customers car. It could also be some other thing but if someone was working around the wheel speed sensors then ABS goes off shortly thereafter just too coincidental.if the cable to wheel sensor is damaged all you can do is replace it but much less than ABS pump. I'm pretty sure a BMW OBD scanner will tell you if wheel sensor is bad. Mine does.
Appreciate 0
      11-26-2018, 01:43 PM   #12
dkat
Private
80
Rep
68
Posts

Drives: 2000 BMW Z8 & 2011 1M
Join Date: Dec 2012
Location: New York

iTrader: (0)

Dealer just called, rear wheel speed sensor. At least it is not ABS unit.
Appreciate 0
      06-25-2019, 04:30 AM   #13
FSK7
New Member
9
Rep
19
Posts

Drives: BMW 1M
Join Date: Mar 2017
Location: Riyadh, Saudi Arabia

iTrader: (0)

Just got the same exact msgs after changing four tires. haven't scanned it yet but I'm assuming its also the speed sensor and not the abs unit. Would anyone mind sending me the part numbers for the speed sensors.
Appreciate 0
Post Reply

Bookmarks

Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off



All times are GMT -5. The time now is 09:30 AM.




1addicts
Powered by vBulletin® Version 3.8.11
Copyright ©2000 - 2019, vBulletin Solutions Inc.
1Addicts.com, BIMMERPOST.com, E90Post.com, F30Post.com, M3Post.com, ZPost.com, 5Post.com, 6Post.com, 7Post.com, XBimmers.com logo and trademark are properties of BIMMERPOST