BMW 1 Series Coupe Forum / 1 Series Convertible Forum (1M / tii / 135i / 128i / Coupe / Cabrio / Hatchback) (BMW E82 E88 128i 130i 135i)
 





 

Post Reply
 
Thread Tools Search this Thread
      08-20-2019, 03:00 PM   #1
talmadge
New Member
0
Rep
9
Posts

Drives: 135i convertible
Join Date: May 2019
Location: Charlotte

iTrader: (0)

N54 Starting Issues

I have a 2010 135i with 76,000 miles. Intermittently it has been hard to start. What I mean is hit the starter button and it takes a few seconds of turning over before it starts. Unfortunately this has been increasingly the case. What might be causing this? Fuel pump or maybe injectors? Also sometimes after the first start of the day I hear a quick rattle sound. Donít hear it when I start after the car is warm.
Any ideas?
Other than this the car runs great!
FYI I replaced the plugs and coils along with the charge pipe. Running MHD stage 1.
Appreciate 0
Post Reply

Bookmarks

Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off



All times are GMT -5. The time now is 02:26 AM.




1addicts
Powered by vBulletin® Version 3.8.11
Copyright ©2000 - 2019, vBulletin Solutions Inc.
1Addicts.com, BIMMERPOST.com, E90Post.com, F30Post.com, M3Post.com, ZPost.com, 5Post.com, 6Post.com, 7Post.com, XBimmers.com logo and trademark are properties of BIMMERPOST