BMW 1 Series Coupe Forum / 1 Series Convertible Forum (1M / tii / 135i / 128i / Coupe / Cabrio / Hatchback) (BMW E82 E88 128i 130i 135i)
 





 

Post Reply
 
Thread Tools Search this Thread
      12-15-2016, 03:45 PM   #1
TridenTBoy
Second Lieutenant
United_States
103
Rep
277
Posts

Drives: 2013 BMW 135is
Join Date: Nov 2016
Location: San Francisco, CA

iTrader: (0)

Garage List
2013 BMW 135is  [0.00]
Cornering Light Malfunction - What bulb to replace and get?

Hi, I'm a new owner and I've found other threads about this but little with what people actually replaced and what bulb they used. I've got a 135is. I've heard I probably need to get a new bulb to remove this error for good. It's intermittent right now and goes away rather quickly. (Left cornering light malfunction) But I'd rather just solve the problem forever. Which bulb do you suggest to get rid of this and which one would I be replacing? I was on RockAuto and saw too many options for me to make a simple purchase. I really want all the lights to look and project stock/OEM light.

Thanks in advance.

EDIT: Read the whole thread. Turns out there was a mistake along the way.
I have since made a video demonstrating a method to replacing the bulb. This is how it worked for me. YMMV


Last edited by TridenTBoy; 01-15-2018 at 11:29 PM..
Appreciate 0
      12-15-2016, 03:56 PM   #2
MightyMouseTech
Major General
MightyMouseTech's Avatar
3558
Rep
5,579
Posts

Drives: 13 135i 6MT LeMans Blue MSport
Join Date: Feb 2013
Location: Ottawa, Canada

iTrader: (0)

The cornering lights don't really do much. They are the inner lights in the headlight, the ones that look like they could be a high beam. They only come on briefly when you put your signal on, or when you "flash" the highbeams, which does not actually activate the high beams.

Appreciate 1
Dackelone9308.00

      12-15-2016, 04:02 PM   #3
TridenTBoy
Second Lieutenant
United_States
103
Rep
277
Posts

Drives: 2013 BMW 135is
Join Date: Nov 2016
Location: San Francisco, CA

iTrader: (0)

Garage List
2013 BMW 135is  [0.00]
Quote:
Originally Posted by MightyMouseTech View Post
The cornering lights don't really do much. They are the inner lights in the headlight, the ones that look like they could be a high beam. They only come on briefly when you put your signal on, or when you "flash" the highbeams, which does not actually activate the high beams.

Okay, I figured out that much. I'm hoping to figure out which bulb to buy next.

I don't mind if they don't do much... I just want the error gone *forever*.
Appreciate 0
      12-15-2016, 04:29 PM   #4
MightyMouseTech
Major General
MightyMouseTech's Avatar
3558
Rep
5,579
Posts

Drives: 13 135i 6MT LeMans Blue MSport
Join Date: Feb 2013
Location: Ottawa, Canada

iTrader: (0)

Quote:
Originally Posted by TridenTBoy View Post
Okay, I figured out that much. I'm hoping to figure out which bulb to buy next.

I don't mind if they don't do much... I just want the error gone *forever*.
Then code out the bulb check on that bulb.

It is a standard H8, 35W bulb, #1 as seen on realoem.

http://www.realoem.com/bmw/enUS/show...diagId=63_1006
Appreciate 0
      12-15-2016, 05:26 PM   #5
TridenTBoy
Second Lieutenant
United_States
103
Rep
277
Posts

Drives: 2013 BMW 135is
Join Date: Nov 2016
Location: San Francisco, CA

iTrader: (0)

Garage List
2013 BMW 135is  [0.00]
Quote:
Originally Posted by MightyMouseTech View Post
Then code out the bulb check on that bulb.

It is a standard H8, 35W bulb, #1 as seen on realoem.

http://www.realoem.com/bmw/enUS/show...diagId=63_1006
Fantastic, thanks. I totally forgot about RealOEM. I've been using that a lot and totally spaced on it.

Looks like PHILIPS 12360 is the OEM bulb.
Appreciate 0
      12-15-2016, 11:54 PM   #6
Mach1er
Lieutenant
Mach1er's Avatar
75
Rep
524
Posts

Drives: '13 128i
Join Date: Mar 2013
Location: Austin, TX

iTrader: (0)

I've had this error a bunch, on both sides. If you have iDrive, click into the error dialogue and make sure it's actually the left. My top banner error always says left, but when actually looking at the detailed error message in iDrive it has specified the right one.

The service log was a bit unclear which bubs were replaced in each case, but I think it was either the headlight turn signal or the door turn signal in at least one case.

My error popped up the same way yours does, right at start-up and then goes away quickly. In all cases it was actually a burnt out bulb, or at least on the verge of burning out. I was never able to figure out which bulb was dying because they all seemed to be working when tested.
__________________
'13 128i | 6MT | SGM | Black Boston | Black Gloss | Lighting | Premium | Tech | HK | Anti-Theft | [CDV-Delete | Clutch Stop | 30% Pinnacle]
Ordered 2.23 | Production Begin 3.7 | Ends 3.15 | Released to carrier 3.18 | At port 3.19 | Departed 3.23 (K-line to Brunswick) | Arrived 4.7 | Truck 4.12 | Dealer 4.19
Appreciate 0
      12-16-2016, 06:07 AM   #7
Dackelone
European Editor
Dackelone's Avatar
Germany
9308
Rep
22,956
Posts

Drives: N54 e82
Join Date: Feb 2010
Location: Bayern, Germany

iTrader: (1)

CCID error codes...

Quote:
Originally Posted by Mach1er View Post

My error popped up the same way yours does, right at start-up and then goes away quickly. In all cases it was actually a burnt out bulb, or at least on the verge of burning out. I was never able to figure out which bulb was dying because they all seemed to be working when tested.
You can also press and hold the BC button for the CCID error code to tell you which bulb is causing the error code.

http://www.endtuning.com/ccidcodes/


Quote:
Originally Posted by MightyMouseTech View Post
The cornering lights don't really do much. They are the inner lights in the headlight, the ones that look like they could be a high beam. They only come on briefly when you put your signal on, or when you "flash" the highbeams, which does not actually activate the high beams.
Good point! Also... when the car is in reverse... BOTH inner lights will come on.
__________________
Appreciate 1
Mach1er75.00

      12-16-2016, 04:20 PM   #8
TridenTBoy
Second Lieutenant
United_States
103
Rep
277
Posts

Drives: 2013 BMW 135is
Join Date: Nov 2016
Location: San Francisco, CA

iTrader: (0)

Garage List
2013 BMW 135is  [0.00]
Quote:
Originally Posted by Dackelone View Post
You can also press and hold the BC button for the CCID error code to tell you which bulb is causing the error code.

http://www.endtuning.com/ccidcodes/




Good point! Also... when the car is in reverse... BOTH inner lights will come on.
Only today has the code stayed on. Before the error would go away before I could do those steps. Fortunately, I get a replacement bulb tomorrow. I'll see if that gets rid of it. I should've bought 2. It's CC-ID 381.
Appreciate 0
      12-16-2016, 04:53 PM   #9
Mach1er
Lieutenant
Mach1er's Avatar
75
Rep
524
Posts

Drives: '13 128i
Join Date: Mar 2013
Location: Austin, TX

iTrader: (0)

Relevant?
http://www.1addicts.com/forums/showthread.php?t=795084

Good luck!
__________________
'13 128i | 6MT | SGM | Black Boston | Black Gloss | Lighting | Premium | Tech | HK | Anti-Theft | [CDV-Delete | Clutch Stop | 30% Pinnacle]
Ordered 2.23 | Production Begin 3.7 | Ends 3.15 | Released to carrier 3.18 | At port 3.19 | Departed 3.23 (K-line to Brunswick) | Arrived 4.7 | Truck 4.12 | Dealer 4.19
Appreciate 0
      12-16-2016, 06:14 PM   #10
TridenTBoy
Second Lieutenant
United_States
103
Rep
277
Posts

Drives: 2013 BMW 135is
Join Date: Nov 2016
Location: San Francisco, CA

iTrader: (0)

Garage List
2013 BMW 135is  [0.00]
Quote:
Originally Posted by Mach1er View Post
Ugh. That doesn't look promising... I'll check it out. I'm out of warranty, basically. So, replacing the headlight would be some serious $$$$.
Appreciate 0
      12-19-2016, 12:35 AM   #11
TridenTBoy
Second Lieutenant
United_States
103
Rep
277
Posts

Drives: 2013 BMW 135is
Join Date: Nov 2016
Location: San Francisco, CA

iTrader: (0)

Garage List
2013 BMW 135is  [0.00]
Replaced the front right light bulb. Error is still coming up here and there. Same behavior as before. Sometimes it goes away, sometimes it doesn't. I could try replacing the front left but at this point I feel like I'm throwing money down the drain.
Appreciate 0
      12-21-2016, 04:49 PM   #12
TridenTBoy
Second Lieutenant
United_States
103
Rep
277
Posts

Drives: 2013 BMW 135is
Join Date: Nov 2016
Location: San Francisco, CA

iTrader: (0)

Garage List
2013 BMW 135is  [0.00]
Been looking around but don't see anything:

How do you replace the left/drivers side light? The cover is blocked by too many things to just pull it out. I barely managed to get the passenger side. The drivers side is fully blocked. I can imagine the only way to really replace the bulbs is by removing the entire headlamp assembly out of the car. :/

One reason mine is more difficult is that I have a convertible and I think all the videos out there are on coupes. From what I am seeing, there are metal bars in the way of the headlamp covers and I figure these are part of the chassis strengthening. Either that or part of the 135is... Either way, hard knock life.

Last edited by TridenTBoy; 12-21-2016 at 05:05 PM..
Appreciate 0
      04-29-2017, 06:16 PM   #13
TridenTBoy
Second Lieutenant
United_States
103
Rep
277
Posts

Drives: 2013 BMW 135is
Join Date: Nov 2016
Location: San Francisco, CA

iTrader: (0)

Garage List
2013 BMW 135is  [0.00]
Finally replaced the drivers side. Had to remove the bumper and the headlight assembly to change it.

Guess what? Error is still coming up.

F'ing BMW.
Appreciate 0
      04-29-2017, 06:21 PM   #14
Dackelone
European Editor
Dackelone's Avatar
Germany
9308
Rep
22,956
Posts

Drives: N54 e82
Join Date: Feb 2010
Location: Bayern, Germany

iTrader: (1)

Quote:
Originally Posted by TridenTBoy View Post
Finally replaced the drivers side. Had to remove the bumper and the headlight assembly to change it.

Guess what? Error is still coming up.

F'ing BMW.
Did you replace BOTH bulbs? The bulbs should be replaced in pairs to avoid the bulb error out codes.

What did the CCID codes reveal ?


Quote:
Originally Posted by MightyMouseTech View Post
The cornering lights don't really do much. They are the inner lights in the headlight, the ones that look like they could be a high beam. They only come on briefly when you put your signal on, or when you "flash" the highbeams, which does not actually activate the high beams.
I think you might be wrong on this one. When I flash my high beams... the xenon bulbs(outter lights) come on. I'm not sure about the inner lights though.

When the headlights are on, the xenons are on. The highbeam function works via a electronic shutter inside the headlight box/lens.

Dack
__________________
Appreciate 0
      04-29-2017, 06:27 PM   #15
TridenTBoy
Second Lieutenant
United_States
103
Rep
277
Posts

Drives: 2013 BMW 135is
Join Date: Nov 2016
Location: San Francisco, CA

iTrader: (0)

Garage List
2013 BMW 135is  [0.00]
Quote:
Originally Posted by Dackelone View Post
Did you replace BOTH bulbs? The bulbs should be replaced in pairs to avoid the bulb error out codes.

What did the CCID codes reveal ?




I think you might be wrong on this one. When I flash my high beams... the xenon bulbs(outter lights) come on. I'm not sure about the inner lights though.

When the headlights are on, the xenons are on. The highbeam function works via a electronic shutter inside the headlight box/lens.

Dack
Well, I didn't get to do pairs because the driver's side required taking off the bumper and all. So, it's been a few months between bulb changes.

At this point, I want to code out the voltage monitoring but I don't know if I even can because I have a 2013. (Something about encryption or what not?)
Appreciate 1
Dackelone9308.00

      04-30-2017, 11:06 AM   #16
tracer bullet
Lieutenant Colonel
tracer bullet's Avatar
United_States
755
Rep
1,966
Posts

Drives: '11 135i , '15 X3 35i
Join Date: May 2011
Location: Saint Paul, MN

iTrader: (1)

I'd contact the Carly site via email, it can take a few days to get an answer but you very likely will get one. Let them know the details of your car, and the current flash on it from BMW if possible, and see what they have to say.

You might be able to run a trial of the app???
Appreciate 0
      05-26-2017, 03:45 PM   #17
amg6975
Private First Class
amg6975's Avatar
90
Rep
172
Posts

Drives: '12 135, '05 ZHP, '09 fJCW,
Join Date: May 2017
Location: Rochester NY

iTrader: (0)

I just got a 2012 135 and had this same issue, kept getting the CC error but the lights worked most of the time. I took it apart and there was significant corrosion on the bulb carrier, I cleaned it up with some sand paper and it's all good now. I put in new bulbs while I was in there too.

Just an FYI for anyone else, you don't need to take off the bumper and head light, you just have to remove the weatherstrip and the "rail" piece. There's a good DIY on here: http://www.1addicts.com/forums/showthread.php?t=239169
Appreciate 0
      05-26-2017, 03:57 PM   #18
TridenTBoy
Second Lieutenant
United_States
103
Rep
277
Posts

Drives: 2013 BMW 135is
Join Date: Nov 2016
Location: San Francisco, CA

iTrader: (0)

Garage List
2013 BMW 135is  [0.00]
Quote:
Originally Posted by amg6975 View Post
I just got a 2012 135 and had this same issue, kept getting the CC error but the lights worked most of the time. I took it apart and there was significant corrosion on the bulb carrier, I cleaned it up with some sand paper and it's all good now. I put in new bulbs while I was in there too.

Just an FYI for anyone else, you don't need to take off the bumper and head light, you just have to remove the weatherstrip and the "rail" piece. There's a good DIY on here: http://www.1addicts.com/forums/showthread.php?t=239169
That doesn't look like the bulb that I replaced in mine. o_O Did I just change the wrong bulbs?!

Ugh. I replaced #1 in this image: http://www.realoem.com/bmw/enUS/show...diagId=63_1006

Should I have replaced #12?
Appreciate 0
      05-26-2017, 04:19 PM   #19
MightyMouseTech
Major General
MightyMouseTech's Avatar
3558
Rep
5,579
Posts

Drives: 13 135i 6MT LeMans Blue MSport
Join Date: Feb 2013
Location: Ottawa, Canada

iTrader: (0)

Quote:
Originally Posted by TridenTBoy View Post
That doesn't look like the bulb that I replaced in mine. o_O Did I just change the wrong bulbs?!

Ugh. I replaced #1 in this image: http://www.realoem.com/bmw/enUS/show...diagId=63_1006

Should I have replaced #12?
Oh shit. It does look like it is #12.



When you are actually looking at the headlight, they are opposite of that. The "halo" light is more towards the middle.
Appreciate 0
      05-26-2017, 04:30 PM   #20
TridenTBoy
Second Lieutenant
United_States
103
Rep
277
Posts

Drives: 2013 BMW 135is
Join Date: Nov 2016
Location: San Francisco, CA

iTrader: (0)

Garage List
2013 BMW 135is  [0.00]
Quote:
Originally Posted by MightyMouseTech View Post
Oh shit. It does look like it is #12.



When you are actually looking at the headlight, they are opposite of that. The "halo" light is more towards the middle.


Wasted a bunch of time and $20+ on the wrong lights. Sigh!

Well, at least, they're new... but now I'm looking at getting the LUX H8 V5 adjustable anyway because I don't like the orange halo. It makes the car look so dated.

Now I know how to replace them at least...
Appreciate 0
      05-26-2017, 04:31 PM   #21
MightyMouseTech
Major General
MightyMouseTech's Avatar
3558
Rep
5,579
Posts

Drives: 13 135i 6MT LeMans Blue MSport
Join Date: Feb 2013
Location: Ottawa, Canada

iTrader: (0)

Quote:
Originally Posted by TridenTBoy View Post


Wasted a bunch of time and $20+ on the wrong lights. Sigh!

Well, at least, they're new... but now I'm looking at getting the LUX H8 V5 adjustable anyway because I don't like the orange halo. It makes the car look so dated.

Now I know how to replace them at least...
I am really sorry.
Appreciate 0
      05-27-2017, 01:46 AM   #22
TridenTBoy
Second Lieutenant
United_States
103
Rep
277
Posts

Drives: 2013 BMW 135is
Join Date: Nov 2016
Location: San Francisco, CA

iTrader: (0)

Garage List
2013 BMW 135is  [0.00]
Went to auto parts store. Bought a sylvania basic h3 bulb for $6 and replaced the left. Didn't solve the problem. Took the old left and put it in the right. That seemed to solve it so far. Tomorrow will tell...

Pro-tip: be careful with that weather stripping holding plastic and the strip itself. They're both very fragile and break and tear easily. Some of the plastic clips the plastic thing slides over broke when reattaching. All well, I can just baking soda and Super glue them back to working position. Had to do that for other plastic bits here...
Appreciate 0
Post Reply

Bookmarks

Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off



All times are GMT -5. The time now is 11:35 AM.




1addicts
Powered by vBulletin® Version 3.8.11
Copyright ©2000 - 2020, vBulletin Solutions Inc.
1Addicts.com, BIMMERPOST.com, E90Post.com, F30Post.com, M3Post.com, ZPost.com, 5Post.com, 6Post.com, 7Post.com, XBimmers.com logo and trademark are properties of BIMMERPOST